lua: Fixed some cross-platform issues for PPC (and probably other architectures)

SVN-Revision: 11608
v19.07.3_mercusys_ac12_duma
Steven Barth 16 years ago
parent e2a5ae841b
commit 76215afdec

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@ -96,7 +96,7 @@ define Build/Compile
AR="$(TARGET_CROSS)ar rcu" \
RANLIB="$(TARGET_CROSS)ranlib" \
INSTALL_ROOT=/usr \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -fPIC" \
MYLDFLAGS="$(TARGET_LDFLAGS)" \
PKG_VERSION=$(PKG_VERSION) \
all linux

@ -0,0 +1,13 @@
Index: lua-5.1.3/src/lua.h
===================================================================
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
@@ -79,7 +79,7 @@
* not acceptable for 5.1, maybe 5.2 onwards?
* 9: greater than existing (5.1) type values.
*/
-#define LUA_TINT (-2)
+#define LUA_TINT 9
#define LUA_TNIL 0
#define LUA_TBOOLEAN 1

@ -0,0 +1,13 @@
Index: lua-5.1.3/src/lua.h
===================================================================
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
@@ -79,7 +79,7 @@
* not acceptable for 5.1, maybe 5.2 onwards?
* 9: greater than existing (5.1) type values.
*/
-#define LUA_TINT (-2)
+#define LUA_TINT 9
#define LUA_TNIL 0
#define LUA_TBOOLEAN 1
Loading…
Cancel
Save