Add keynote, dependency to isakmpd

SVN-Revision: 4740
v19.07.3_mercusys_ac12_duma
Florian Fainelli 18 years ago
parent 73242900e3
commit 760f4a9690

@ -0,0 +1,59 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: Makefile 4619 2006-08-22 09:50:02Z florian $
include $(TOPDIR)/rules.mk
PKG_NAME:=keynote
PKG_VERSION:=2.3
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/keynote
PKG_MD5SUM:=b569066ac2ba1356c2112b118a7d74d0
PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
define Package/keynote
SECTION:=base
CATEGORY:=Network
DEPENDS:=@LINUX_2_6
TITLE:=IPsec management tools
DESCRIPTION:=IPsec management tools
URL:=http://keynote.sourceforge.net/
endef
define Build/Configure
$(call Build/Configure/Default,--enable-static --enable-shared,LDFLAGS="-L$(STAGING_DIR)/usr/lib")
endef
define Build/Compile
$(call Build/Compile/Default,$(TARGET_CONFIGURE_OPTS) \
CFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
all)
endef
define Package/keynote/install
install -d -m0755 $(1)/usr/sbin
$(CP) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
endef
define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/*.h $(STAGING_DIR)/usr/include/
$(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
endef
define Build/UninstallDev
rm -rf $(STAGING_DIR)/usr/include/{assertion,getopt,header,keynote,signature}.h
endef
$(eval $(call BuildPackage,keynote))

@ -0,0 +1,327 @@
diff -ru keynote-2.3/configure.in keynote-2.3.new/configure.in
--- keynote-2.3/configure.in 2000-09-27 01:16:28.000000000 +0200
+++ keynote-2.3.new/configure.in 2004-01-16 11:34:03.991537404 +0100
@@ -21,19 +21,13 @@
AC_PATH_PROG(ECHO, echo, /bin/echo)
AC_PATH_PROG(SED, sed, /usr/bin/sed)
-dnl Checks for libraries.
-LIBS="-L/usr/lib -L/usr/local/lib -L/usr/ssl/lib -L/usr/openssl/lib\
- -L/usr/local/ssl/lib -L/usr/local/openssl/lib -L/usr/pkg/lib -L/pkg/lib"
-
AC_CHECK_LIB(m, floor, LIBS="$LIBS -lm")
AC_CHECK_LIB(rsaref, RSAPrivateDecrypt, LIBS="$LIBS -lrsaref")
AC_CHECK_LIB(crypto, i2a_ASN1_STRING, LIBS="$LIBS -lcrypto")
AC_CHECK_LIB(RSAglue, RSA_ref_private_encrypt, LIBS="$LIBS -lRSAglue")
dnl Checks for header files.
-CPPFLAGS="-I/usr/include -I/usr/local/include -I/usr/ssl/include\
- -I/usr/local/ssl/include -I/usr/openssl/include -I/usr/pkg/include\
- -I/usr/local/openssl/include -I/pkg/include"
+CPPFLAGS="-I/usr/include/openssl"
AC_HEADER_STDC
AC_HEADER_TIME
diff -ru keynote-2.3/keynote-keygen.c keynote-2.3.new/keynote-keygen.c
--- keynote-2.3/keynote-keygen.c 2000-09-27 02:09:13.000000000 +0200
+++ keynote-2.3.new/keynote-keygen.c 2004-01-16 11:32:06.652242269 +0100
@@ -161,7 +161,7 @@
if (strlen(algname) + 2 > prlen)
{
fprintf(stderr, "Parameter ``print-length'' should be larger "
- "than the length of AlgorithmName (%d)\n", strlen(algname));
+ "than the length of AlgorithmName (%lu)\n", strlen(algname));
exit(-1);
}
diff -ru keynote-2.3/keynote.l keynote-2.3.new/keynote.l
--- keynote-2.3/keynote.l 2000-08-11 22:49:13.000000000 +0200
+++ keynote-2.3.new/keynote.l 2004-01-16 11:17:29.910430978 +0100
@@ -61,7 +61,8 @@ struct lex_list
static struct lex_list *keynote_lex_list = (struct lex_list *) NULL;
static int keynote_max_lex_list = 32;
static int keynote_lex_counter = 0;
-static int first_tok = 0;
+extern int first_tok;
+int first_tok = 0;
%}
digit [0-9]
specnumber [1-9][0-9]*
@@ -766,7 +767,7 @@
if (0)
{
yyunput(0, NULL);
- yy_flex_realloc(0, NULL);
+ yy_flex_realloc(NULL, 0);
}
return en;
diff -ru keynote-2.3/keynote-ver.l keynote-2.3.new/keynote-ver.l
--- keynote-2.3/keynote-ver.l 2000-08-11 22:49:13.000000000 +0200
+++ keynote-2.3.new/keynote-ver.l 2004-01-16 11:31:14.667107044 +0100
@@ -267,7 +267,7 @@
if (0)
{
yyunput(0, NULL);
- yy_flex_realloc(0, NULL);
+ yy_flex_realloc(NULL, 0);
}
}
diff -ru keynote-2.3/keynote-ver.y keynote-2.3.new/keynote-ver.y
--- keynote-2.3/keynote-ver.y 1999-10-12 00:34:29.000000000 +0200
+++ keynote-2.3.new/keynote-ver.y 2004-01-16 11:07:19.709634736 +0100
@@ -49,7 +49,7 @@
return keynote_errno;
free($1);
}
-
+ ;
expr: VSTRING EQ STRING { int i = kn_add_action(sessid, $1, $3, 0);
if (i != 0)
@@ -64,6 +64,7 @@
free($1);
free($3);
} expr
+ ;
%%
void
kverror(char *s)
diff -ru keynote-2.3/keynote.y keynote-2.3.new/keynote.y
--- keynote-2.3/keynote.y 2000-06-14 08:28:23.000000000 +0200
+++ keynote-2.3.new/keynote.y 2004-01-16 11:14:55.365898229 +0100
@@ -73,8 +73,7 @@
%}
%%
-grammarswitch: LOCINI { keynote_exceptionflag = keynote_donteval = 0; }
- localinit
+grammarswitch: LOCINI { keynote_exceptionflag = keynote_donteval = 0; } localinit
| ACTSTR { keynote_exceptionflag = keynote_donteval = 0; } program
| KEYPRE { keynote_exceptionflag = keynote_donteval = 0; }
keypredicate
@@ -91,17 +90,17 @@
STRING { keynote_lex_remove($3);
keynote_privkey = $3;
}
-
+ ;
keypredicate: /* Nothing */ { keynote_returnvalue = 0;
return 0;
}
| notemptykeypredicate { keynote_returnvalue = $1;
return 0;
}
-
+ ;
notemptykeypredicate: key { $$ = $1; }
| keyexp { $$ = $1; }
-
+ ;
keyexp: notemptykeypredicate AND { if (($1 == 0) && !keynote_justrecord)
keynote_donteval = 1;
} notemptykeypredicate
@@ -138,7 +137,7 @@
else
$$ = 0;
} /* K-th */
-
+ ;
keylist: key
{ /* Don't do anything if we're just recording */
if (!keynote_justrecord && !keynote_donteval)
@@ -155,7 +154,7 @@
keylistcount++;
}
-
+ ;
key: str {
if (keynote_donteval)
$$ = 0;
@@ -193,10 +192,10 @@
}
}
}
-
+ ;
localinit: /* Nothing */
| localconstants
-
+ ;
localconstants: VARIABLE EQQ STRING
{
int i;
@@ -265,12 +264,12 @@
if (i != RESULT_TRUE)
return -1;
} localconstants
-
+ ;
program: prog {
keynote_returnvalue = $1;
return 0;
}
-
+ ;
prog: /* Nada */ { $$ = 0; }
| notemptyprog {
/*
@@ -285,7 +284,7 @@
else
$$ = $4;
}
-
+ ;
notemptyprog: expr HINT afterhint
{
if (checkexception($1))
@@ -300,7 +299,7 @@
else
$$ = 0;
}
-
+ ;
afterhint: str { if (keynote_exceptionflag || keynote_donteval)
$$ = 0;
else
@@ -315,7 +314,7 @@
}
}
| OPENBLOCK prog CLOSEBLOCK { $$ = $2; }
-
+ ;
expr: OPENPAREN expr CLOSEPAREN { $$ = $2; }
| expr AND { if ($1 == 0)
@@ -334,19 +333,19 @@
| stringexp { $$ = $1; }
| TRUE { $$ = 1; }
| FALSE { $$ = 0; }
-
+ ;
numexp: numex LT numex { $$ = $1 < $3; }
| numex GT numex { $$ = $1 > $3; }
| numex EQ numex { $$ = $1 == $3; }
| numex LE numex { $$ = $1 <= $3; }
| numex GE numex { $$ = $1 >= $3; }
| numex NE numex { $$ = $1 != $3; }
-
+ ;
floatexp: floatex LT floatex { $$ = $1 < $3; }
| floatex GT floatex { $$ = $1 > $3; }
| floatex LE floatex { $$ = $1 <= $3; }
| floatex GE floatex { $$ = $1 >= $3; }
-
+ ;
numex: numex PLUS numex { $$ = $1 + $3; }
| numex MINUS numex { $$ = $1 - $3; }
| numex MULT numex { $$ = $1 * $3; }
@@ -384,7 +383,7 @@
free($2);
}
}
-
+ ;
floatex: floatex PLUS floatex { $$ = ($1 + $3); }
| floatex MINUS floatex { $$ = ($1 - $3); }
| floatex MULT floatex { $$ = ($1 * $3); }
@@ -418,7 +417,7 @@
free($2);
}
}
-
+ ;
stringexp: str EQ str {
if (keynote_exceptionflag || keynote_donteval)
$$ = 0;
@@ -529,9 +528,9 @@
if (i == 0)
{
#if !defined(HAVE_SNPRINTF)
- sprintf(grp, "%d", preg.re_nsub);
+ sprintf(grp, "%d", (int)preg.re_nsub);
#else /* !HAVE_SNPRINTF */
- snprintf(grp, 3, "%d", preg.re_nsub);
+ snprintf(grp, 3, "%d", (int)preg.re_nsub);
#endif /* !HAVE_SNPRINTF */
if (keynote_env_add("_0", grp, &keynote_temp_list,
1, 0) != RESULT_TRUE)
@@ -579,7 +578,7 @@
}
}
}
-
+ ;
str: str DOTT str { if (keynote_exceptionflag || keynote_donteval)
$$ = (char *) NULL;
else
@@ -605,7 +604,7 @@
}
}
| strnotconcat { $$ = $1; }
-
+ ;
strnotconcat: STRING { $$ = $1; }
| OPENPAREN str CLOSEPAREN { $$ = $2; }
| VARIABLE { if (keynote_exceptionflag || keynote_donteval)
@@ -660,6 +659,7 @@
return -1;
}
}
+ ;
%%
/*
diff -ru keynote-2.3/Makefile.in keynote-2.3.new/Makefile.in
--- keynote-2.3/Makefile.in 2000-09-27 01:16:27.000000000 +0200
+++ keynote-2.3.new/Makefile.in 2004-01-16 11:35:38.841528129 +0100
@@ -41,7 +41,7 @@
YACCFLAGS = -d -p kn -b k
LEXFLAGS2 = -Pkv -s -i
LEXFLAGS = -Cr -Pkn -s -i
-CFLAGS = -O2 -Wall # -g
+CFLAGS = -O2 -Wall -fno-strict-aliasing # -g
RMFLAGS2 = -rf
RMFLAGS = -f
NROFFFLAGS = -mandoc
diff -ru keynote-2.3/signature.c keynote-2.3.new/signature.c
--- keynote-2.3/signature.c 1999-10-12 00:34:31.000000000 +0200
+++ keynote-2.3.new/signature.c 2004-01-16 11:30:48.062084986 +0100
@@ -515,7 +515,7 @@
kk = dc->dec_key;
if (keytype == KEYNOTE_PRIVATE_KEY)
{
- if (d2i_DSAPrivateKey((DSA **) &kk, &decoded, len) == (DSA *) NULL)
+ if (d2i_DSAPrivateKey((DSA **) &kk, (const unsigned char **) &decoded, len) == (DSA *) NULL)
{
if (ptr != (unsigned char *) NULL)
free(ptr);
@@ -526,7 +526,7 @@
}
else
{
- if (d2i_DSAPublicKey((DSA **) &kk, &decoded, len) == (DSA *) NULL)
+ if (d2i_DSAPublicKey((DSA **) &kk, (const unsigned char **) &decoded, len) == (DSA *) NULL)
{
if (ptr != (unsigned char *) NULL)
free(ptr);
@@ -556,7 +556,7 @@
kk = dc->dec_key;
if (keytype == KEYNOTE_PRIVATE_KEY)
{
- if (d2i_RSAPrivateKey((RSA **) &kk, &decoded, len) == (RSA *) NULL)
+ if (d2i_RSAPrivateKey((RSA **) &kk, (const unsigned char **) &decoded, len) == (RSA *) NULL)
{
if (ptr != (unsigned char *) NULL)
free(ptr);
@@ -567,7 +567,7 @@
}
else
{
- if (d2i_RSAPublicKey((RSA **) &kk, &decoded, len) == (RSA *) NULL)
+ if (d2i_RSAPublicKey((RSA **) &kk, (const unsigned char **) &decoded, len) == (RSA *) NULL)
{
if (ptr != (unsigned char *) NULL)
free(ptr);

@ -0,0 +1,586 @@
diff -urN keynote-2.3/configure keynote-2.3.new/configure
--- keynote-2.3/configure 2000-09-27 01:16:28.000000000 +0200
+++ keynote-2.3.new/configure 2006-09-01 19:16:35.000000000 +0200
@@ -889,52 +889,10 @@
done
test -n "$YACC" || YACC="yacc"
-for ac_prog in openssl ssleay
-do
-# Extract the first word of "$ac_prog", so it can be a program name with args.
-set dummy $ac_prog; ac_word=$2
-echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:898: checking for $ac_word" >&5
-if eval "test \"`echo '$''{'ac_cv_path_SSLEAY'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- case "$SSLEAY" in
- /*)
- ac_cv_path_SSLEAY="$SSLEAY" # Let the user override the test with a path.
- ;;
- ?:/*)
- ac_cv_path_SSLEAY="$SSLEAY" # Let the user override the test with a dos path.
- ;;
- *)
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
- ac_dummy="\
- $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin"
- for ac_dir in $ac_dummy; do
- test -z "$ac_dir" && ac_dir=.
- if test -f $ac_dir/$ac_word; then
- ac_cv_path_SSLEAY="$ac_dir/$ac_word"
- break
- fi
- done
- IFS="$ac_save_ifs"
- ;;
-esac
-fi
-SSLEAY="$ac_cv_path_SSLEAY"
-if test -n "$SSLEAY"; then
- echo "$ac_t""$SSLEAY" 1>&6
-else
- echo "$ac_t""no" 1>&6
-fi
-
-test -n "$SSLEAY" && break
-done
-test -n "$SSLEAY" || SSLEAY="/usr/local/bin/ssleay"
-
# Extract the first word of "rm", so it can be a program name with args.
set dummy rm; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:938: checking for $ac_word" >&5
+echo "configure:896: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_RM'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -970,7 +928,7 @@
# Extract the first word of "ar", so it can be a program name with args.
set dummy ar; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:974: checking for $ac_word" >&5
+echo "configure:932: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_AR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1006,7 +964,7 @@
# Extract the first word of "nroff", so it can be a program name with args.
set dummy nroff; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1010: checking for $ac_word" >&5
+echo "configure:968: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_NROFF'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1042,7 +1000,7 @@
# Extract the first word of "tar", so it can be a program name with args.
set dummy tar; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1046: checking for $ac_word" >&5
+echo "configure:1004: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_TAR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1078,7 +1036,7 @@
# Extract the first word of "true", so it can be a program name with args.
set dummy true; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1082: checking for $ac_word" >&5
+echo "configure:1040: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_TRUE'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1114,7 +1072,7 @@
# Extract the first word of "mkdir", so it can be a program name with args.
set dummy mkdir; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1118: checking for $ac_word" >&5
+echo "configure:1076: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_MKDIR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1150,7 +1108,7 @@
# Extract the first word of "tr", so it can be a program name with args.
set dummy tr; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1154: checking for $ac_word" >&5
+echo "configure:1112: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_TR'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1186,7 +1144,7 @@
# Extract the first word of "echo", so it can be a program name with args.
set dummy echo; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1190: checking for $ac_word" >&5
+echo "configure:1148: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_ECHO'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1222,7 +1180,7 @@
# Extract the first word of "sed", so it can be a program name with args.
set dummy sed; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
-echo "configure:1226: checking for $ac_word" >&5
+echo "configure:1184: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_SED'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1256,11 +1214,8 @@
fi
-LIBS="-L/usr/lib -L/usr/local/lib -L/usr/ssl/lib -L/usr/openssl/lib\
- -L/usr/local/ssl/lib -L/usr/local/openssl/lib -L/usr/pkg/lib -L/pkg/lib"
-
echo $ac_n "checking for floor in -lm""... $ac_c" 1>&6
-echo "configure:1264: checking for floor in -lm" >&5
+echo "configure:1219: checking for floor in -lm" >&5
ac_lib_var=`echo m'_'floor | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1268,7 +1223,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lm $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1272 "configure"
+#line 1227 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1279,7 +1234,7 @@
floor()
; return 0; }
EOF
-if { (eval echo configure:1283: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1238: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1300,7 +1255,7 @@
fi
echo $ac_n "checking for RSAPrivateDecrypt in -lrsaref""... $ac_c" 1>&6
-echo "configure:1304: checking for RSAPrivateDecrypt in -lrsaref" >&5
+echo "configure:1259: checking for RSAPrivateDecrypt in -lrsaref" >&5
ac_lib_var=`echo rsaref'_'RSAPrivateDecrypt | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1308,7 +1263,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lrsaref $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1312 "configure"
+#line 1267 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1319,7 +1274,7 @@
RSAPrivateDecrypt()
; return 0; }
EOF
-if { (eval echo configure:1323: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1278: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1340,7 +1295,7 @@
fi
echo $ac_n "checking for i2a_ASN1_STRING in -lcrypto""... $ac_c" 1>&6
-echo "configure:1344: checking for i2a_ASN1_STRING in -lcrypto" >&5
+echo "configure:1299: checking for i2a_ASN1_STRING in -lcrypto" >&5
ac_lib_var=`echo crypto'_'i2a_ASN1_STRING | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1348,7 +1303,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lcrypto $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1352 "configure"
+#line 1307 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1359,7 +1314,7 @@
i2a_ASN1_STRING()
; return 0; }
EOF
-if { (eval echo configure:1363: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1318: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1380,7 +1335,7 @@
fi
echo $ac_n "checking for RSA_ref_private_encrypt in -lRSAglue""... $ac_c" 1>&6
-echo "configure:1384: checking for RSA_ref_private_encrypt in -lRSAglue" >&5
+echo "configure:1339: checking for RSA_ref_private_encrypt in -lRSAglue" >&5
ac_lib_var=`echo RSAglue'_'RSA_ref_private_encrypt | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1388,7 +1343,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lRSAglue $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1392 "configure"
+#line 1347 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1399,7 +1354,7 @@
RSA_ref_private_encrypt()
; return 0; }
EOF
-if { (eval echo configure:1403: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1358: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1420,12 +1375,9 @@
fi
-CPPFLAGS="-I/usr/include -I/usr/local/include -I/usr/ssl/include\
- -I/usr/local/ssl/include -I/usr/openssl/include -I/usr/pkg/include\
- -I/usr/local/openssl/include -I/pkg/include"
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
-echo "configure:1429: checking how to run the C preprocessor" >&5
+echo "configure:1381: checking how to run the C preprocessor" >&5
# On Suns, sometimes $CPP names a directory.
if test -n "$CPP" && test -d "$CPP"; then
CPP=
@@ -1440,13 +1392,13 @@
# On the NeXT, cc -E runs the code through the compiler's parser,
# not just through cpp.
cat > conftest.$ac_ext <<EOF
-#line 1444 "configure"
+#line 1396 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1450: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1402: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
:
@@ -1457,13 +1409,13 @@
rm -rf conftest*
CPP="${CC-cc} -E -traditional-cpp"
cat > conftest.$ac_ext <<EOF
-#line 1461 "configure"
+#line 1413 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1467: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1419: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
:
@@ -1474,13 +1426,13 @@
rm -rf conftest*
CPP="${CC-cc} -nologo -E"
cat > conftest.$ac_ext <<EOF
-#line 1478 "configure"
+#line 1430 "configure"
#include "confdefs.h"
#include <assert.h>
Syntax Error
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1484: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1436: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
:
@@ -1505,12 +1457,12 @@
echo "$ac_t""$CPP" 1>&6
echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6
-echo "configure:1509: checking for ANSI C header files" >&5
+echo "configure:1461: checking for ANSI C header files" >&5
if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1514 "configure"
+#line 1466 "configure"
#include "confdefs.h"
#include <stdlib.h>
#include <stdarg.h>
@@ -1518,7 +1470,7 @@
#include <float.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1522: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1474: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1535,7 +1487,7 @@
if test $ac_cv_header_stdc = yes; then
# SunOS 4.x string.h does not declare mem*, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1539 "configure"
+#line 1491 "configure"
#include "confdefs.h"
#include <string.h>
EOF
@@ -1553,7 +1505,7 @@
if test $ac_cv_header_stdc = yes; then
# ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1557 "configure"
+#line 1509 "configure"
#include "confdefs.h"
#include <stdlib.h>
EOF
@@ -1574,7 +1526,7 @@
:
else
cat > conftest.$ac_ext <<EOF
-#line 1578 "configure"
+#line 1530 "configure"
#include "confdefs.h"
#include <ctype.h>
#define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
@@ -1585,7 +1537,7 @@
exit (0); }
EOF
-if { (eval echo configure:1589: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1541: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
:
else
@@ -1609,12 +1561,12 @@
fi
echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6
-echo "configure:1613: checking whether time.h and sys/time.h may both be included" >&5
+echo "configure:1565: checking whether time.h and sys/time.h may both be included" >&5
if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1618 "configure"
+#line 1570 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/time.h>
@@ -1623,7 +1575,7 @@
struct tm *tp;
; return 0; }
EOF
-if { (eval echo configure:1627: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1579: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_header_time=yes
else
@@ -1647,17 +1599,17 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:1651: checking for $ac_hdr" >&5
+echo "configure:1603: checking for $ac_hdr" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1656 "configure"
+#line 1608 "configure"
#include "confdefs.h"
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1661: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1613: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1687,17 +1639,17 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:1691: checking for $ac_hdr" >&5
+echo "configure:1643: checking for $ac_hdr" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1696 "configure"
+#line 1648 "configure"
#include "confdefs.h"
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1701: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1653: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1726,12 +1678,12 @@
echo $ac_n "checking for working const""... $ac_c" 1>&6
-echo "configure:1730: checking for working const" >&5
+echo "configure:1682: checking for working const" >&5
if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1735 "configure"
+#line 1687 "configure"
#include "confdefs.h"
int main() {
@@ -1780,7 +1732,7 @@
; return 0; }
EOF
-if { (eval echo configure:1784: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1736: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_c_const=yes
else
@@ -1801,12 +1753,12 @@
fi
echo $ac_n "checking for u_int""... $ac_c" 1>&6
-echo "configure:1805: checking for u_int" >&5
+echo "configure:1757: checking for u_int" >&5
if eval "test \"`echo '$''{'ac_cv_type_u_int'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1810 "configure"
+#line 1762 "configure"
#include "confdefs.h"
#include <sys/types.h>
#if STDC_HEADERS
@@ -1834,12 +1786,12 @@
fi
echo $ac_n "checking for u_char""... $ac_c" 1>&6
-echo "configure:1838: checking for u_char" >&5
+echo "configure:1790: checking for u_char" >&5
if eval "test \"`echo '$''{'ac_cv_type_u_char'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1843 "configure"
+#line 1795 "configure"
#include "confdefs.h"
#include <sys/types.h>
#if STDC_HEADERS
@@ -1870,12 +1822,12 @@
for ac_func in regcomp open close read _open _close _read strchr memcpy
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:1874: checking for $ac_func" >&5
+echo "configure:1826: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1879 "configure"
+#line 1831 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -1898,7 +1850,7 @@
; return 0; }
EOF
-if { (eval echo configure:1902: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1854: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -1925,12 +1877,12 @@
for ac_func in strcasecmp strncasecmp stricmp strnicmp snprintf __b64_ntop
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:1929: checking for $ac_func" >&5
+echo "configure:1881: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1934 "configure"
+#line 1886 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -1953,7 +1905,7 @@
; return 0; }
EOF
-if { (eval echo configure:1957: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1909: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -1980,12 +1932,12 @@
for ac_func in getopt
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:1984: checking for $ac_func" >&5
+echo "configure:1936: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1989 "configure"
+#line 1941 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2008,7 +1960,7 @@
; return 0; }
EOF
-if { (eval echo configure:2012: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1964: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -2172,7 +2124,6 @@
s%@CC@%$CC%g
s%@RANLIB@%$RANLIB%g
s%@YACC@%$YACC%g
-s%@SSLEAY@%$SSLEAY%g
s%@RM@%$RM%g
s%@AR@%$AR%g
s%@NROFF@%$NROFF%g
diff -urN keynote-2.3/configure.in keynote-2.3.new/configure.in
--- keynote-2.3/configure.in 2006-09-01 19:08:13.000000000 +0200
+++ keynote-2.3.new/configure.in 2006-09-01 19:16:05.000000000 +0200
@@ -9,8 +9,8 @@
AC_PROG_CC
AC_PROG_RANLIB
AC_PROG_YACC
-AC_PATH_PROGS(SSLEAY, openssl ssleay, /usr/local/bin/ssleay, \
- $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin)
+dnl AC_PATH_PROGS(SSLEAY, openssl ssleay, /usr/local/bin/ssleay, \
+dnl $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin)
AC_PATH_PROG(RM, rm, /bin/rm)
AC_PATH_PROG(AR, ar, /usr/bin/ar)
AC_PATH_PROG(NROFF, nroff, /usr/bin/nroff)
@@ -27,7 +27,7 @@
AC_CHECK_LIB(RSAglue, RSA_ref_private_encrypt, LIBS="$LIBS -lRSAglue")
dnl Checks for header files.
-CPPFLAGS="-I/usr/include/openssl"
+dnl CPPFLAGS="-I/usr/include/openssl"
AC_HEADER_STDC
AC_HEADER_TIME
Loading…
Cancel
Save