Revert "[tools] mklibs: upgrade to 0.1.37"

It breaks on trying to find ldso

SVN-Revision: 36849
v19.07.3_mercusys_ac12_duma
Felix Fietkau 11 years ago
parent 5bb2e8030d
commit 6f0f50b532

@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mklibs
PKG_VERSION:=0.1.37
PKG_VERSION:=0.1.35
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
PKG_MD5SUM:=099cc99d51f09ea51e58a56e62a46af7
PKG_MD5SUM:=3d2a4bd0bbf5ba964b0a1ecdafd1ea9a
HOST_FIXUP:=autoreconf

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -522,7 +522,7 @@
@@ -524,7 +524,7 @@ while 1:
# No progress in last pass. Verify all remaining symbols are weak.
for name in unresolved:
if not needed_symbols[name].weak:
@ -9,7 +9,7 @@
break
previous_pass_unresolved = unresolved
@@ -557,7 +557,7 @@
@@ -559,7 +559,7 @@ while 1:
for name in needed_symbols:
if not name in symbol_provider:
if not needed_symbols[name].weak:

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -461,7 +461,7 @@
@@ -463,7 +463,7 @@ while 1:
passnr = passnr + 1
# Gather all already reduced libraries and treat them as objects as well
small_libs = []
@ -9,7 +9,7 @@
obj = dest_path + "/" + lib
small_libs.append(obj)
inode = os.stat(obj)[ST_INO]
@@ -577,12 +577,7 @@
@@ -579,12 +579,7 @@ while 1:
if not so_file:
sys.exit("File not found:" + library)
pic_file = find_pic(library)
@ -23,7 +23,7 @@
# we have a pic file, recompile
debug(DEBUG_SPAM, "extracting from:", pic_file, "so_file:", so_file)
soname = extract_soname(so_file)
@@ -625,22 +620,14 @@
@@ -627,22 +622,14 @@ while 1:
cmd.append(library_depends_gcc_libnames(so_file))
command(target + "gcc", *cmd)

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -106,14 +106,14 @@
@@ -106,14 +106,14 @@ def library_depends(obj):
# Return a list of libraries the passed objects depend on. The
# libraries are in "-lfoo" format suitable for passing to gcc.
@ -17,7 +17,7 @@
if match.group('ld'):
ret.append(find_lib(match.group(0)))
elif match.group('lib'):
@@ -617,7 +617,7 @@
@@ -619,7 +619,7 @@ while 1:
cmd.extend(extra_flags)
cmd.append("-lgcc")
cmd.extend(["-L%s" % a for a in [dest_path] + [sysroot + b for b in lib_path if sysroot == "" or b not in ("/" + libdir + "/", "/usr/" + libdir + "/")]])

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -529,7 +529,6 @@
@@ -531,7 +531,6 @@ while 1:
library_symbols = {}
library_symbols_used = {}
@ -8,7 +8,7 @@
# WORKAROUND: Always add libgcc on old-abi arm
header = elf_header(find_lib(libraries.copy().pop()))
@@ -547,20 +546,13 @@
@@ -549,20 +548,13 @@ while 1:
library_symbols_used[library] = set()
for symbol in symbols:
for name in symbol.base_names():

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -593,6 +593,11 @@
@@ -595,6 +595,11 @@ while 1:
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")
symbols.add(ProvidedSymbol('__dso_handle', None, None, True))

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -605,7 +605,7 @@
@@ -607,7 +607,7 @@ while 1:
# compile in only used symbols
cmd = []
cmd.extend(gcc_options)

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -113,11 +113,8 @@
@@ -113,11 +113,8 @@ def library_depends_gcc_libnames(obj, so
ret = []
for i in libs:
match = re.match("^(((?P<ld>ld\S*)|(lib(?P<lib>\S+))))\.so.*$", i)
@ -14,7 +14,7 @@
return ' '.join(ret)
class Symbol(object):
@@ -582,6 +579,7 @@
@@ -584,6 +581,7 @@ while 1:
extra_flags = []
extra_pre_obj = []
extra_post_obj = []
@ -22,7 +22,7 @@
symbols.update(library_symbols_used[library])
@@ -612,9 +610,10 @@
@@ -614,9 +612,10 @@ while 1:
cmd.append(pic_file)
cmd.extend(extra_post_obj)
cmd.extend(extra_flags)

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -162,9 +162,10 @@
@@ -162,9 +162,10 @@ def undefined_symbols(obj):
return result
class ProvidedSymbol(Symbol):
@ -12,7 +12,7 @@
def base_names(self):
ret = []
@@ -205,11 +206,15 @@
@@ -205,11 +206,15 @@ def provided_symbols(obj):
if version_string.lower() not in ('base', 'none'):
version = version_string
@ -29,7 +29,7 @@
return result
@@ -498,6 +503,9 @@
@@ -500,6 +505,9 @@ while 1:
debug(DEBUG_SPAM, "present_symbols adding %s" % symbol)
names = symbol.base_names()
for name in names:
@ -39,7 +39,7 @@
present_symbols[name] = symbol
# are we finished?
@@ -589,12 +597,16 @@
@@ -591,12 +599,16 @@ while 1:
# may segfault in ptmalloc_init due to undefined weak reference
extra_pre_obj.append(sysroot + libc_extras_dir + "/soinit.o")
extra_post_obj.append(sysroot + libc_extras_dir + "/sofini.o")

@ -1,6 +1,6 @@
--- a/src/mklibs-readelf/main.cpp
+++ b/src/mklibs-readelf/main.cpp
@@ -84,7 +84,7 @@
@@ -84,7 +84,7 @@ static void process_symbols_provided (co
continue;
if (shndx == SHN_UNDEF || shndx == SHN_ABS)
continue;
@ -9,7 +9,7 @@
continue;
if (!name.size())
continue;
@@ -115,7 +115,7 @@
@@ -115,7 +115,7 @@ static void process_symbols_undefined (c
continue;
if (shndx != SHN_UNDEF)
continue;

@ -1,6 +1,6 @@
--- a/src/mklibs
+++ b/src/mklibs
@@ -263,6 +263,7 @@
@@ -263,6 +263,7 @@ def extract_soname(so_file):
return ""
def multiarch(paths):

Loading…
Cancel
Save