ipset: update to 6.38

dropped already upstream patch

Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
v19.07.3_mercusys_ac12_duma
Syrone Wong 6 years ago committed by Hans Dedecker
parent 2cc821e7ed
commit 68f109609b

@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ipset
PKG_VERSION:=6.34
PKG_VERSION:=6.38
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://ipset.netfilter.org
PKG_HASH:=d70e831b670b7aa25dde81fd994d3a7ce0c0e801559a557105576df66cd8d680
PKG_HASH:=ceef625ba31fe0aaa422926c7231a819de0b07644c02c17ebdd3022a29e3e244
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-2.0

@ -1,25 +0,0 @@
From a4212bf911026740afc7fce98d9100e2ef5dcea0 Mon Sep 17 00:00:00 2001
From: Jozsef Kadlecsik <kadlec@blackhole.kfki.hu>
Date: Tue, 26 Sep 2017 07:00:13 +0200
Subject: [PATCH] Replace the last reference to u_int8_t with uint8_t.
---
src/ipset.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/ipset.c b/src/ipset.c
index 79f56b8..df0778a 100644
--- a/src/ipset.c
+++ b/src/ipset.c
@@ -282,7 +282,7 @@ call_parser(int *argc, char *argv[], const struct ipset_type *type,
const struct ipset_arg *arg;
const char *optstr;
const struct ipset_type *t = type;
- u_int8_t revision = type->revision;
+ uint8_t revision = type->revision;
int ret = 0, i = 1;
/* Currently CREATE and ADT may have got additional arguments */
--
2.13.5
Loading…
Cancel
Save