ppl: update to 1.1

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 39068
v19.07.3_mercusys_ac12_duma
Luka Perkov 11 years ago
parent 152f0b7017
commit 5efbcf2f92

@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ppl
PKG_VERSION:=1.0
PKG_VERSION:=1.1
PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/1.0/
PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_MD5SUM:=e8caeb84cd858f64b36333c368891c7b
PKG_MD5SUM:=82617a9c4e08606111ed9d2dc37ececa
HOST_FIXUP:=autoreconf

@ -0,0 +1,44 @@
--- a/tests/BD_Shape/Makefile.am
+++ b/tests/BD_Shape/Makefile.am
@@ -21,8 +21,6 @@
# For the most up-to-date information see the Parma Polyhedra Library
# site: http://bugseng.com/products/ppl/ .
-AUTOMAKE_OPTIONS = serial-tests
-
if VALGRIND_TESTS_ENABLED
CHECKER = \
--- a/tests/Box/Makefile.am
+++ b/tests/Box/Makefile.am
@@ -21,8 +21,6 @@
# For the most up-to-date information see the Parma Polyhedra Library
# site: http://bugseng.com/products/ppl/ .
-AUTOMAKE_OPTIONS = serial-tests
-
if VALGRIND_TESTS_ENABLED
CHECKER = \
--- a/tests/Concrete_Expression/Makefile.am
+++ b/tests/Concrete_Expression/Makefile.am
@@ -21,8 +21,6 @@
# For the most up-to-date information see the Parma Polyhedra Library
# site: http://bugseng.com/products/ppl/ .
-AUTOMAKE_OPTIONS = serial-tests
-
if VALGRIND_TESTS_ENABLED
CHECKER = \
--- a/tests/Octagonal_Shape/Makefile.am
+++ b/tests/Octagonal_Shape/Makefile.am
@@ -21,8 +21,6 @@
# For the most up-to-date information see the Parma Polyhedra Library
# site: http://bugseng.com/products/ppl/ .
-AUTOMAKE_OPTIONS = serial-tests
-
if VALGRIND_TESTS_ENABLED
CHECKER = \

@ -1,41 +0,0 @@
--- a/src/mp_std_bits.cc
+++ b/src/mp_std_bits.cc
@@ -25,6 +25,9 @@ site: http://bugseng.com/products/ppl/ . */
#include "ppl-config.h"
#include "mp_std_bits_defs.hh"
+#if __GNU_MP_VERSION < 5 \
+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
+
const bool std::numeric_limits<mpz_class>::is_specialized;
const int std::numeric_limits<mpz_class>::digits;
const int std::numeric_limits<mpz_class>::digits10;
@@ -70,3 +73,6 @@ const bool std::numeric_limits<mpq_class>::is_modulo;
const bool std::numeric_limits<mpq_class>::traps;
const bool std::numeric_limits<mpq_class>::tininess_before;
const std::float_round_style std::numeric_limits<mpq_class>::round_style;
+
+#endif // __GNU_MP_VERSION < 5
+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
--- a/src/mp_std_bits.defs.hh
+++ b/src/mp_std_bits.defs.hh
@@ -38,6 +38,9 @@
#endif // defined(PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS)
void swap(mpq_class& x, mpq_class& y);
+#if __GNU_MP_VERSION < 5 \
+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
+
namespace std {
#ifdef PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS
@@ -164,6 +167,9 @@
} // namespace std
+#endif // __GNU_MP_VERSION < 5
+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
+
#include "mp_std_bits.inlines.hh"
#endif // !defined(PPL_mp_std_bits_defs_hh)
Loading…
Cancel
Save