refresh generic patches

SVN-Revision: 32059
v19.07.3_mercusys_ac12_duma
Florian Fainelli 12 years ago
parent 36c99bcc42
commit 5ec2209734

@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
@@ -854,25 +854,7 @@ void netlink_detachskb(struct sock *sk,
@@ -854,25 +854,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{

@ -1,8 +1,6 @@
Index: linux-3.3.7/drivers/net/phy/Kconfig
===================================================================
--- linux-3.3.7.orig/drivers/net/phy/Kconfig 2012-05-27 18:09:00.129697447 +0200
+++ linux-3.3.7/drivers/net/phy/Kconfig 2012-05-29 18:31:44.462611635 +0200
@@ -207,3 +207,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -206,3 +206,7 @@ endif # PHYLIB
config MICREL_KS8995MA
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
depends on SPI
@ -10,11 +8,9 @@ Index: linux-3.3.7/drivers/net/phy/Kconfig
+config PSB6970_PHY
+ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
+ select SWCONFIG
Index: linux-3.3.7/drivers/net/phy/Makefile
===================================================================
--- linux-3.3.7.orig/drivers/net/phy/Makefile 2012-05-27 18:09:00.129697447 +0200
+++ linux-3.3.7/drivers/net/phy/Makefile 2012-05-29 18:30:59.286610634 +0200
@@ -28,6 +28,7 @@
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb
obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_MICREL_PHY) += micrel.o

@ -1,7 +1,7 @@
--- a/drivers/usb/host/pci-quirks.c
+++ b/drivers/usb/host/pci-quirks.c
@@ -431,6 +431,8 @@ reset_needed:
@@ -432,6 +432,8 @@ reset_needed:
}
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
@ -10,7 +10,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
@@ -898,3 +900,5 @@ static void __devinit quirk_usb_early_ha
@@ -928,3 +930,5 @@ static void __devinit quirk_usb_early_ha
pci_disable_device(pdev);
}
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);

@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
@@ -815,7 +815,7 @@ static int __init kernel_init(void * unu
@@ -816,7 +816,7 @@ static int __init kernel_init(void * unu
/* Open the /dev/console on the rootfs, this should never fail */
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)

@ -1,6 +1,6 @@
--- a/init/main.c
+++ b/init/main.c
@@ -777,10 +777,7 @@ static noinline int init_post(void)
@@ -774,10 +774,7 @@ static noinline int init_post(void)
printk(KERN_WARNING "Failed to execute %s. Attempting "
"defaults...\n", execute_command);
}

Loading…
Cancel
Save