cyassl: upgrade to v2.8.0

Un-reverts the previous update commit and forward-ports the patch
to improve legacy SSLv2 handshake handling.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 38609
v19.07.3_mercusys_ac12_duma
Jo-Philipp Wich 11 years ago
parent fdfc296aaf
commit 5e8abac86f

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cyassl
PKG_VERSION:=1.6.5
PKG_RELEASE:=2
PKG_VERSION:=2.8.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://www.yassl.com/
PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
PKG_MD5SUM:=7465d4815af90eff01095fa1b031ce09
PKG_FIXUP:=patch-libtool
PKG_INSTALL:=1
@ -38,14 +38,15 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--without-zlib \
--enable-singleThreaded
--enable-singlethreaded \
--disable-examples
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{so*,la} $(1)/usr/lib/
endef
define Package/libcyassl/install

@ -1,6 +1,6 @@
--- a/src/cyassl_int.c
+++ b/src/cyassl_int.c
@@ -1588,6 +1588,10 @@
--- a/src/internal.c
+++ b/src/internal.c
@@ -4622,6 +4622,10 @@
b1 =
ssl->buffers.inputBuffer.buffer[ssl->buffers.inputBuffer.idx++];
ssl->curSize = ((b0 & 0x7f) << 8) | b1;

Loading…
Cancel
Save