upgrade the Linaro binutils to 2.24-2013.12

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>

SVN-Revision: 39210
v19.07.3_mercusys_ac12_duma
Imre Kaloz 10 years ago
parent f6be067784
commit 5c3cb628f8

@ -13,10 +13,10 @@ PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
PKG_RELEASE:=6
ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
PKG_SOURCE_URL:=https://releases.linaro.org/13.06/components/toolchain/binutils-linaro/
PKG_REV:=2.23.2-2013.06
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
BINUTILS_DIR:=$(PKG_NAME)-2.23.2
PKG_SOURCE_URL:=https://releases.linaro.org/13.12/components/toolchain/binutils-linaro/
PKG_REV:=2.24-2013.12
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
PKG_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
PKG_VERSION:=$(PKG_REV)
else

@ -21,7 +21,7 @@ choice
config BINUTILS_VERSION_LINARO
depends on !avr32 || (avr32 && BROKEN)
bool "Linaro binutils 2.23.2"
bool "Linaro binutils 2.24"
endchoice

@ -11,11 +11,11 @@ PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
BIN_VERSION:=$(PKG_VERSION)
ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
PKG_SOURCE_URL:=https://releases.linaro.org/13.06/components/toolchain/binutils-linaro/
PKG_REV:=2.23.2-2013.06
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
PKG_MD5SUM:=73ad2a91f17b7e4fd41d49db5a541d2d
BINUTILS_DIR:=$(PKG_NAME)-2.23.2
PKG_SOURCE_URL:=https://releases.linaro.org/13.12/components/toolchain/binutils-linaro/
PKG_REV:=2.24-2013.12
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
PKG_MD5SUM:=4f0fe947895a260b8386de63b09feb18
BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
else
PKG_SOURCE_URL:=@GNU/binutils/

@ -20,7 +20,7 @@ make[4]: *** [as-new] Error 1
--- a/gas/configure.tgt
+++ b/gas/configure.tgt
@@ -450,6 +450,12 @@ case ${generic_target} in
@@ -468,6 +468,12 @@ case ${generic_target} in
*-*-netware) fmt=elf em=netware ;;
esac

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -3595,7 +3595,7 @@ case "${target}" in
@@ -3793,7 +3793,7 @@ case "${target}" in
mips*-*-*)
noconfigdirs="$noconfigdirs gprof"
;;
@ -11,7 +11,7 @@
;;
--- a/configure.ac
+++ b/configure.ac
@@ -1021,7 +1021,7 @@ case "${target}" in
@@ -1129,7 +1129,7 @@ case "${target}" in
mips*-*-*)
noconfigdirs="$noconfigdirs gprof"
;;

@ -1,10 +0,0 @@
--- a/config.sub
+++ b/config.sub
@@ -125,6 +125,7 @@ esac
maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
case $maybe_os in
nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
+ linux-musl* | \
linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
knetbsd*-gnu* | netbsd*-gnu* | \
kopensolaris*-gnu* | \

@ -1,6 +1,6 @@
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -37,7 +37,7 @@ endif
@@ -54,7 +54,7 @@ endif
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
@ -11,7 +11,7 @@
EMULATION_OFILES = @EMULATION_OFILES@
--- a/ld/Makefile.in
+++ b/ld/Makefile.in
@@ -367,7 +367,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
@@ -386,7 +386,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.

@ -1,6 +1,6 @@
--- a/ld/emultempl/elf32.em
+++ b/ld/emultempl/elf32.em
@@ -1278,6 +1278,8 @@ fragment <<EOF
@@ -1267,6 +1267,8 @@ fragment <<EOF
&& command_line.rpath == NULL)
{
lib_path = (const char *) getenv ("LD_RUN_PATH");
@ -9,7 +9,7 @@
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
force))
break;
@@ -1505,6 +1507,8 @@ gld${EMULATION_NAME}_before_allocation (
@@ -1518,6 +1520,8 @@ gld${EMULATION_NAME}_before_allocation (
rpath = command_line.rpath;
if (rpath == NULL)
rpath = (const char *) getenv ("LD_RUN_PATH");

@ -1,6 +1,6 @@
--- a/bfd/elfxx-mips.c
+++ b/bfd/elfxx-mips.c
@@ -7331,6 +7331,7 @@ _bfd_mips_elf_create_dynamic_sections (b
@@ -7450,6 +7450,7 @@ _bfd_mips_elf_create_dynamic_sections (b
name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
bh = NULL;
@ -8,7 +8,7 @@
if (!(_bfd_generic_link_add_one_symbol
(info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
@@ -7343,6 +7344,7 @@ _bfd_mips_elf_create_dynamic_sections (b
@@ -7462,6 +7463,7 @@ _bfd_mips_elf_create_dynamic_sections (b
if (! bfd_elf_link_record_dynamic_symbol (info, h))
return FALSE;

Loading…
Cancel
Save