ar71xx: refresh 2.6.33 patches

SVN-Revision: 19960
v19.07.3_mercusys_ac12_duma
Gabor Juhos 15 years ago
parent 111ae3e04b
commit 58ec1289d9

@ -1,8 +1,6 @@
Index: linux-2.6.33/arch/mips/Makefile
===================================================================
--- linux-2.6.33.orig/arch/mips/Makefile 2010-02-28 16:43:15.000000000 +0100
+++ linux-2.6.33/arch/mips/Makefile 2010-02-28 16:45:56.397211344 +0100
@@ -637,6 +637,13 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -637,6 +637,13 @@ else
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
endif
@ -16,11 +14,9 @@ Index: linux-2.6.33/arch/mips/Makefile
# temporary until string.h is fixed
cflags-y += -ffreestanding
Index: linux-2.6.33/arch/mips/Kconfig
===================================================================
--- linux-2.6.33.orig/arch/mips/Kconfig 2010-02-28 16:43:15.000000000 +0100
+++ linux-2.6.33/arch/mips/Kconfig 2010-02-28 16:46:56.150331076 +0100
@@ -48,6 +48,23 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -48,6 +48,23 @@ config AR7
Support for the Texas Instruments AR7 System-on-a-Chip
family: TNETD7100, 7200 and 7300.
@ -44,7 +40,7 @@ Index: linux-2.6.33/arch/mips/Kconfig
config BCM47XX
bool "BCM47XX based boards"
select CEVT_R4K
@@ -682,6 +699,7 @@
@@ -682,6 +699,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
endchoice
source "arch/mips/alchemy/Kconfig"

@ -1,8 +1,8 @@
--- a/drivers/usb/host/Kconfig
+++ b/drivers/usb/host/Kconfig
@@ -98,6 +98,13 @@ config USB_EHCI_BIG_ENDIAN_DESC
depends on USB_EHCI_HCD && (440EPX || ARCH_IXP4XX)
default y
@@ -109,6 +109,13 @@ config XPS_USB_HCD_XILINX
support both high speed and full speed devices, or high speed
devices only.
+config USB_EHCI_AR71XX
+ bool "USB EHCI support for AR71xx"
@ -14,7 +14,7 @@
config USB_EHCI_FSL
bool "Support for Freescale on-chip EHCI USB controller"
depends on USB_EHCI_HCD && FSL_SOC
@@ -189,6 +196,13 @@ config USB_OHCI_HCD
@@ -207,6 +214,13 @@ config USB_OHCI_HCD
To compile this driver as a module, choose M here: the
module will be called ohci-hcd.
@ -30,7 +30,7 @@
depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL");
@@ -1158,6 +1158,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_atmel_driver
#endif

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -2126,6 +2126,8 @@ config ACENIC_OMIT_TIGON_I
@@ -2128,6 +2128,8 @@ config ACENIC_OMIT_TIGON_I
The safe and default value for this is N.

@ -1,6 +1,6 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -850,6 +850,13 @@ config TXX9_WDT
@@ -840,6 +840,13 @@ config TXX9_WDT
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@ -16,7 +16,7 @@
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -113,6 +113,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
@@ -112,6 +112,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o

@ -1,6 +1,6 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
@@ -259,6 +259,13 @@ config MTD_ALCHEMY
@@ -257,6 +257,13 @@ config MTD_ALCHEMY
help
Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -867,6 +867,16 @@ static int __devinit m25p_probe(struct s
@@ -922,6 +922,16 @@ static int __devinit m25p_probe(struct s
part_probes, &parts, 0);
}

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -877,6 +877,15 @@ static int __devinit m25p_probe(struct s
@@ -932,6 +932,15 @@ static int __devinit m25p_probe(struct s
}
#endif

@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -1141,8 +1141,8 @@ static int __xipram do_write_oneword(str
@@ -1130,8 +1130,8 @@ static int __xipram do_write_oneword(str
break;
}
@ -11,7 +11,7 @@
/* Latency issues. Drop the lock, wait a while and retry */
UDELAY(map, chip, adr, 1);
@@ -1158,6 +1158,8 @@ static int __xipram do_write_oneword(str
@@ -1147,6 +1147,8 @@ static int __xipram do_write_oneword(str
ret = -EIO;
}
@ -20,7 +20,7 @@
xip_enable(map, chip, adr);
op_done:
chip->state = FL_READY;
@@ -1504,7 +1506,6 @@ static int cfi_amdstd_write_buffers(stru
@@ -1493,7 +1495,6 @@ static int cfi_amdstd_write_buffers(stru
return 0;
}
@ -28,7 +28,7 @@
/*
* Handle devices with one erase region, that only implement
* the chip erase command.
@@ -1568,8 +1569,8 @@ static int __xipram do_erase_chip(struct
@@ -1557,8 +1558,8 @@ static int __xipram do_erase_chip(struct
chip->erase_suspended = 0;
}
@ -39,7 +39,7 @@
if (time_after(jiffies, timeo)) {
printk(KERN_WARNING "MTD %s(): software timeout\n",
@@ -1589,6 +1590,7 @@ static int __xipram do_erase_chip(struct
@@ -1578,6 +1579,7 @@ static int __xipram do_erase_chip(struct
ret = -EIO;
}
@ -47,7 +47,7 @@
chip->state = FL_READY;
xip_enable(map, chip, adr);
put_chip(map, chip, adr);
@@ -1656,9 +1658,9 @@ static int __xipram do_erase_oneblock(st
@@ -1645,9 +1647,9 @@ static int __xipram do_erase_oneblock(st
chip->erase_suspended = 0;
}
@ -59,7 +59,7 @@
}
if (time_after(jiffies, timeo)) {
@@ -1680,6 +1682,7 @@ static int __xipram do_erase_oneblock(st
@@ -1669,6 +1671,7 @@ static int __xipram do_erase_oneblock(st
ret = -EIO;
}

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -886,6 +886,16 @@ static int __devinit m25p_probe(struct s
@@ -941,6 +941,16 @@ static int __devinit m25p_probe(struct s
part_probes, &parts, 0);
}
#endif

@ -1,6 +1,6 @@
--- a/drivers/usb/host/ehci-q.c
+++ b/drivers/usb/host/ehci-q.c
@@ -1172,6 +1172,9 @@ static void end_unlink_async (struct ehc
@@ -1194,6 +1194,9 @@ static void end_unlink_async (struct ehc
ehci->reclaim = NULL;
start_unlink_async (ehci, next);
}

@ -35,7 +35,7 @@
/* Atmel chips don't use the same PRI format as AMD chips */
static void fixup_convert_atmel_pri(struct mtd_info *mtd, void *param)
@@ -1315,6 +1319,7 @@ static int cfi_amdstd_write_words(struct
@@ -1304,6 +1308,7 @@ static int cfi_amdstd_write_words(struct
/*
* FIXME: interleaved mode not tested, and probably not supported!
*/
@ -43,7 +43,7 @@
static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
unsigned long adr, const u_char *buf,
int len)
@@ -1426,7 +1431,6 @@ static int __xipram do_write_buffer(stru
@@ -1415,7 +1420,6 @@ static int __xipram do_write_buffer(stru
return ret;
}
@ -51,7 +51,7 @@
static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
size_t *retlen, const u_char *buf)
{
@@ -1505,6 +1509,7 @@ static int cfi_amdstd_write_buffers(stru
@@ -1494,6 +1498,7 @@ static int cfi_amdstd_write_buffers(stru
return 0;
}

@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -482,4 +482,8 @@ config MTD_NAND_W90P910
@@ -488,4 +488,8 @@ config MTD_NAND_W90P910
This enables the driver for the NAND Flash on evaluation board based
on w90p910.
@ -11,7 +11,7 @@
endif # MTD_NAND
--- a/drivers/mtd/nand/Makefile
+++ b/drivers/mtd/nand/Makefile
@@ -31,6 +31,7 @@ obj-$(CONFIG_MTD_NAND_BASLER_EXCITE) +=
@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_NAND_CM_X270) += cmx27
obj-$(CONFIG_MTD_NAND_PXA3xx) += pxa3xx_nand.o
obj-$(CONFIG_MTD_NAND_TMIO) += tmio_nand.o
obj-$(CONFIG_MTD_NAND_PLATFORM) += plat_nand.o

@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -296,6 +296,11 @@ config SPI_TLE62X0
@@ -365,6 +365,11 @@ config SPI_TLE62X0
sysfs interface, with each line presented as a kind of GPIO
exposing both switch control and diagnostic feedback.
@ -14,7 +14,7 @@
#
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.
@@ -54,6 +54,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
# SPI protocol drivers (device/link on bus)
obj-$(CONFIG_SPI_SPIDEV) += spidev.o

@ -17,7 +17,7 @@
depends on (ARCH_AT91 || AVR32)
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
@@ -24,6 +24,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
obj-$(CONFIG_SPI_IMX) += spi_imx.o
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o

@ -1,8 +1,6 @@
Index: linux-2.6.33/drivers/leds/Kconfig
===================================================================
--- linux-2.6.33.orig/drivers/leds/Kconfig 2010-02-28 16:43:15.000000000 +0100
+++ linux-2.6.33/drivers/leds/Kconfig 2010-02-28 16:47:43.134713224 +0100
@@ -269,6 +269,13 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -269,6 +269,13 @@ config LEDS_ADP5520
To compile this driver as a module, choose M here: the module will
be called leds-adp5520.
@ -16,11 +14,9 @@ Index: linux-2.6.33/drivers/leds/Kconfig
comment "LED Triggers"
config LEDS_TRIGGERS
Index: linux-2.6.33/drivers/leds/Makefile
===================================================================
--- linux-2.6.33.orig/drivers/leds/Makefile 2010-02-28 16:43:15.000000000 +0100
+++ linux-2.6.33/drivers/leds/Makefile 2010-02-28 16:48:22.946586221 +0100
@@ -29,6 +29,7 @@
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -29,6 +29,7 @@ obj-$(CONFIG_LEDS_DA903X) += leds-da903
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o

@ -1,6 +1,6 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -230,4 +230,12 @@ config GPIO_UCB1400
@@ -255,4 +255,12 @@ config GPIO_UCB1400
To compile this driver as a module, choose M here: the
module will be called ucb1400_gpio.
@ -15,7 +15,7 @@
endif
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -10,6 +10,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
@@ -11,6 +11,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
obj-$(CONFIG_GPIO_MAX732X) += max732x.o
obj-$(CONFIG_GPIO_MC33880) += mc33880.o
obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o

@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -169,6 +169,7 @@ endif
@@ -181,6 +181,7 @@ endif
#
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
@ -10,7 +10,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -880,6 +880,9 @@ config MIPS_NILE4
@@ -877,6 +877,9 @@ config MIPS_NILE4
config MIPS_DISABLE_OBSOLETE_IDE
bool

@ -1,7 +1,5 @@
Index: linux-2.6.33/arch/mips/kernel/traps.c
===================================================================
--- linux-2.6.33.orig/arch/mips/kernel/traps.c 2010-02-24 19:52:17.000000000 +0100
+++ linux-2.6.33/arch/mips/kernel/traps.c 2010-02-28 16:51:35.397204241 +0100
--- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c
@@ -50,6 +50,7 @@
#include <asm/types.h>
#include <asm/stacktrace.h>
@ -10,7 +8,7 @@ Index: linux-2.6.33/arch/mips/kernel/traps.c
extern void check_wait(void);
extern asmlinkage void r4k_wait(void);
@@ -1496,6 +1497,8 @@
@@ -1496,6 +1497,8 @@ void __cpuinit per_cpu_trap_init(void)
if (cpu_has_mips_r2) {
cp0_compare_irq_shift = CAUSEB_TI - CAUSEB_IP;
cp0_compare_irq = (read_c0_intctl() >> INTCTLB_IPTI) & 7;
@ -19,11 +17,9 @@ Index: linux-2.6.33/arch/mips/kernel/traps.c
cp0_perfcount_irq = (read_c0_intctl() >> INTCTLB_IPPCI) & 7;
if (cp0_perfcount_irq == cp0_compare_irq)
cp0_perfcount_irq = -1;
Index: linux-2.6.33/arch/mips/include/asm/time.h
===================================================================
--- linux-2.6.33.orig/arch/mips/include/asm/time.h 2010-02-24 19:52:17.000000000 +0100
+++ linux-2.6.33/arch/mips/include/asm/time.h 2010-02-28 16:49:18.925959821 +0100
@@ -52,6 +52,7 @@
--- a/arch/mips/include/asm/time.h
+++ b/arch/mips/include/asm/time.h
@@ -52,6 +52,7 @@ extern int (*perf_irq)(void);
*/
#ifdef CONFIG_CEVT_R4K_LIB
extern unsigned int __weak get_c0_compare_int(void);

@ -32,7 +32,7 @@
return res;
}
@@ -100,22 +117,6 @@ static int c0_compare_int_pending(void)
return (read_c0_cause() >> cp0_compare_irq) & 0x100;
return (read_c0_cause() >> cp0_compare_irq_shift) & (1ul << CAUSEB_IP);
}
-/*

Loading…
Cancel
Save