update opkg to 4564, fixes a couple of memory leaks

SVN-Revision: 12115
v19.07.3_mercusys_ac12_duma
Travis Kemen 16 years ago
parent dd3f4dd178
commit 56172a1eba

@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=opkg
PKG_REV:=4561
PKG_REV:=4564
PKG_VERSION:=$(PKG_REV)
PKG_RELEASE:=1

@ -1,7 +1,55 @@
Index: opkg-4561/libopkg/opkg_download.c
===================================================================
--- opkg-4561/libopkg/opkg_download.c (revision 4480)
+++ opkg-4561/libopkg/opkg_download.c (working copy)
--- opkg-4564/configure.ac-orig 2008-08-04 19:39:20.000000000 -0500
+++ opkg-4564/configure.ac 2008-08-04 19:37:17.000000000 -0500
@@ -22,9 +22,16 @@
# Checks for libraries
-# check for libcurl
-PKG_CHECK_MODULES(CURL, libcurl)
+AC_ARG_ENABLE(curl,
+ AC_HELP_STRING([--enable-curl], [Enable use of libcurl instead of wget
+ [[default=yes]] ]),
+ [want_curl="$enableval"], [want_curl="yes"])
+if test "x$want_curl" = "xyes"; then
+ # check for libcurl
+ PKG_CHECK_MODULES(CURL, libcurl)
+ AC_DEFINE(HAVE_CURL, 1, [Define if you want to use libcurl instead of wget])
+fi
dnl **********
--- opkg-4564/libopkg/opkg.c-orig 2008-08-04 19:39:38.000000000 -0500
+++ opkg-4564/libopkg/opkg.c 2008-08-04 19:37:17.000000000 -0500
@@ -1020,8 +1020,9 @@
return package;
}
-
+#ifdef HAVE_CURL
#include <curl/curl.h>
+#endif
/**
* @brief Check the accessibility of repositories. It will try to access the repository to check if the respository is accessible throught current network status.
* @param opkg The opkg_t
@@ -1071,6 +1072,7 @@
repositories--;
err = opkg_download(opkg->conf, iter1->data, "/dev/null", NULL, NULL);
+ #ifdef HAVE_CURL
if (!(err == CURLE_OK ||
err == CURLE_HTTP_RETURNED_ERROR ||
err == CURLE_FILE_COULDNT_READ_FILE ||
@@ -1079,6 +1081,7 @@
)) {
ret++;
}
+ #endif
str_list_elt_deinit(iter1);
free(iter1);
}
--- opkg-4564/libopkg/opkg_download.c-orig 2008-08-04 19:39:56.000000000 -0500
+++ opkg-4564/libopkg/opkg_download.c 2008-08-04 19:37:17.000000000 -0500
@@ -17,7 +17,9 @@
General Public License for more details.
*/
@ -12,7 +60,7 @@ Index: opkg-4561/libopkg/opkg_download.c
#ifdef HAVE_GPGME
#include <gpgme.h>
#endif
@@ -74,6 +76,7 @@
@@ -76,6 +78,7 @@
setenv("no_proxy", conf->no_proxy, 1);
}
@ -20,7 +68,7 @@ Index: opkg-4561/libopkg/opkg_download.c
CURL *curl;
CURLcode res;
FILE * file = fopen (tmp_file_location, "w");
@@ -119,6 +122,31 @@
@@ -121,6 +124,31 @@
free(src_basec);
return -1;
}
@ -52,57 +100,3 @@ Index: opkg-4561/libopkg/opkg_download.c
err = file_move(tmp_file_location, dest_file_name);
Index: opkg-4561/configure.ac
===================================================================
--- opkg-4561/configure.ac (revision 4480)
+++ opkg-4561/configure.ac (working copy)
@@ -22,9 +22,16 @@
# Checks for libraries
-# check for libcurl
-PKG_CHECK_MODULES(CURL, libcurl)
+AC_ARG_ENABLE(curl,
+ AC_HELP_STRING([--enable-curl], [Enable use of libcurl instead of wget
+ [[default=yes]] ]),
+ [want_curl="$enableval"], [want_curl="yes"])
+if test "x$want_curl" = "xyes"; then
+ # check for libcurl
+ PKG_CHECK_MODULES(CURL, libcurl)
+ AC_DEFINE(HAVE_CURL, 1, [Define if you want to use libcurl instead of wget])
+fi
dnl **********
Index: opkg-4561/libopkg/opkg.c
===================================================================
--- opkg-4561/libopkg/opkg.c-orig 2008-07-28 16:27:53.000000000 -0500
+++ opkg-4561/libopkg/opkg.c 2008-07-29 07:46:42.000000000 -0500
@@ -1013,8 +1013,9 @@
return package;
}
-
+#ifdef HAVE_CURL
#include <curl/curl.h>
+#endif
/**
* @brief Check the accessibility of repositories. It will try to access the repository to check if the respository is accessible throught current network status.
* @param opkg The opkg_t
@@ -1064,6 +1065,7 @@
repositories--;
err = opkg_download(opkg->conf, iter1->data, "/dev/null", NULL, NULL);
+ #ifdef HAVE_CURL
if (!(err == CURLE_OK ||
err == CURLE_HTTP_RETURNED_ERROR ||
err == CURLE_FILE_COULDNT_READ_FILE ||
@@ -1072,6 +1074,7 @@
)) {
ret++;
}
+ #endif
str_list_elt_deinit(iter1);
free(iter1);
}

Loading…
Cancel
Save