refresh patches

SVN-Revision: 15630
v19.07.3_mercusys_ac12_duma
Gabor Juhos 15 years ago
parent ed861cf5e9
commit 51ee440082

@ -1,7 +1,7 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -84,6 +84,11 @@ config IP175C_PHY
tristate "Driver for IC+ IP175C/IP178C switches"
@@ -88,6 +88,11 @@ config AR8216_PHY
tristate "Driver for Atheros AR8216 switches"
select SWCONFIG
+config MICREL_PHY
@ -14,9 +14,9 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o

@ -1,6 +1,6 @@
--- a/drivers/usb/host/ehci-q.c
+++ b/drivers/usb/host/ehci-q.c
@@ -1050,6 +1050,9 @@ static void end_unlink_async (struct ehc
@@ -1082,6 +1082,9 @@ static void end_unlink_async (struct ehc
ehci->reclaim = NULL;
start_unlink_async (ehci, next);
}

@ -1,8 +1,8 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -96,6 +96,11 @@ config ADM6996_PHY
config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"
@@ -104,6 +104,11 @@ config AR8216_PHY
tristate "Driver for Atheros AR8216 switches"
select SWCONFIG
+config MICREL_PHY
+ tristate "Drivers for Micrel/Kendin PHYs"
@ -14,8 +14,8 @@
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_AR8216_PHY) += ar8216.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+obj-$(CONFIG_MICREL) += micrel.o

@ -1,6 +1,6 @@
--- a/drivers/net/ag71xx/ag71xx_main.c
+++ b/drivers/net/ag71xx/ag71xx_main.c
@@ -557,7 +557,7 @@ static void ag71xx_oom_timer_handler(uns
@@ -561,7 +561,7 @@ static void ag71xx_oom_timer_handler(uns
struct net_device *dev = (struct net_device *) data;
struct ag71xx *ag = netdev_priv(dev);
@ -9,7 +9,7 @@
}
static void ag71xx_tx_timeout(struct net_device *dev)
@@ -713,7 +713,7 @@ static int ag71xx_poll(struct napi_struc
@@ -717,7 +717,7 @@ static int ag71xx_poll(struct napi_struc
DBG("%s: disable polling mode, done=%d, limit=%d\n",
dev->name, done, limit);
@ -18,7 +18,7 @@
/* enable interrupts */
spin_lock_irqsave(&ag->lock, flags);
@@ -732,7 +732,7 @@ static int ag71xx_poll(struct napi_struc
@@ -736,7 +736,7 @@ static int ag71xx_poll(struct napi_struc
printk(KERN_DEBUG "%s: out of memory\n", dev->name);
mod_timer(&ag->oom_timer, jiffies + AG71XX_OOM_REFILL);
@ -27,7 +27,7 @@
return 0;
}
@@ -762,7 +762,7 @@ static irqreturn_t ag71xx_interrupt(int
@@ -766,7 +766,7 @@ static irqreturn_t ag71xx_interrupt(int
if (likely(status & AG71XX_INT_POLL)) {
ag71xx_int_disable(ag, AG71XX_INT_POLL);
DBG("%s: enable polling mode\n", dev->name);

Loading…
Cancel
Save