mac80211: Fix incorrect ifdef placement in 800-nuke_led_code.patch

SVN-Revision: 22749
v19.07.3_mercusys_ac12_duma
Michael Büsch 14 years ago
parent bcdf9742be
commit 4df18c296e

@ -1,5 +1,23 @@
--- a/config.mk
+++ b/config.mk
---
config.mk | 14 +++++++-------
drivers/net/wireless/ath/ath9k/ath9k.h | 4 ++++
drivers/net/wireless/ath/ath9k/gpio.c | 2 ++
drivers/net/wireless/ath/ath9k/init.c | 6 ++++++
drivers/net/wireless/ath/ath9k/main.c | 6 ++++++
drivers/net/wireless/ath/ath9k/pci.c | 4 ++++
include/linux/compat-2.6.25.h | 2 ++
net/mac80211/iface.c | 4 ++++
net/mac80211/main.c | 8 ++++++++
net/mac80211/mlme.c | 6 ++++++
net/mac80211/pm.c | 2 ++
net/mac80211/rx.c | 4 ++++
net/mac80211/status.c | 4 ++++
net/mac80211/tx.c | 4 ++++
net/mac80211/util.c | 6 ++++++
15 files changed, 69 insertions(+), 7 deletions(-)
--- compat-wireless-2010-07-29.orig/config.mk
+++ compat-wireless-2010-07-29/config.mk
@@ -115,7 +115,7 @@ CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstr
# CONFIG_MAC80211_RC_PID=y
CONFIG_MAC80211_RC_MINSTREL=y
@ -61,8 +79,8 @@
# Atheros
CONFIG_ATH_COMMON=m
--- a/include/linux/compat-2.6.25.h
+++ b/include/linux/compat-2.6.25.h
--- compat-wireless-2010-07-29.orig/include/linux/compat-2.6.25.h
+++ compat-wireless-2010-07-29/include/linux/compat-2.6.25.h
@@ -146,10 +146,12 @@ static inline void __hwrng_unregister(st
hwrng_unregister(rng);
}
@ -76,8 +94,8 @@
/**
* The following things are out of ./include/linux/kernel.h
--- a/drivers/net/wireless/ath/ath9k/gpio.c
+++ b/drivers/net/wireless/ath/ath9k/gpio.c
--- compat-wireless-2010-07-29.orig/drivers/net/wireless/ath/ath9k/gpio.c
+++ compat-wireless-2010-07-29/drivers/net/wireless/ath/ath9k/gpio.c
@@ -20,6 +20,7 @@
/* LED functions */
/********************************/
@ -94,8 +112,8 @@
/*******************/
/* Rfkill */
--- a/drivers/net/wireless/ath/ath9k/pci.c
+++ b/drivers/net/wireless/ath/ath9k/pci.c
--- compat-wireless-2010-07-29.orig/drivers/net/wireless/ath/ath9k/pci.c
+++ compat-wireless-2010-07-29/drivers/net/wireless/ath/ath9k/pci.c
@@ -273,7 +273,9 @@ static int ath_pci_suspend(struct pci_de
struct ath_wiphy *aphy = hw->priv;
struct ath_softc *sc = aphy->sc;
@ -119,8 +137,8 @@
return 0;
}
--- a/drivers/net/wireless/ath/ath9k/ath9k.h
+++ b/drivers/net/wireless/ath/ath9k/ath9k.h
--- compat-wireless-2010-07-29.orig/drivers/net/wireless/ath/ath9k/ath9k.h
+++ compat-wireless-2010-07-29/drivers/net/wireless/ath/ath9k/ath9k.h
@@ -465,6 +465,7 @@ void ath9k_btcoex_timer_pause(struct ath
/********************/
/* LED Control */
@ -152,9 +170,9 @@
+#endif
int beacon_interval;
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
--- compat-wireless-2010-07-29.orig/drivers/net/wireless/ath/ath9k/init.c
+++ compat-wireless-2010-07-29/drivers/net/wireless/ath/ath9k/init.c
@@ -34,9 +34,11 @@ int modparam_nohwcrypt;
module_param_named(nohwcrypt, modparam_nohwcrypt, int, 0444);
MODULE_PARM_DESC(nohwcrypt, "Disable hardware encryption");
@ -187,8 +205,8 @@
for (i = 0; i < sc->num_sec_wiphy; i++) {
struct ath_wiphy *aphy = sc->sec_wiphy[i];
--- a/drivers/net/wireless/ath/ath9k/main.c
+++ b/drivers/net/wireless/ath/ath9k/main.c
--- compat-wireless-2010-07-29.orig/drivers/net/wireless/ath/ath9k/main.c
+++ compat-wireless-2010-07-29/drivers/net/wireless/ath/ath9k/main.c
@@ -868,9 +868,11 @@ void ath_radio_enable(struct ath_softc *
ath9k_hw_set_interrupts(ah, ah->imask);
@ -225,8 +243,8 @@
cancel_delayed_work_sync(&sc->tx_complete_work);
cancel_work_sync(&sc->paprd_work);
--- a/net/mac80211/iface.c
+++ b/net/mac80211/iface.c
--- compat-wireless-2010-07-29.orig/net/mac80211/iface.c
+++ compat-wireless-2010-07-29/net/mac80211/iface.c
@@ -21,7 +21,9 @@
#include "sta_info.h"
#include "debugfs_netdev.h"
@ -247,8 +265,8 @@
}
/*
--- a/net/mac80211/main.c
+++ b/net/mac80211/main.c
--- compat-wireless-2010-07-29.orig/net/mac80211/main.c
+++ compat-wireless-2010-07-29/net/mac80211/main.c
@@ -29,7 +29,9 @@
#include "rate.h"
#include "mesh.h"
@ -289,8 +307,8 @@
kfree(local->int_scan_req);
}
EXPORT_SYMBOL(ieee80211_unregister_hw);
--- a/net/mac80211/mlme.c
+++ b/net/mac80211/mlme.c
--- compat-wireless-2010-07-29.orig/net/mac80211/mlme.c
+++ compat-wireless-2010-07-29/net/mac80211/mlme.c
@@ -26,7 +26,9 @@
#include "ieee80211_i.h"
#include "driver-ops.h"
@ -321,8 +339,8 @@
changed |= BSS_CHANGED_ASSOC;
sdata->vif.bss_conf.assoc = false;
--- a/net/mac80211/pm.c
+++ b/net/mac80211/pm.c
--- compat-wireless-2010-07-29.orig/net/mac80211/pm.c
+++ compat-wireless-2010-07-29/net/mac80211/pm.c
@@ -4,7 +4,9 @@
#include "ieee80211_i.h"
#include "mesh.h"
@ -333,8 +351,8 @@
int __ieee80211_suspend(struct ieee80211_hw *hw)
{
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
--- compat-wireless-2010-07-29.orig/net/mac80211/rx.c
+++ compat-wireless-2010-07-29/net/mac80211/rx.c
@@ -21,7 +21,9 @@
#include "ieee80211_i.h"
@ -345,18 +363,19 @@
#include "mesh.h"
#include "wep.h"
#include "wpa.h"
@@ -1343,7 +1345,9 @@ ieee80211_rx_h_defragment(struct ieee802
@@ -1342,8 +1344,10 @@ ieee80211_rx_h_defragment(struct ieee802
rx->sta->rx_packets++;
if (is_multicast_ether_addr(hdr->addr1))
rx->local->dot11MulticastReceivedFrameCount++;
else
+#ifdef CONFIG_MAC80211_LEDS
else
ieee80211_led_rx(rx->local);
+#endif
return RX_CONTINUE;
}
--- a/net/mac80211/status.c
+++ b/net/mac80211/status.c
--- compat-wireless-2010-07-29.orig/net/mac80211/status.c
+++ compat-wireless-2010-07-29/net/mac80211/status.c
@@ -13,7 +13,9 @@
#include "ieee80211_i.h"
#include "rate.h"
@ -377,8 +396,8 @@
/* SNMP counters
* Fragments are passed to low-level drivers as separate skbs, so these
--- a/net/mac80211/tx.c
+++ b/net/mac80211/tx.c
--- compat-wireless-2010-07-29.orig/net/mac80211/tx.c
+++ compat-wireless-2010-07-29/net/mac80211/tx.c
@@ -26,7 +26,9 @@
#include "ieee80211_i.h"
@ -399,8 +418,8 @@
fragm = true;
}
--- a/net/mac80211/util.c
+++ b/net/mac80211/util.c
--- compat-wireless-2010-07-29.orig/net/mac80211/util.c
+++ compat-wireless-2010-07-29/net/mac80211/util.c
@@ -29,7 +29,9 @@
#include "rate.h"
#include "mesh.h"

Loading…
Cancel
Save