ppp: version bump to 2.4.5

Bump to the current version of PPP.

A few of the patches are either in 2.4.5 or something functionally equivalent is, so those patches were removed.

1 patch was added to accommodate pppol2pv3_addr which is referenced in a linux kernel header file, but isn't defined in the kernel header files packaged with PPP.

Redux: re-instate the commenting out of the exponential back-off as requested by Felix.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>

SVN-Revision: 27818
v19.07.3_mercusys_ac12_duma
Felix Fietkau 13 years ago
parent e18ceb1dac
commit 4c4da37c09

@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
PKG_RELEASE:=17
PKG_VERSION:=2.4.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
PKG_MD5SUM:=183800762e266132218b204dfb428d29
PKG_MD5SUM:=4621bc56167b6953ec4071043fe0ec57
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)

@ -1,6 +1,6 @@
--- a/pppd/ipcp.c
+++ b/pppd/ipcp.c
@@ -1850,7 +1850,7 @@ ipcp_up(f)
@@ -1939,7 +1939,7 @@ ipcp_up(f)
*/
if (ipcp_script_state == s_down && ipcp_script_pid == 0) {
ipcp_script_state = s_up;
@ -9,7 +9,7 @@
}
}
@@ -1900,7 +1900,7 @@ ipcp_down(f)
@@ -1989,7 +1989,7 @@ ipcp_down(f)
/* Execute the ip-down script */
if (ipcp_script_state == s_up && ipcp_script_pid == 0) {
ipcp_script_state = s_down;
@ -18,7 +18,7 @@
}
}
@@ -1954,13 +1954,13 @@ ipcp_script_done(arg)
@@ -2043,13 +2043,13 @@ ipcp_script_done(arg)
case s_up:
if (ipcp_fsm[0].state != OPENED) {
ipcp_script_state = s_down;
@ -36,7 +36,7 @@
}
--- a/pppd/main.c
+++ b/pppd/main.c
@@ -315,6 +315,9 @@ main(argc, argv)
@@ -316,6 +316,9 @@ main(argc, argv)
struct protent *protp;
char numbuf[16];
@ -73,7 +73,7 @@
"Enable multilink operation", OPT_PRIO | 1 },
--- a/pppd/pppd.h
+++ b/pppd/pppd.h
@@ -312,6 +312,8 @@ extern bool tune_kernel; /* May alter ke
@@ -313,6 +313,8 @@ extern bool tune_kernel; /* May alter ke
extern int connect_delay; /* Time to delay after connect script */
extern int max_data_rate; /* max bytes/sec through charshunt */
extern int req_unit; /* interface unit number to use */

@ -1,19 +0,0 @@
--- a/pppd/main.c
+++ b/pppd/main.c
@@ -1570,6 +1570,8 @@ safe_fork(int infd, int outfd, int errfd
if (errfd == 0 || errfd == 1)
errfd = dup(errfd);
+ closelog();
+
/* dup the in, out, err fds to 0, 1, 2 */
if (infd != 0)
dup2(infd, 0);
@@ -1578,7 +1580,6 @@ safe_fork(int infd, int outfd, int errfd
if (errfd != 2)
dup2(errfd, 2);
- closelog();
if (log_to_fd > 2)
close(log_to_fd);
if (the_channel->close)

@ -1,6 +1,6 @@
--- a/pppd/main.c
+++ b/pppd/main.c
@@ -772,8 +772,7 @@ detach()
@@ -773,8 +773,7 @@ detach()
/* update pid files if they have been written already */
if (pidfilename[0])
create_pidfile(pid);

@ -1,11 +0,0 @@
--- a/pppd/chap_ms.c
+++ b/pppd/chap_ms.c
@@ -852,7 +852,7 @@ ChapMS2(u_char *rchallenge, u_char *Peer
u_char *p = &response[MS_CHAP2_PEER_CHALLENGE];
int i;
- BZERO(response, sizeof(*response));
+ BZERO(response, MS_CHAP2_RESPONSE_LEN);
/* Generate the Peer-Challenge if requested, or copy it if supplied. */
if (!PeerChallenge)

@ -139,7 +139,7 @@
} else {
--- a/pppd/ipcp.c
+++ b/pppd/ipcp.c
@@ -1776,7 +1776,7 @@ ipcp_up(f)
@@ -1864,7 +1864,7 @@ ipcp_up(f)
proxy_arp_set[f->unit] = 1;
}
@ -161,7 +161,7 @@
} else {
--- a/pppd/pppd.h
+++ b/pppd/pppd.h
@@ -565,7 +565,7 @@ void demand_conf __P((void)); /* config
@@ -566,7 +566,7 @@ void demand_conf __P((void)); /* config
void demand_block __P((void)); /* set all NPs to queue up packets */
void demand_unblock __P((void)); /* set all NPs to pass packets */
void demand_discard __P((void)); /* set all NPs to discard packets */

@ -1,6 +1,6 @@
--- a/pppd/chap-new.c
+++ b/pppd/chap-new.c
@@ -57,6 +57,7 @@ int (*chap_verify_hook)(char *name, char
@@ -58,6 +58,7 @@ int (*chap_verify_hook)(char *name, char
int chap_timeout_time = 3;
int chap_max_transmits = 10;
int chap_rechallenge_time = 0;
@ -8,7 +8,7 @@
/*
* Command-line options.
@@ -68,6 +69,8 @@ static option_t chap_option_list[] = {
@@ -69,6 +70,8 @@ static option_t chap_option_list[] = {
"Set max #xmits for challenge", OPT_PRIO },
{ "chap-interval", o_int, &chap_rechallenge_time,
"Set interval for rechallenge", OPT_PRIO },
@ -17,7 +17,7 @@
{ NULL }
};
@@ -335,6 +338,14 @@ chap_handle_response(struct chap_server_
@@ -336,6 +339,14 @@ chap_handle_response(struct chap_server_
/* Null terminate and clean remote name. */
slprintf(rname, sizeof(rname), "%.*v", len, name);
name = rname;

@ -1,14 +1,7 @@
--- a/pppd/plugins/pppoatm/pppoatm.c
+++ b/pppd/plugins/pppoatm/pppoatm.c
@@ -70,18 +70,20 @@ static int setdevname_pppoatm(const char
{
struct sockaddr_atmpvc addr;
extern struct stat devstat;
+
if (device_got_set)
return 0;
- //info("PPPoATM setdevname_pppoatm: '%s'", cp);
+
@@ -75,13 +75,14 @@ static int setdevname_pppoatm(const char
//info("PPPoATM setdevname_pppoatm: '%s'", cp);
memset(&addr, 0, sizeof addr);
if (text2atm(cp, (struct sockaddr *) &addr, sizeof(addr),
- T2A_PVC | T2A_NAME) < 0) {
@ -28,52 +21,7 @@
memcpy(&pvcaddr, &addr, sizeof pvcaddr);
strlcpy(devnam, cp, sizeof devnam);
devstat.st_mode = S_IFSOCK;
@@ -93,7 +95,6 @@ static int setdevname_pppoatm(const char
lcp_allowoptions[0].neg_asyncmap = 0;
lcp_wantoptions[0].neg_pcompression = 0;
}
- info("PPPoATM setdevname_pppoatm - SUCCESS:%s", cp);
device_got_set = 1;
return 1;
}
@@ -108,6 +109,7 @@ static void no_device_given_pppoatm(void
static void set_line_discipline_pppoatm(int fd)
{
struct atm_backend_ppp be;
+
be.backend_num = ATM_BACKEND_PPP;
if (!llc_encaps)
be.encaps = PPPOATM_ENCAPS_VC;
@@ -115,6 +117,7 @@ static void set_line_discipline_pppoatm(
be.encaps = PPPOATM_ENCAPS_LLC;
else
be.encaps = PPPOATM_ENCAPS_AUTODETECT;
+
if (ioctl(fd, ATM_SETBACKEND, &be) < 0)
fatal("ioctl(ATM_SETBACKEND): %m");
}
@@ -175,16 +178,19 @@ static void send_config_pppoa(int mtu,
{
int sock;
struct ifreq ifr;
+
if (mtu > pppoatm_max_mtu)
error("Couldn't increase MTU to %d", mtu);
+
sock = socket(AF_INET, SOCK_DGRAM, 0);
if (sock < 0)
fatal("Couldn't create IP socket: %m");
+
strlcpy(ifr.ifr_name, ifname, sizeof(ifr.ifr_name));
ifr.ifr_mtu = mtu;
if (ioctl(sock, SIOCSIFMTU, (caddr_t) &ifr) < 0)
fatal("ioctl(SIOCSIFMTU): %m");
- (void) close (sock);
+ close(sock);
}
static void recv_config_pppoa(int mru,
@@ -198,7 +204,7 @@ static void recv_config_pppoa(int mru,
@@ -170,7 +171,7 @@ static void disconnect_pppoatm(void)
void plugin_init(void)
{
@ -82,14 +30,3 @@
extern int new_style_driver; /* From sys-linux.c */
if (!ppp_available() && !new_style_driver)
fatal("Kernel doesn't support ppp_generic - "
@@ -206,9 +212,9 @@ void plugin_init(void)
#else
fatal("No PPPoATM support on this OS");
#endif
- info("PPPoATM plugin_init");
add_options(pppoa_options);
}
+
struct channel pppoa_channel = {
options: pppoa_options,
process_extra_options: NULL,

@ -1,30 +0,0 @@
--- a/pppd/plugins/pppoatm/pppoatm.c
+++ b/pppd/plugins/pppoatm/pppoatm.c
@@ -179,8 +179,11 @@ static void send_config_pppoa(int mtu,
int sock;
struct ifreq ifr;
- if (mtu > pppoatm_max_mtu)
- error("Couldn't increase MTU to %d", mtu);
+ if (pppoatm_max_mtu && mtu > pppoatm_max_mtu) {
+ warn("Couldn't increase MTU to %d. Using %d",
+ mtu, pppoatm_max_mtu);
+ mtu = pppoatm_max_mtu;
+ }
sock = socket(AF_INET, SOCK_DGRAM, 0);
if (sock < 0)
@@ -198,8 +201,11 @@ static void recv_config_pppoa(int mru,
int pcomp,
int accomp)
{
- if (mru > pppoatm_max_mru)
- error("Couldn't increase MRU to %d", mru);
+ if (pppoatm_max_mru && mru > pppoatm_max_mru) {
+ warn("Couldn't increase MRU to %d. Using %d",
+ mru, pppoatm_max_mru);
+ mru = pppoatm_max_mru;
+ }
}
void plugin_init(void)

File diff suppressed because it is too large Load Diff

@ -1,6 +1,6 @@
--- a/pppd/ipcp.c
+++ b/pppd/ipcp.c
@@ -197,6 +197,14 @@ static option_t ipcp_option_list[] = {
@@ -198,6 +198,14 @@ static option_t ipcp_option_list[] = {
"disable defaultroute option", OPT_ALIAS | OPT_A2CLR,
&ipcp_wantoptions[0].default_route },
@ -15,7 +15,7 @@
{ "proxyarp", o_bool, &ipcp_wantoptions[0].proxy_arp,
"Add proxy ARP entry", OPT_ENABLE|1, &ipcp_allowoptions[0].proxy_arp },
{ "noproxyarp", o_bool, &ipcp_allowoptions[0].proxy_arp,
@@ -263,7 +271,7 @@ struct protent ipcp_protent = {
@@ -271,7 +279,7 @@ struct protent ipcp_protent = {
ip_active_pkt
};
@ -24,7 +24,7 @@
static void ipcp_script __P((char *, int)); /* Run an up/down script */
static void ipcp_script_done __P((void *));
@@ -1660,7 +1668,8 @@ ip_demand_conf(u)
@@ -1742,7 +1750,8 @@ ip_demand_conf(u)
if (!sifnpmode(u, PPP_IP, NPMODE_QUEUE))
return 0;
if (wo->default_route)
@ -34,7 +34,7 @@
default_route_set[u] = 1;
if (wo->proxy_arp)
if (sifproxyarp(u, wo->hisaddr))
@@ -1742,7 +1751,8 @@ ipcp_up(f)
@@ -1830,7 +1839,8 @@ ipcp_up(f)
*/
if (demand) {
if (go->ouraddr != wo->ouraddr || ho->hisaddr != wo->hisaddr) {
@ -44,7 +44,7 @@
if (go->ouraddr != wo->ouraddr) {
warn("Local IP address changed to %I", go->ouraddr);
script_setenv("OLDIPLOCAL", ip_ntoa(wo->ouraddr), 0);
@@ -1767,7 +1777,8 @@ ipcp_up(f)
@@ -1855,7 +1865,8 @@ ipcp_up(f)
/* assign a default route through the interface if required */
if (ipcp_wantoptions[f->unit].default_route)
@ -54,7 +54,7 @@
default_route_set[f->unit] = 1;
/* Make a proxy ARP entry if requested. */
@@ -1817,7 +1828,8 @@ ipcp_up(f)
@@ -1905,7 +1916,8 @@ ipcp_up(f)
/* assign a default route through the interface if required */
if (ipcp_wantoptions[f->unit].default_route)
@ -64,7 +64,7 @@
default_route_set[f->unit] = 1;
/* Make a proxy ARP entry if requested. */
@@ -1894,7 +1906,7 @@ ipcp_down(f)
@@ -1983,7 +1995,7 @@ ipcp_down(f)
sifnpmode(f->unit, PPP_IP, NPMODE_DROP);
sifdown(f->unit);
ipcp_clear_addrs(f->unit, ipcp_gotoptions[f->unit].ouraddr,
@ -73,7 +73,7 @@
}
/* Execute the ip-down script */
@@ -1910,16 +1922,25 @@ ipcp_down(f)
@@ -1999,16 +2011,25 @@ ipcp_down(f)
* proxy arp entries, etc.
*/
static void
@ -125,7 +125,7 @@
.B disconnect \fIscript
Execute the command specified by \fIscript\fR, by passing it to a
shell, after
@@ -706,7 +711,12 @@ disable both forms of hardware flow cont
@@ -717,7 +722,12 @@ disable both forms of hardware flow cont
.TP
.B nodefaultroute
Disable the \fIdefaultroute\fR option. The system administrator who
@ -141,7 +141,7 @@
.B nodeflate
--- a/pppd/pppd.h
+++ b/pppd/pppd.h
@@ -644,7 +644,7 @@ int sif6addr __P((int, eui64_t, eui64_t
@@ -645,7 +645,7 @@ int sif6addr __P((int, eui64_t, eui64_t
int cif6addr __P((int, eui64_t, eui64_t));
/* Remove an IPv6 address from i/f */
#endif
@ -161,7 +161,7 @@
static u_int32_t proxy_arp_addr; /* Addr for proxy arp entry added */
static char proxy_arp_dev[16]; /* Device for proxy arp entry */
static u_int32_t our_old_addr; /* for detecting address changes */
@@ -1520,6 +1522,9 @@ static int read_route_table(struct rtent
@@ -1544,6 +1546,9 @@ static int read_route_table(struct rtent
p = NULL;
}
@ -171,7 +171,7 @@
SIN_ADDR(rt->rt_dst) = strtoul(cols[route_dest_col], NULL, 16);
SIN_ADDR(rt->rt_gateway) = strtoul(cols[route_gw_col], NULL, 16);
SIN_ADDR(rt->rt_genmask) = strtoul(cols[route_mask_col], NULL, 16);
@@ -1589,20 +1594,51 @@ int have_route_to(u_int32_t addr)
@@ -1613,20 +1618,51 @@ int have_route_to(u_int32_t addr)
/********************************************************************
*
* sifdefaultroute - assign a default route through the address given.
@ -236,7 +236,7 @@
}
memset (&rt, 0, sizeof (rt));
@@ -1617,10 +1653,16 @@ int sifdefaultroute (int unit, u_int32_t
@@ -1641,10 +1677,16 @@ int sifdefaultroute (int unit, u_int32_t
rt.rt_flags = RTF_UP;
if (ioctl(sock_fd, SIOCADDRT, &rt) < 0) {
@ -254,7 +254,7 @@
have_default_route = 1;
return 1;
@@ -1649,11 +1691,21 @@ int cifdefaultroute (int unit, u_int32_t
@@ -1675,11 +1717,21 @@ int cifdefaultroute (int unit, u_int32_t
rt.rt_flags = RTF_UP;
if (ioctl(sock_fd, SIOCDELRT, &rt) < 0 && errno != ESRCH) {
if (still_ppp()) {

@ -9,27 +9,9 @@
*
* NOTE TO MAINTAINERS:
* If you modify this file at all, please set the above date.
@@ -86,7 +86,7 @@ struct compressor {
/* Compress a packet */
int (*compress) (void *state, unsigned char *rptr,
- unsigned char *obuf, int isize, int osize);
+ unsigned char *obuf, int isize, int osize);
/* Return compression statistics */
void (*comp_stat) (void *state, struct compstat *stats);
@@ -107,7 +107,7 @@ struct compressor {
/* Decompress a packet. */
int (*decompress) (void *state, unsigned char *ibuf, int isize,
- unsigned char *obuf, int osize);
+ unsigned char *obuf, int osize);
/* Update state for an incompressible packet received */
void (*incomp) (void *state, unsigned char *ibuf, int icnt);
@@ -288,6 +288,33 @@ struct compressor {
opts |= MPPE_OPT_UNKNOWN; \
} while (/* CONSTCOND */ 0)
@@ -201,6 +201,33 @@ struct compressor {
#define CI_MPPE 18 /* config option for MPPE */
#define CILEN_MPPE 6 /* length of config option */
+/* MPPE/MPPC definitions by J.D.*/
+#define MPPE_STATELESS MPPE_H_BIT /* configuration bit H */
@ -63,9 +45,9 @@
*/
--- a/include/net/ppp-comp.h
+++ b/include/net/ppp-comp.h
@@ -255,6 +255,33 @@ struct compressor {
opts |= MPPE_OPT_UNKNOWN; \
} while (/* CONSTCOND */ 0)
@@ -168,6 +168,33 @@ struct compressor {
#define CI_MPPE 18 /* config option for MPPE */
#define CILEN_MPPE 6 /* length of config option */
+/* MPPE/MPPC definitions by J.D.*/
+#define MPPE_STATELESS MPPE_H_BIT /* configuration bit H */
@ -705,15 +687,6 @@
if (go->deflate) {
if (len < CILEN_DEFLATE
|| p[0] != (go->deflate_correct? CI_DEFLATE: CI_DEFLATE_DRAFT)
@@ -891,7 +1070,7 @@ ccp_ackci(f, p, len)
/*
* ccp_nakci - process received configure-nak.
- * Returns 1 iff the nak was OK.
+ * Returns 1 if the nak was OK.
*/
static int
ccp_nakci(f, p, len, treat_as_reject)
@@ -901,6 +1080,8 @@ ccp_nakci(f, p, len, treat_as_reject)
int treat_as_reject;
{
@ -930,6 +903,10 @@
-
- /* Nak if anything unsupported or unknown are set. */
- if (ho->mppe & MPPE_OPT_UNSUPPORTED) {
- newret = CONFNAK;
- ho->mppe &= ~MPPE_OPT_UNSUPPORTED;
- }
- if (ho->mppe & MPPE_OPT_UNKNOWN) {
+ p2 = p[2];
+ p5 = p[5];
+ /* not sure what they want, tell 'em what we got */
@ -938,10 +915,6 @@
+ MPPE_MPPC)) != 0 || p[5] == 0) ||
+ (p[2] == 0 && p[3] == 0 && p[4] == 0 && p[5] == 0)) {
newret = CONFNAK;
- ho->mppe &= ~MPPE_OPT_UNSUPPORTED;
- }
- if (ho->mppe & MPPE_OPT_UNKNOWN) {
- newret = CONFNAK;
- ho->mppe &= ~MPPE_OPT_UNKNOWN;
- }
-
@ -1471,11 +1444,6 @@
* Send a reset-request to reset the peer's compressor.
* We don't do that if we are still waiting for an
* acknowledgement to a previous reset-request.
@@ -1675,4 +2180,3 @@ ccp_rack_timeout(arg)
} else
ccp_localstate[f->unit] &= ~RACK_PENDING;
}
-
--- a/pppd/ccp.h
+++ b/pppd/ccp.h
@@ -37,9 +37,17 @@ typedef struct ccp_options {
@ -1498,7 +1466,7 @@
--- a/pppd/chap_ms.c
+++ b/pppd/chap_ms.c
@@ -897,13 +897,17 @@ set_mppe_enc_types(int policy, int types
@@ -898,13 +898,17 @@ set_mppe_enc_types(int policy, int types
/*
* Disable undesirable encryption types. Note that we don't ENABLE
* any encryption types, to avoid overriding manual configuration.

@ -46,7 +46,7 @@
--- a/pppd/plugins/rp-pppoe/Makefile.linux
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
@@ -39,9 +39,9 @@ rp-pppoe.so: libplugin.a plugin.o
@@ -43,9 +43,9 @@ rp-pppoe.so: plugin.o discovery.o if.o c
install: all
$(INSTALL) -d -m 755 $(LIBDIR)
@ -57,7 +57,7 @@
+ $(INSTALL) -c -m 555 pppoe-discovery $(BINDIR)
clean:
rm -f *.o *.so
rm -f *.o *.so pppoe-discovery
--- a/pppdump/Makefile.linux
+++ b/pppdump/Makefile.linux
@@ -17,5 +17,5 @@ clean:

@ -1,21 +1,16 @@
--- a/pppd/plugins/rp-pppoe/discovery.c
+++ b/pppd/plugins/rp-pppoe/discovery.c
@@ -593,12 +593,14 @@ discovery(PPPoEConnection *conn)
@@ -548,7 +548,9 @@ discovery(PPPoEConnection *conn)
conn->discoveryState = STATE_SENT_PADI;
waitForPADO(conn, timeout);
+#if 0
/* If we're just probing for access concentrators, don't do
exponential backoff. This reduces the time for an unsuccessful
probe to 15 seconds. */
if (!conn->printACNames) {
timeout *= 2;
}
timeout *= 2;
+#endif
if (conn->printACNames && conn->numPADOs) {
break;
}
@@ -621,7 +623,9 @@ discovery(PPPoEConnection *conn)
} while (conn->discoveryState == STATE_SENT_PADI);
timeout = conn->discoveryTimeout;
@@ -563,7 +565,9 @@ discovery(PPPoEConnection *conn)
sendPADR(conn);
conn->discoveryState = STATE_SENT_PADR;
waitForPADS(conn, timeout);

@ -8,7 +8,7 @@
#include "pppd.h"
#include "magic.h"
@@ -227,6 +228,7 @@ static struct subprocess *children;
@@ -228,6 +229,7 @@ static struct subprocess *children;
/* Prototypes for procedures local to this file. */
@ -16,7 +16,7 @@
static void setup_signals __P((void));
static void create_pidfile __P((int pid));
static void create_linkpidfile __P((int pid));
@@ -532,6 +534,7 @@ main(argc, argv)
@@ -533,6 +535,7 @@ main(argc, argv)
info("Starting link");
}
@ -24,7 +24,7 @@
gettimeofday(&start_time, NULL);
script_unsetenv("CONNECT_TIME");
script_unsetenv("BYTES_SENT");
@@ -1264,6 +1267,36 @@ struct callout {
@@ -1265,6 +1268,36 @@ struct callout {
static struct callout *callout = NULL; /* Callout list */
static struct timeval timenow; /* Current time */
@ -61,7 +61,7 @@
/*
* timeout - Schedule a timeout.
@@ -1334,6 +1367,8 @@ calltimeout()
@@ -1335,6 +1368,8 @@ calltimeout()
{
struct callout *p;
@ -70,7 +70,7 @@
while (callout != NULL) {
p = callout;
@@ -1361,6 +1396,8 @@ timeleft(tvp)
@@ -1362,6 +1397,8 @@ timeleft(tvp)
{
if (callout == NULL)
return NULL;

@ -64,7 +64,7 @@
#ifdef MAXOCTETS
{ "maxoctets", o_int, &maxoctets,
"Set connection traffic limit",
@@ -1456,6 +1472,29 @@ callfile(argv)
@@ -1463,6 +1479,29 @@ callfile(argv)
return ok;
}

@ -1,6 +1,6 @@
--- a/pppd/main.c
+++ b/pppd/main.c
@@ -742,8 +742,11 @@ void
@@ -743,8 +743,11 @@ void
set_ifunit(iskey)
int iskey;
{
@ -47,7 +47,7 @@
/*
* Limits.
*/
@@ -308,6 +312,7 @@ extern char *record_file; /* File to rec
@@ -309,6 +313,7 @@ extern char *record_file; /* File to rec
extern bool sync_serial; /* Device is synchronous serial device */
extern int maxfail; /* Max # of unsuccessful connection attempts */
extern char linkname[MAXPATHLEN]; /* logical name for link */
@ -115,12 +115,12 @@
if (argc > 0)
interface = argv[0];
+/*
+#if 0
if (sscanf(interface, PPP_DRV_NAME "%d", &unit) != 1) {
fprintf(stderr, "%s: invalid interface '%s' specified\n",
progname, interface);
}
+*/
+#endif
#ifndef STREAMS
{

@ -1,6 +1,6 @@
--- a/pppd/sys-linux.c
+++ b/pppd/sys-linux.c
@@ -1717,6 +1717,7 @@ int cifdefaultroute (int unit, u_int32_t
@@ -1743,6 +1743,7 @@ int cifdefaultroute (int unit, u_int32_t
SIN_ADDR(rt.rt_genmask) = 0L;
}

@ -1,6 +1,6 @@
--- a/pppd/sys-linux.c
+++ b/pppd/sys-linux.c
@@ -1673,6 +1673,9 @@ int sifdefaultroute (int unit, u_int32_t
@@ -1697,6 +1697,9 @@ int sifdefaultroute (int unit, u_int32_t
memset (&rt, 0, sizeof (rt));
SET_SA_FAMILY (rt.rt_dst, AF_INET);
@ -10,7 +10,7 @@
rt.rt_dev = ifname;
if (kernel_version > KVERSION(2,1,0)) {
@@ -1680,7 +1683,7 @@ int sifdefaultroute (int unit, u_int32_t
@@ -1704,7 +1707,7 @@ int sifdefaultroute (int unit, u_int32_t
SIN_ADDR(rt.rt_genmask) = 0L;
}

@ -1,109 +0,0 @@
--- a/pppd/plugins/rp-pppoe/common.c
+++ b/pppd/plugins/rp-pppoe/common.c
@@ -75,7 +75,9 @@ parsePacket(PPPoEPacket *packet, ParseFu
error("Invalid PPPoE tag length (%u)", tagLen);
return -1;
}
- func(tagType, tagLen, curTag+TAG_HDR_SIZE, extra);
+ if (func(tagType, tagLen, curTag+TAG_HDR_SIZE, extra)) {
+ return -1;
+ }
curTag = curTag + TAG_HDR_SIZE + tagLen;
}
return 0;
--- a/pppd/plugins/rp-pppoe/discovery.c
+++ b/pppd/plugins/rp-pppoe/discovery.c
@@ -48,7 +48,7 @@ static char const RCSID[] =
*%DESCRIPTION:
* If a HostUnique tag is found which matches our PID, sets *extra to 1.
***********************************************************************/
-void
+int
parseForHostUniq(UINT16_t type, UINT16_t len, unsigned char *data,
void *extra)
{
@@ -60,6 +60,7 @@ parseForHostUniq(UINT16_t type, UINT16_t
*val = 1;
}
}
+ return 0;
}
/**********************************************************************
@@ -102,7 +103,7 @@ packetIsForMe(PPPoEConnection *conn, PPP
*%DESCRIPTION:
* Picks interesting tags out of a PADO packet
***********************************************************************/
-void
+int
parsePADOTags(UINT16_t type, UINT16_t len, unsigned char *data,
void *extra)
{
@@ -181,6 +182,7 @@ parsePADOTags(UINT16_t type, UINT16_t le
}
break;
}
+ return 0;
}
/**********************************************************************
@@ -195,7 +197,7 @@ parsePADOTags(UINT16_t type, UINT16_t le
*%DESCRIPTION:
* Picks interesting tags out of a PADS packet
***********************************************************************/
-void
+int
parsePADSTags(UINT16_t type, UINT16_t len, unsigned char *data,
void *extra)
{
@@ -205,17 +207,21 @@ parsePADSTags(UINT16_t type, UINT16_t le
dbglog("PADS: Service-Name: '%.*s'", (int) len, data);
break;
case TAG_SERVICE_NAME_ERROR:
- fatal("PADS: Service-Name-Error: %.*s", (int) len, data);
+ error("PADS: Service-Name-Error: %.*s", (int) len, data);
+ return -1;
case TAG_AC_SYSTEM_ERROR:
- fatal("PADS: System-Error: %.*s", (int) len, data);
+ error("PADS: System-Error: %.*s", (int) len, data);
+ return -1;
case TAG_GENERIC_ERROR:
- fatal("PADS: Generic-Error: %.*s", (int) len, data);
+ error("PADS: Generic-Error: %.*s", (int) len, data);
+ return -1;
case TAG_RELAY_SESSION_ID:
conn->relayId.type = htons(type);
conn->relayId.length = htons(len);
memcpy(conn->relayId.payload, data, len);
break;
}
+ return 0;
}
/***********************************************************************
@@ -532,9 +538,11 @@ waitForPADS(PPPoEConnection *conn, int t
/* Is it PADS? */
if (packet.code == CODE_PADS) {
/* Parse for goodies */
- parsePacket(&packet, parsePADSTags, conn);
- conn->discoveryState = STATE_SESSION;
- break;
+ if (!parsePacket(&packet, parsePADSTags, conn))
+ {
+ conn->discoveryState = STATE_SESSION;
+ break;
+ }
}
} while (conn->discoveryState != STATE_SESSION);
--- a/pppd/plugins/rp-pppoe/pppoe.h
+++ b/pppd/plugins/rp-pppoe/pppoe.h
@@ -238,7 +238,7 @@ typedef struct PPPoETagStruct {
#define READ_CHUNK 4096
/* Function passed to parsePacket */
-typedef void ParseFunc(UINT16_t type,
+typedef int ParseFunc(UINT16_t type,
UINT16_t len,
unsigned char *data,
void *extra);

@ -19,7 +19,7 @@
#define MAX_IFS 100
@@ -1414,11 +1414,12 @@ int ccp_fatal_error (int unit)
@@ -1438,11 +1438,12 @@ int ccp_fatal_error (int unit)
*
* path_to_procfs - find the path to the proc file system mount point
*/
@ -34,7 +34,7 @@
struct mntent *mntent;
FILE *fp;
@@ -1440,6 +1441,7 @@ static char *path_to_procfs(const char *
@@ -1464,6 +1465,7 @@ static char *path_to_procfs(const char *
fclose (fp);
}
}
@ -42,9 +42,9 @@
strlcpy(proc_path + proc_path_len, tail,
sizeof(proc_path) - proc_path_len);
@@ -2098,11 +2100,13 @@ int ppp_available(void)
"ppp.o exists in /lib/modules/`uname -r`/net.\n"
"See README.linux file in the ppp distribution for more details.\n";
@@ -2116,15 +2118,19 @@ int ppp_available(void)
int my_version, my_modification, my_patch;
int osmaj, osmin, ospatch;
+#if 0
/* get the kernel version now, since we are called before sys_init */
@ -55,10 +55,6 @@
+#endif
fd = open("/dev/ppp", O_RDWR);
#if 0
@@ -2121,7 +2125,9 @@ int ppp_available(void)
}
#endif /* 0 */
if (fd >= 0) {
+#if 0
new_style_driver = 1;
@ -66,7 +62,7 @@
/* XXX should get from driver */
driver_version = 2;
@@ -2168,6 +2174,7 @@ int ppp_available(void)
@@ -2185,6 +2191,7 @@ int ppp_available(void)
if (ok && ((ifr.ifr_hwaddr.sa_family & ~0xFF) != ARPHRD_PPP))
ok = 0;
@ -74,7 +70,7 @@
/*
* This is the PPP device. Validate the version of the driver at this
@@ -2659,6 +2666,7 @@ get_pty(master_fdp, slave_fdp, slave_nam
@@ -2678,6 +2685,7 @@ get_pty(master_fdp, slave_fdp, slave_nam
}
#endif /* TIOCGPTN */
@ -82,7 +78,7 @@
if (sfd < 0) {
/* the old way - scan through the pty name space */
for (i = 0; i < 64; ++i) {
@@ -2677,6 +2685,7 @@ get_pty(master_fdp, slave_fdp, slave_nam
@@ -2696,6 +2704,7 @@ get_pty(master_fdp, slave_fdp, slave_nam
}
}
}
@ -92,7 +88,7 @@
return 0;
--- a/pppd/plugins/pppoatm/pppoatm.c
+++ b/pppd/plugins/pppoatm/pppoatm.c
@@ -210,14 +210,6 @@ static void recv_config_pppoa(int mru,
@@ -171,14 +171,6 @@ static void disconnect_pppoatm(void)
void plugin_init(void)
{
@ -104,12 +100,12 @@
-#else
- fatal("No PPPoATM support on this OS");
-#endif
info("PPPoATM plugin_init");
add_options(pppoa_options);
}
--- a/pppd/plugins/rp-pppoe/plugin.c
+++ b/pppd/plugins/rp-pppoe/plugin.c
@@ -55,9 +55,6 @@ static char const RCSID[] =
@@ -60,9 +60,6 @@ static char const RCSID[] =
char pppd_version[] = VERSION;
@ -119,7 +115,7 @@
char *pppd_pppoe_service = NULL;
static char *acName = NULL;
static char *existingSession = NULL;
@@ -312,10 +309,6 @@ PPPoEDevnameHook(char *cmd, char **argv,
@@ -340,10 +337,6 @@ PPPoEDevnameHook(char *cmd, char **argv,
void
plugin_init(void)
{
@ -128,5 +124,5 @@
- }
-
add_options(Options);
}
info("RP-PPPoE plugin version %s compiled against pppd %s",

@ -1,6 +1,6 @@
--- a/pppd/pppd.h
+++ b/pppd/pppd.h
@@ -308,7 +308,6 @@ extern int holdoff; /* Dead time before
@@ -309,7 +309,6 @@ extern int holdoff; /* Dead time before
extern bool holdoff_specified; /* true if user gave a holdoff value */
extern bool notty; /* Stdin/out is not a tty */
extern char *pty_socket; /* Socket to connect to pty */
@ -10,7 +10,7 @@
extern char linkname[MAXPATHLEN]; /* logical name for link */
--- a/pppd/tty.c
+++ b/pppd/tty.c
@@ -144,7 +144,7 @@ char *disconnect_script = NULL; /* Scrip
@@ -145,7 +145,7 @@ char *disconnect_script = NULL; /* Scrip
char *welcomer = NULL; /* Script to run after phys link estab. */
char *ptycommand = NULL; /* Command to run on other side of pty */
bool notty = 0; /* Stdin/out is not a tty */
@ -19,7 +19,7 @@
int max_data_rate; /* max bytes/sec through charshunt */
bool sync_serial = 0; /* Device is synchronous serial device */
char *pty_socket = NULL; /* Socket to connect to pty */
@@ -200,8 +200,10 @@ option_t tty_options[] = {
@@ -201,8 +201,10 @@ option_t tty_options[] = {
"Send and receive over socket, arg is host:port",
OPT_PRIO | OPT_DEVNAM },

@ -1,6 +1,6 @@
--- a/pppd/sys-linux.c
+++ b/pppd/sys-linux.c
@@ -2237,6 +2237,7 @@ int ppp_available(void)
@@ -2254,6 +2254,7 @@ int ppp_available(void)
void logwtmp (const char *line, const char *name, const char *host)
{
@ -8,7 +8,7 @@
struct utmp ut, *utp;
pid_t mypid = getpid();
#if __GLIBC__ < 2
@@ -2302,6 +2303,7 @@ void logwtmp (const char *line, const ch
@@ -2319,6 +2320,7 @@ void logwtmp (const char *line, const ch
close (wtmp);
}
#endif

@ -1,6 +1,6 @@
--- a/pppd/main.c
+++ b/pppd/main.c
@@ -879,14 +879,17 @@ struct protocol_list {
@@ -880,14 +880,17 @@ struct protocol_list {
const char *name;
} protocol_list[] = {
{ 0x21, "IP" },
@ -18,7 +18,7 @@
{ 0x33, "Stream Protocol ST-II" },
{ 0x35, "Banyan Vines" },
{ 0x39, "AppleTalk EDDP" },
@@ -900,8 +903,11 @@ struct protocol_list {
@@ -901,8 +904,11 @@ struct protocol_list {
{ 0x49, "Serial Data Transport Protocol (PPP-SDTP)" },
{ 0x4b, "SNA over 802.2" },
{ 0x4d, "SNA" },
@ -30,7 +30,7 @@
{ 0x53, "Encryption" },
{ 0x55, "Individual Link Encryption" },
{ 0x57, "IPv6" },
@@ -912,12 +918,15 @@ struct protocol_list {
@@ -913,12 +919,15 @@ struct protocol_list {
{ 0x65, "RTP IPHC Compressed non-TCP" },
{ 0x67, "RTP IPHC Compressed UDP 8" },
{ 0x69, "RTP IPHC Compressed RTP 8" },
@ -46,7 +46,7 @@
{ 0x0203, "IBM Source Routing BPDU" },
{ 0x0205, "DEC LANBridge100 Spanning Tree" },
{ 0x0207, "Cisco Discovery Protocol" },
@@ -929,15 +938,19 @@ struct protocol_list {
@@ -930,15 +939,19 @@ struct protocol_list {
{ 0x0231, "Luxcom" },
{ 0x0233, "Sigma Network Systems" },
{ 0x0235, "Apple Client Server Protocol" },
@ -66,7 +66,7 @@
{ 0x4001, "Cray Communications Control Protocol" },
{ 0x4003, "CDPD Mobile Network Registration Protocol" },
{ 0x4005, "Expand accelerator protocol" },
@@ -948,8 +961,10 @@ struct protocol_list {
@@ -949,8 +962,10 @@ struct protocol_list {
{ 0x4023, "RefTek Protocol" },
{ 0x4025, "Fibre Channel" },
{ 0x4027, "EMIT Protocols" },
@ -77,7 +77,7 @@
{ 0x8023, "OSI Network Layer Control Protocol" },
{ 0x8025, "Xerox NS IDP Control Protocol" },
{ 0x8027, "DECnet Phase IV Control Protocol" },
@@ -958,7 +973,9 @@ struct protocol_list {
@@ -959,7 +974,9 @@ struct protocol_list {
{ 0x8031, "Bridging NCP" },
{ 0x8033, "Stream Protocol Control Protocol" },
{ 0x8035, "Banyan Vines Control Protocol" },
@ -87,7 +87,7 @@
{ 0x803f, "NETBIOS Framing Control Protocol" },
{ 0x8041, "Cisco Systems Control Protocol" },
{ 0x8043, "Ascom Timeplex" },
@@ -967,18 +984,24 @@ struct protocol_list {
@@ -968,18 +985,24 @@ struct protocol_list {
{ 0x8049, "Serial Data Control Protocol (PPP-SDCP)" },
{ 0x804b, "SNA over 802.2 Control Protocol" },
{ 0x804d, "SNA Control Protocol" },
@ -98,7 +98,7 @@
+#endif
{ 0x8053, "Encryption Control Protocol" },
{ 0x8055, "Individual Link Encryption Control Protocol" },
{ 0x8057, "IPv6 Control Protovol" },
{ 0x8057, "IPv6 Control Protocol" },
{ 0x8059, "PPP Muxing Control Protocol" },
{ 0x805b, "Vendor-Specific Network Control Protocol (VSNCP)" },
+#if 0
@ -112,7 +112,7 @@
{ 0x8207, "Cisco Discovery Protocol Control" },
{ 0x8209, "Netcs Twin Routing" },
{ 0x820b, "STP - Control Protocol" },
@@ -987,24 +1010,29 @@ struct protocol_list {
@@ -988,24 +1011,29 @@ struct protocol_list {
{ 0x8281, "MPLSCP" },
{ 0x8285, "IEEE p1284.4 standard - Protocol Control" },
{ 0x8287, "ETSI TETRA TNP1 Control Protocol" },

@ -0,0 +1,23 @@
--- a/include/linux/if_pppol2tp.h
+++ b/include/linux/if_pppol2tp.h
@@ -32,6 +32,20 @@ struct pppol2tp_addr
__u16 d_tunnel, d_session; /* For sending outgoing packets */
};
+/* The L2TPv3 protocol changes tunnel and session ids from 16 to 32
+ * bits. So we need a different sockaddr structure.
+ */
+struct pppol2tpv3_addr {
+ pid_t pid; /* pid that owns the fd.
+ * 0 => current */
+ int fd; /* FD of UDP or IP socket to use */
+
+ struct sockaddr_in addr; /* IP address and port to send to */
+
+ __u32 s_tunnel, s_session; /* For matching incoming packets */
+ __u32 d_tunnel, d_session; /* For sending outgoing packets */
+};
+
/* Socket options:
* DEBUG - bitmask of debug message categories
* SENDSEQ - 0 => don't send packets with sequence numbers
Loading…
Cancel
Save