ar71xx: refresh patches

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 45528
v19.07.3_mercusys_ac12_duma
Luka Perkov 9 years ago
parent 9d76de9771
commit 48d81861a6

@ -1404,7 +1404,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -38,9 +48,120 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
@@ -38,9 +38,120 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#

@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -1174,6 +1174,10 @@ config SOC_AR934X
@@ -1184,6 +1184,10 @@ config SOC_AR934X
select PCI_AR724X if PCI
def_bool n
@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
config SOC_QCA955X
select HW_HAS_PCI
select PCI_AR724X if PCI
@@ -1216,7 +1220,7 @@ config ATH79_DEV_USB
@@ -1226,7 +1230,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC

@ -189,7 +189,7 @@
pdata->phy_if_mode = PHY_INTERFACE_MODE_GMII;
break;
@@ -992,6 +1002,8 @@ void __init ath79_register_eth(unsigned
@@ -1018,6 +1028,8 @@ void __init ath79_register_eth(unsigned
break;
case ATH79_SOC_QCA9533:
@ -198,7 +198,7 @@
if (id == 0) {
pdata->reset_bit = AR933X_RESET_GE0_MAC |
AR933X_RESET_GE0_MDIO;
@@ -1097,6 +1109,8 @@ void __init ath79_register_eth(unsigned
@@ -1123,6 +1135,8 @@ void __init ath79_register_eth(unsigned
case ATH79_SOC_AR9330:
case ATH79_SOC_AR9331:
case ATH79_SOC_QCA9533:
@ -445,7 +445,7 @@
}
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -1183,6 +1183,12 @@ config SOC_QCA955X
@@ -1193,6 +1193,12 @@ config SOC_QCA955X
select PCI_AR724X if PCI
def_bool n
@ -458,7 +458,7 @@
config ATH79_DEV_M25P80
select ATH79_DEV_SPI
def_bool n
@@ -1220,7 +1226,7 @@ config ATH79_DEV_USB
@@ -1230,7 +1236,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -524,6 +524,16 @@ config ATH79_MACH_R6100
@@ -534,6 +534,16 @@ config ATH79_MACH_R6100
select ATH79_DEV_USB
select ATH79_DEV_WMAC

@ -10,7 +10,7 @@
ATH79_MACH_PB92, /* Atheros PB92 */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -677,6 +677,7 @@ config ATH79_MACH_OM2P
@@ -687,6 +687,7 @@ config ATH79_MACH_OM2P
config ATH79_MACH_OM5P
bool "OpenMesh OM5P board support"
select SOC_AR934X

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -559,6 +559,16 @@ config ATH79_MACH_RB91X
@@ -569,6 +569,16 @@ config ATH79_MACH_RB91X
select ATH79_DEV_USB
select ATH79_ROUTERBOOT

@ -210,7 +210,7 @@
#include <linux/uaccess.h>
#include <linux/ipv6.h>
#include <linux/icmpv6.h>
@@ -833,10 +834,10 @@ static void tcp_v6_send_response(struct
@@ -833,10 +834,10 @@ static void tcp_v6_send_response(struct
topt = (__be32 *)(t1 + 1);
if (tsecr) {
@ -593,7 +593,7 @@
--- a/net/sched/cls_u32.c
+++ b/net/sched/cls_u32.c
@@ -148,7 +148,7 @@ next_knode:
@@ -151,7 +151,7 @@ next_knode:
data = skb_header_pointer(skb, toff, 4, &hdata);
if (!data)
goto out;
@ -602,7 +602,7 @@
n = rcu_dereference_bh(n->next);
goto next_knode;
}
@@ -201,8 +201,8 @@ check_terminal:
@@ -204,8 +204,8 @@ check_terminal:
&hdata);
if (!data)
goto out;
@ -637,7 +637,7 @@
#include <linux/netdevice.h>
--- a/include/net/inet_ecn.h
+++ b/include/net/inet_ecn.h
@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
{
if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
return 0;
@ -822,7 +822,7 @@
| TCPOLEN_TIMESTAMP))
--- a/net/xfrm/xfrm_input.c
+++ b/net/xfrm/xfrm_input.c
@@ -152,8 +152,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
@@ -152,8 +152,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
if (!pskb_may_pull(skb, hlen))
return -EINVAL;

Loading…
Cancel
Save