iproute2: fix broken configuration patch

Since v4.13, iproute2 switched to a config.mk file with greater use of
pkg-config for library/feature detection. Replace the old Config patch
with one modifying the configure script but enabling the same changes:
 - explicitly disable TC_CONFIG_ATM
 - rely on feature detection for IP_CONFIG_SETNS and TC_CONFIG_XT

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
v19.07.3_mercusys_ac12_duma
Tony Ambardar 6 years ago committed by Kevin Darbyshire-Bryant
parent d741b31eb8
commit 43e14a2f9e

@ -1,7 +0,0 @@
--- /dev/null
+++ b/Config
@@ -0,0 +1,4 @@
+# Fixed config to disable ATM support even if present on host system
+IP_CONFIG_SETNS:=y
+TC_CONFIG_ATM:=n
+TC_CONFIG_XT:=y

@ -0,0 +1,12 @@
--- a/configure
+++ b/configure
@@ -32,7 +32,8 @@ int main(int argc, char **argv) {
}
EOF
- if $CC -I$INCLUDE -o $TMPDIR/atmtest $TMPDIR/atmtest.c -latm >/dev/null 2>&1; then
+# OpenWrt: disable ATM support even if present on host system
+ if [ 1 -eq 0 ]; then
echo "TC_CONFIG_ATM:=y" >>$CONFIG
echo yes
else
Loading…
Cancel
Save