mac80211: update to 2011-02-25

SVN-Revision: 25749
v19.07.3_mercusys_ac12_duma
Felix Fietkau 13 years ago
parent fb28515e26
commit 39570be248

@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2011-02-07
PKG_VERSION:=2011-02-25
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_MD5SUM:=a194610426c81ed5ad71ee83330c9669
PKG_MD5SUM:=c0242cc152a157902ff60fe05d1773b2
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)

@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
@@ -311,8 +311,8 @@ endif #CONFIG_SSB
@@ -316,8 +316,8 @@ endif #CONFIG_SSB
CONFIG_P54_PCI=m

@ -9,7 +9,7 @@
ifeq ($(CONFIG_MAC80211),y)
$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
@@ -613,10 +613,10 @@ endif #CONFIG_COMPAT_KERNEL_27
@@ -623,10 +623,10 @@ endif #CONFIG_COMPAT_KERNEL_27
# We need the backported rfkill module on kernel < 2.6.31.
# In more recent kernel versions use the in kernel rfkill module.
ifdef CONFIG_COMPAT_KERNEL_31

@ -19,7 +19,7 @@
else
include $(KLIB_BUILD)/.config
endif
@@ -295,19 +294,18 @@ CONFIG_IPW2200_QOS=y
@@ -300,19 +299,18 @@ CONFIG_IPW2200_QOS=y
# % echo 1 > /sys/bus/pci/drivers/ipw2200/*/rtap_iface
endif #CONFIG_WIRELESS_EXT
@ -51,7 +51,7 @@
CONFIG_P54_PCI=m
@@ -505,7 +503,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
@@ -514,7 +512,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
ifdef CONFIG_MMC

@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
@@ -202,7 +202,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
@@ -204,7 +204,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
endif #CONFIG_WIRELESS_EXT
ifneq ($(CONFIG_STAGING),)
@ -9,7 +9,7 @@
endif
# mac80211 test driver
@@ -336,13 +336,13 @@ endif #CONFIG_CRC_ITU_T
@@ -342,13 +342,13 @@ endif #CONFIG_CRC_ITU_T
CONFIG_MWL8K=m
# Ethernet drivers go here
@ -28,7 +28,7 @@
endif #CONFIG_COMPAT_KERNEL_27
ifdef CONFIG_WIRELESS_EXT
@@ -396,21 +396,21 @@ CONFIG_ZD1211RW=m
@@ -403,21 +403,21 @@ endif #CONFIG_COMPAT_KERNEL_29
# Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
# it also requires new RNDIS_HOST and CDC_ETHER modules which we add
ifdef CONFIG_COMPAT_KERNEL_29

@ -9,7 +9,7 @@
else
include $(KLIB_BUILD)/.config
endif
@@ -229,7 +229,7 @@ CONFIG_B43=m
@@ -234,7 +234,7 @@ CONFIG_B43=m
CONFIG_B43_HWRNG=y
CONFIG_B43_PCI_AUTOSELECT=y
ifdef CONFIG_PCMCIA

@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
@@ -486,7 +486,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
@@ -495,7 +495,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
ifdef CONFIG_MMC

@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
@@ -235,7 +235,7 @@ ifdef CONFIG_MAC80211_LEDS
@@ -240,7 +240,7 @@ ifdef CONFIG_MAC80211_LEDS
CONFIG_B43_LEDS=y
endif #CONFIG_MAC80211_LEDS
CONFIG_B43_PHY_LP=y

@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
@@ -299,7 +299,7 @@ CONFIG_RTL8180=m
@@ -304,7 +304,7 @@ CONFIG_RTL8180=m
CONFIG_ADM8211=m
@ -9,7 +9,7 @@
CONFIG_RT2400PCI=m
CONFIG_RT2500PCI=m
ifdef CONFIG_CRC_CCITT
@@ -437,7 +437,7 @@ CONFIG_RT2800USB=m
@@ -444,7 +444,7 @@ CONFIG_RT2800USB=m
# CONFIG_RT2800USB_RT35XX=y
CONFIG_RT2800USB_UNKNOWN=y
endif #CONFIG_CRC_CCITT

@ -1,11 +1,11 @@
--- a/config.mk
+++ b/config.mk
@@ -212,7 +212,7 @@ CONFIG_ATH9K_COMMON=m
@@ -207,7 +207,7 @@ CONFIG_ATH9K_COMMON=m
# as default once we get minstrel properly tested and blessed by
# our systems engineering team. CCK rates also need to be used
# for long range considerations.
-CONFIG_ATH9K_RATE_CONTROL=y
+# CONFIG_ATH9K_RATE_CONTROL=y
CONFIG_COMPAT_IWLWIFI=m
# PCI Drivers
ifdef CONFIG_PCI

@ -1,11 +1,11 @@
--- a/config.mk
+++ b/config.mk
@@ -195,7 +195,7 @@ CONFIG_MAC80211_HWSIM=m
@@ -212,7 +212,7 @@ CONFIG_ATH9K_COMMON=m
# PCI Drivers
ifdef CONFIG_PCI
CONFIG_ATH5K=m
-CONFIG_ATH5K_PCI=y
+# CONFIG_ATH5K_PCI=y
# CONFIG_ATH5K_DEBUG=y
# CONFIG_ATH5K_AHB=y
CONFIG_ATH9K_HW=m
CONFIG_ATH9K=m
CONFIG_IWLAGN=m

@ -1,11 +1,11 @@
--- a/include/linux/compat-2.6.36.h
+++ b/include/linux/compat-2.6.36.h
@@ -101,6 +101,8 @@ int no_printk(const char *s, ...) { retu
@@ -102,6 +102,8 @@ int no_printk(const char *s, ...) { retu
#define alloc_workqueue(name, flags, max_active) __create_workqueue(name, flags, max_active, 0)
#endif
+#define PCI_EEPROM_WIDTH_93C86 8
+
#endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,36)) */
#define EXTPROC 0200000
#define TIOCPKT_IOCTL 64
#endif /* LINUX_26_36_COMPAT_H */

@ -0,0 +1,10 @@
--- a/compat/compat-2.6.39.c
+++ b/compat/compat-2.6.39.c
@@ -10,6 +10,7 @@
#include <linux/compat.h>
#include <linux/tty.h>
+#include <linux/sched.h>
/*
* Termios Helper Methods

@ -33,7 +33,7 @@
#endif
--- a/config.mk
+++ b/config.mk
@@ -424,7 +424,7 @@ endif #CONFIG_COMPAT_KERNEL_29
@@ -431,7 +431,7 @@ endif #CONFIG_COMPAT_KERNEL_29
# This activates a threading fix for usb urb.
# this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
# This fix will be included in some stable releases.

@ -8,8 +8,8 @@
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#include <linux/kernel.h>
--- a/drivers/net/wireless/iwlwifi/iwl3945-base.c
+++ b/drivers/net/wireless/iwlwifi/iwl3945-base.c
--- a/drivers/net/wireless/iwlegacy/iwl3945-base.c
+++ b/drivers/net/wireless/iwlegacy/iwl3945-base.c
@@ -27,6 +27,7 @@
*
*****************************************************************************/
@ -88,3 +88,13 @@
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#include <linux/kernel.h>
--- a/drivers/net/wireless/iwlegacy/iwl4965-base.c
+++ b/drivers/net/wireless/iwlegacy/iwl4965-base.c
@@ -27,6 +27,7 @@
*
*****************************************************************************/
+#undef pr_fmt
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#include <linux/kernel.h>

@ -26,7 +26,7 @@
struct ar5416IniArray iniCommon;
--- a/drivers/net/wireless/ath/ath9k/hw.c
+++ b/drivers/net/wireless/ath/ath9k/hw.c
@@ -1213,6 +1213,20 @@ static bool ath9k_hw_channel_change(stru
@@ -1212,6 +1212,20 @@ static bool ath9k_hw_channel_change(stru
return true;
}
@ -47,7 +47,7 @@
bool ath9k_hw_check_alive(struct ath_hw *ah)
{
int count = 50;
@@ -1501,6 +1515,8 @@ int ath9k_hw_reset(struct ath_hw *ah, st
@@ -1500,6 +1514,8 @@ int ath9k_hw_reset(struct ath_hw *ah, st
if (AR_SREV_9300_20_OR_LATER(ah))
ar9003_hw_bb_watchdog_config(ah);

@ -18,7 +18,7 @@
#include "ath9k.h"
@@ -526,6 +527,7 @@ static void ath9k_init_misc(struct ath_s
@@ -522,6 +523,7 @@ static void ath9k_init_misc(struct ath_s
static int ath9k_init_softc(u16 devid, struct ath_softc *sc, u16 subsysid,
const struct ath_bus_ops *bus_ops)
{
@ -26,7 +26,7 @@
struct ath_hw *ah = NULL;
struct ath_common *common;
int ret = 0, i;
@@ -540,7 +542,7 @@ static int ath9k_init_softc(u16 devid, s
@@ -536,7 +538,7 @@ static int ath9k_init_softc(u16 devid, s
ah->hw_version.subsysid = subsysid;
sc->sc_ah = ah;
@ -35,7 +35,7 @@
ah->ah_flags |= AH_USE_EEPROM;
common = ath9k_hw_common(ah);
@@ -576,6 +578,9 @@ static int ath9k_init_softc(u16 devid, s
@@ -572,6 +574,9 @@ static int ath9k_init_softc(u16 devid, s
if (ret)
goto err_hw;

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -542,8 +542,14 @@ static int ath9k_init_softc(u16 devid, s
@@ -538,8 +538,14 @@ static int ath9k_init_softc(u16 devid, s
ah->hw_version.subsysid = subsysid;
sc->sc_ah = ah;

@ -253,7 +253,7 @@
/* Rfkill */
--- a/drivers/net/wireless/ath/ath9k/main.c
+++ b/drivers/net/wireless/ath/ath9k/main.c
@@ -1204,9 +1204,6 @@ static void ath9k_stop(struct ieee80211_
@@ -1216,9 +1216,6 @@ static void ath9k_stop(struct ieee80211_
mutex_lock(&sc->mutex);
@ -265,7 +265,7 @@
cancel_work_sync(&sc->paprd_work);
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -145,6 +145,21 @@ static struct ieee80211_rate ath9k_legac
@@ -141,6 +141,21 @@ static struct ieee80211_rate ath9k_legac
RATE(540, 0x0c, 0),
};
@ -287,7 +287,7 @@
static void ath9k_deinit_softc(struct ath_softc *sc);
/*
@@ -746,6 +761,13 @@ int ath9k_init_device(u16 devid, struct
@@ -742,6 +757,13 @@ int ath9k_init_device(u16 devid, struct
ath9k_init_txpower_limits(sc);

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/hw.c
+++ b/drivers/net/wireless/ath/ath9k/hw.c
@@ -1467,8 +1467,8 @@ int ath9k_hw_reset(struct ath_hw *ah, st
@@ -1466,8 +1466,8 @@ int ath9k_hw_reset(struct ath_hw *ah, st
REG_WRITE(ah, AR_OBS, 8);
if (ah->config.rx_intr_mitigation) {

@ -1,6 +1,6 @@
--- a/include/net/mac80211.h
+++ b/include/net/mac80211.h
@@ -2198,6 +2198,20 @@ static inline int ieee80211_sta_ps_trans
@@ -2209,6 +2209,20 @@ static inline int ieee80211_sta_ps_trans
#define IEEE80211_TX_STATUS_HEADROOM 13
/**

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/ath9k.h
+++ b/drivers/net/wireless/ath/ath9k/ath9k.h
@@ -205,6 +205,7 @@ struct ath_atx_ac {
@@ -203,6 +203,7 @@ struct ath_atx_ac {
int sched;
struct list_head list;
struct list_head tid_q;
@ -8,7 +8,7 @@
};
struct ath_frame_info {
@@ -262,6 +263,8 @@ struct ath_node {
@@ -260,6 +261,8 @@ struct ath_node {
struct ath_atx_ac ac[WME_NUM_AC];
u16 maxampdu;
u8 mpdudensity;
@ -17,7 +17,7 @@
};
#define AGGR_CLEANUP BIT(1)
@@ -343,6 +346,9 @@ int ath_tx_aggr_start(struct ath_softc *
@@ -341,6 +344,9 @@ int ath_tx_aggr_start(struct ath_softc *
void ath_tx_aggr_stop(struct ath_softc *sc, struct ieee80211_sta *sta, u16 tid);
void ath_tx_aggr_resume(struct ath_softc *sc, struct ieee80211_sta *sta, u16 tid);
@ -57,7 +57,7 @@
static int ath9k_conf_tx(struct ieee80211_hw *hw, u16 queue,
const struct ieee80211_tx_queue_params *params)
{
@@ -2130,6 +2151,7 @@ struct ieee80211_ops ath9k_ops = {
@@ -2191,6 +2212,7 @@ struct ieee80211_ops ath9k_ops = {
.configure_filter = ath9k_configure_filter,
.sta_add = ath9k_sta_add,
.sta_remove = ath9k_sta_remove,
@ -189,7 +189,7 @@
void ath_tx_aggr_resume(struct ath_softc *sc, struct ieee80211_sta *sta, u16 tid)
{
struct ath_atx_tid *txtid;
@@ -1492,7 +1569,6 @@ static int setup_tx_flags(struct sk_buff
@@ -1493,7 +1570,6 @@ static int setup_tx_flags(struct sk_buff
struct ieee80211_tx_info *tx_info = IEEE80211_SKB_CB(skb);
int flags = 0;
@ -197,7 +197,7 @@
flags |= ATH9K_TXDESC_INTREQ;
if (tx_info->flags & IEEE80211_TX_CTL_NO_ACK)
@@ -1755,6 +1831,9 @@ static void ath_tx_start_dma(struct ath_
@@ -1756,6 +1832,9 @@ static void ath_tx_start_dma(struct ath_
if (txctl->paprd)
bf->bf_state.bfs_paprd_timestamp = jiffies;

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/ath9k/xmit.c
+++ b/drivers/net/wireless/ath/ath9k/xmit.c
@@ -2223,33 +2223,6 @@ static void ath_tx_complete_poll_work(st
@@ -2226,33 +2226,6 @@ static void ath_tx_complete_poll_work(st
} else {
txq->axq_tx_inprogress = true;
}

@ -152,7 +152,7 @@
/*
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
@@ -1166,14 +1166,23 @@ ieee80211_rx_h_sta_process(struct ieee80
@@ -1156,14 +1156,23 @@ ieee80211_rx_h_sta_process(struct ieee80
if (rx->sdata->vif.type == NL80211_IFTYPE_ADHOC) {
u8 *bssid = ieee80211_get_bssid(hdr, rx->skb->len,
NL80211_IFTYPE_ADHOC);

@ -1,21 +0,0 @@
--- a/drivers/net/wireless/ath/ath9k/mac.c
+++ b/drivers/net/wireless/ath/ath9k/mac.c
@@ -891,7 +891,7 @@ void ath9k_hw_set_interrupts(struct ath_
struct ath_common *common = ath9k_hw_common(ah);
if (!(ints & ATH9K_INT_GLOBAL))
- ath9k_hw_enable_interrupts(ah);
+ ath9k_hw_disable_interrupts(ah);
ath_dbg(common, ATH_DBG_INTERRUPT, "0x%x => 0x%x\n", omask, ints);
@@ -969,7 +969,8 @@ void ath9k_hw_set_interrupts(struct ath_
REG_CLR_BIT(ah, AR_IMR_S5, AR_IMR_S5_TIM_TIMER);
}
- ath9k_hw_enable_interrupts(ah);
+ if (ints & ATH9K_INT_GLOBAL)
+ ath9k_hw_enable_interrupts(ah);
return;
}

@ -1,6 +1,6 @@
--- a/drivers/net/wireless/mwl8k.c
+++ b/drivers/net/wireless/mwl8k.c
@@ -4484,6 +4484,7 @@ MODULE_FIRMWARE("mwl8k/fmimage_8366.fw")
@@ -4502,6 +4502,7 @@ MODULE_FIRMWARE("mwl8k/fmimage_8366.fw")
MODULE_FIRMWARE(MWL8K_8366_AP_FW(MWL8K_8366_AP_FW_API));
static DEFINE_PCI_DEVICE_TABLE(mwl8k_pci_id_table) = {

@ -35,7 +35,7 @@
if (dev->dev->bus->chip_id == 0x4301) {
mask |= 0x0060;
set |= 0x0060;
@@ -5102,10 +5107,10 @@ static void b43_print_driverinfo(void)
@@ -5100,10 +5105,10 @@ static void b43_print_driverinfo(void)
feat_sdio = "S";
#endif
printk(KERN_INFO "Broadcom 43xx driver loaded "

Loading…
Cancel
Save