tools: refresh patches for tools lua, mtd-utils, ipkg-utils, squashfs, lzma, and autoconf are touched

SVN-Revision: 14589
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 15 years ago
parent d0484c4cf6
commit 3849a57cd7

@ -1,6 +1,5 @@
diff -urN autoconf-2.62/lib/Makefile.am autoconf-2.62.new/lib/Makefile.am
--- autoconf-2.62/lib/Makefile.am 2008-04-04 19:17:16.000000000 +0200
+++ autoconf-2.62.new/lib/Makefile.am 2008-09-09 16:51:40.000000000 +0200
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -16,7 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
@ -10,10 +9,9 @@ diff -urN autoconf-2.62/lib/Makefile.am autoconf-2.62.new/lib/Makefile.am
nodist_pkgdata_DATA = autom4te.cfg
EXTRA_DIST = autom4te.in freeze.mk
diff -urN autoconf-2.62/lib/Makefile.in autoconf-2.62.new/lib/Makefile.in
--- autoconf-2.62/lib/Makefile.in 2008-04-06 00:57:18.000000000 +0200
+++ autoconf-2.62.new/lib/Makefile.in 2008-09-09 16:51:33.000000000 +0200
@@ -165,7 +165,7 @@
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -165,7 +165,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@

@ -1,7 +1,6 @@
diff -ruN ipkg-utils-1.7-old/ipkg-build ipkg-utils-1.7-new/ipkg-build
--- ipkg-utils-1.7-old/ipkg-build 2004-08-24 04:56:12.000000000 +0200
+++ ipkg-utils-1.7-new/ipkg-build 2004-08-24 04:55:49.000000000 +0200
@@ -47,6 +47,19 @@
--- a/ipkg-build
+++ b/ipkg-build
@@ -47,6 +47,19 @@ pkg_appears_sane() {
PKG_ERROR=0
@ -21,7 +20,7 @@ diff -ruN ipkg-utils-1.7-old/ipkg-build ipkg-utils-1.7-new/ipkg-build
tilde_files=`find . -name '*~'`
if [ -n "$tilde_files" ]; then
if [ "$noclean" = "1" ]; then
@@ -134,8 +147,12 @@
@@ -134,8 +147,12 @@ You probably want to chown these to a sy
for script in $CONTROL/preinst $CONTROL/postinst $CONTROL/prerm $CONTROL/postrm; do
if [ -f $script -a ! -x $script ]; then

@ -1,6 +1,5 @@
diff -ruN ipkg-utils-1.7-old/ipkg-buildpackage ipkg-utils-1.7-new/ipkg-buildpackage
--- ipkg-utils-1.7-old/ipkg-buildpackage 2001-07-26 17:36:36.000000000 +0200
+++ ipkg-utils-1.7-new/ipkg-buildpackage 2004-07-05 19:46:24.000000000 +0200
--- a/ipkg-buildpackage
+++ b/ipkg-buildpackage
@@ -30,8 +30,9 @@
set -e
@ -13,7 +12,7 @@ diff -ruN ipkg-utils-1.7-old/ipkg-buildpackage ipkg-utils-1.7-new/ipkg-buildpack
SCRIPTNAME=`basename $0`
@@ -212,7 +213,7 @@
@@ -212,7 +213,7 @@ done
# build the ipk package
owd=`pwd`
cd ..

@ -1,6 +1,6 @@
--- ipkg-utils-1.7-old/ipkg-buildpackage 2008-05-21 07:18:21.000000000 +0200
+++ ipkg-utils-1.7-new/ipkg-buildpackage 2008-05-21 03:22:19.000000000 +0200
@@ -190,7 +190,7 @@
--- a/ipkg-buildpackage
+++ b/ipkg-buildpackage
@@ -190,7 +190,7 @@ fi
mkdir /tmp/${pkg}/CONTROL
files_required="control"

@ -3,11 +3,9 @@ This patch from aorlinsk fixes an issue with order in options passed to tar
http://openwrt.org/forum/viewtopic.php?pid=8332#p8332
Index: ipkg-utils-1.7/ipkg-build
===================================================================
--- ipkg-utils-1.7.orig/ipkg-build 2007-06-30 14:19:16.519409000 +0200
+++ ipkg-utils-1.7/ipkg-build 2007-06-30 14:20:12.722921500 +0200
@@ -184,7 +184,7 @@
--- a/ipkg-build
+++ b/ipkg-build
@@ -184,7 +184,7 @@ while getopts "cg:ho:v" opt; do
g ) group=$OPTARG
ogargs="$ogargs --group=$group"
;;
@ -16,7 +14,7 @@ Index: ipkg-utils-1.7/ipkg-build
;;
C ) noclean=1
;;
@@ -243,8 +243,8 @@
@@ -243,8 +243,8 @@ tmp_dir=$dest_dir/IPKG_BUILD.$$
mkdir $tmp_dir
echo $CONTROL > $tmp_dir/tarX
@ -27,7 +25,7 @@ Index: ipkg-utils-1.7/ipkg-build
rm $tmp_dir/tarX
echo "2.0" > $tmp_dir/debian-binary
@@ -254,7 +254,7 @@
@@ -254,7 +254,7 @@ rm -f $pkg_file
if [ "$outer" = "ar" ] ; then
( cd $tmp_dir && ar -crf $pkg_file ./debian-binary ./data.tar.gz ./control.tar.gz )
else

@ -1,6 +1,6 @@
--- ipkg-utils-1.7/ipkg.py.orig 2006-06-29 14:16:00.000000000 +0200
+++ ipkg-utils-1.7/ipkg.py 2006-06-29 14:36:01.000000000 +0200
@@ -93,9 +93,9 @@
--- a/ipkg.py
+++ b/ipkg.py
@@ -93,9 +93,9 @@ class Package:
self.filename = os.path.basename(fn)
## sys.stderr.write(" extracting control.tar.gz from %s\n"% (fn,))
if self.isdeb:
@ -12,7 +12,7 @@
line = control.readline()
while 1:
if not line: break
@@ -122,7 +122,7 @@
@@ -122,7 +122,7 @@ class Package:
if self.isdeb:
data = os.popen("ar p "+fn+" data.tar.gz | tar tfz -","r")
else:

@ -1,8 +1,6 @@
Index: ipkg-utils-1.7/ipkg-build
===================================================================
--- ipkg-utils-1.7.orig/ipkg-build 2007-06-30 15:21:37.621213250 +0200
+++ ipkg-utils-1.7/ipkg-build 2007-06-30 15:21:51.862103250 +0200
@@ -11,6 +11,8 @@
--- a/ipkg-build
+++ b/ipkg-build
@@ -11,6 +11,8 @@ set -e
version=1.0
@ -11,10 +9,8 @@ Index: ipkg-utils-1.7/ipkg-build
ipkg_extract_value() {
sed -e "s/^[^:]*:[[:space:]]*//"
}
Index: ipkg-utils-1.7/ipkg-make-index
===================================================================
--- ipkg-utils-1.7.orig/ipkg-make-index 2007-06-30 15:21:37.225188500 +0200
+++ ipkg-utils-1.7/ipkg-make-index 2007-06-30 15:21:51.866103500 +0200
--- a/ipkg-make-index
+++ b/ipkg-make-index
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python

@ -1,8 +1,6 @@
Index: ipkg-utils-1.7/ipkg-build
===================================================================
--- ipkg-utils-1.7.orig/ipkg-build 2007-07-21 03:10:58.228362436 +0200
+++ ipkg-utils-1.7/ipkg-build 2007-07-21 03:11:02.912629374 +0200
@@ -133,7 +133,7 @@
--- a/ipkg-build
+++ b/ipkg-build
@@ -133,7 +133,7 @@ You probably want to chown these to a sy
disallowed_filename=`disallowed_field Filename`
[ "$?" -ne 0 ] && PKG_ERROR=1
@ -11,11 +9,9 @@ Index: ipkg-utils-1.7/ipkg-build
echo "*** Error: Package name $name contains illegal characters, (other than [a-z0-9.+-])" >&2
PKG_ERROR=1;
fi
Index: ipkg-utils-1.7/ipkg-buildpackage
===================================================================
--- ipkg-utils-1.7.orig/ipkg-buildpackage 2007-07-21 03:10:43.859543602 +0200
+++ ipkg-utils-1.7/ipkg-buildpackage 2007-07-21 03:10:52.212019583 +0200
@@ -69,7 +69,7 @@
--- a/ipkg-buildpackage
+++ b/ipkg-buildpackage
@@ -69,7 +69,7 @@ pkg_appears_sane_control() {
required_field Maintainer >/dev/null
required_field Description >/dev/null

@ -1,5 +1,5 @@
--- /tmp/ipkg-build 2008-08-01 09:36:41.000000000 +0200
+++ ipkg-utils-1.7/ipkg-build 2008-08-06 15:04:52.000000000 +0200
--- a/ipkg-build
+++ b/ipkg-build
@@ -10,7 +10,8 @@
set -e
@ -10,7 +10,7 @@
TAR="${TAR:-$(which tar)}"
ipkg_extract_value() {
@@ -49,7 +50,7 @@
@@ -49,7 +50,7 @@ pkg_appears_sane() {
PKG_ERROR=0
@ -19,7 +19,7 @@
if [ -n "$cvs_dirs" ]; then
if [ "$noclean" = "1" ]; then
echo "*** Warning: The following CVS directories where found.
@@ -62,7 +63,7 @@
@@ -62,7 +63,7 @@ You probably want to remove them: " >&2
fi
fi
@ -28,7 +28,7 @@
if [ -n "$tilde_files" ]; then
if [ "$noclean" = "1" ]; then
echo "*** Warning: The following files have names ending in '~'.
@@ -75,7 +76,7 @@
@@ -75,7 +76,7 @@ You probably want to remove them: " >&2
fi
fi

File diff suppressed because it is too large Load Diff

@ -1,8 +1,6 @@
Index: lua-5.1.3/src/lua.h
===================================================================
--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
+++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
@@ -79,7 +79,7 @@
--- a/src/lua.h
+++ b/src/lua.h
@@ -79,7 +79,7 @@ typedef void * (*lua_Alloc) (void *ud, v
* not acceptable for 5.1, maybe 5.2 onwards?
* 9: greater than existing (5.1) type values.
*/

@ -1,8 +1,6 @@
Index: lua-5.1.4/Makefile
===================================================================
--- lua-5.1.4.orig/Makefile 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/Makefile 2008-08-24 16:48:42.000000000 +0200
@@ -42,8 +42,8 @@
--- a/Makefile
+++ b/Makefile
@@ -42,8 +42,8 @@ PLATS= aix ansi bsd freebsd generic linu
# What to install.
TO_BIN= lua luac
@ -13,7 +11,7 @@ Index: lua-5.1.4/Makefile
TO_MAN= lua.1 luac.1
# Lua version and release.
@@ -63,6 +63,7 @@
@@ -63,6 +63,7 @@ install: dummy
cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
@ -21,11 +19,9 @@ Index: lua-5.1.4/Makefile
cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
ranlib:
Index: lua-5.1.4/src/ldo.h
===================================================================
--- lua-5.1.4.orig/src/ldo.h 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/src/ldo.h 2008-08-24 16:48:42.000000000 +0200
@@ -46,7 +46,7 @@
--- a/src/ldo.h
+++ b/src/ldo.h
@@ -46,7 +46,7 @@ LUAI_FUNC int luaD_pcall (lua_State *L,
LUAI_FUNC int luaD_poscall (lua_State *L, StkId firstResult);
LUAI_FUNC void luaD_reallocCI (lua_State *L, int newsize);
LUAI_FUNC void luaD_reallocstack (lua_State *L, int newsize);
@ -34,10 +30,8 @@ Index: lua-5.1.4/src/ldo.h
LUAI_FUNC void luaD_throw (lua_State *L, int errcode);
LUAI_FUNC int luaD_rawrunprotected (lua_State *L, Pfunc f, void *ud);
Index: lua-5.1.4/src/lfunc.h
===================================================================
--- lua-5.1.4.orig/src/lfunc.h 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/src/lfunc.h 2008-08-24 16:48:42.000000000 +0200
--- a/src/lfunc.h
+++ b/src/lfunc.h
@@ -18,7 +18,7 @@
cast(int, sizeof(TValue *)*((n)-1)))
@ -47,10 +41,8 @@ Index: lua-5.1.4/src/lfunc.h
LUAI_FUNC Closure *luaF_newCclosure (lua_State *L, int nelems, Table *e);
LUAI_FUNC Closure *luaF_newLclosure (lua_State *L, int nelems, Table *e);
LUAI_FUNC UpVal *luaF_newupval (lua_State *L);
Index: lua-5.1.4/src/lmem.h
===================================================================
--- lua-5.1.4.orig/src/lmem.h 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/src/lmem.h 2008-08-24 16:48:42.000000000 +0200
--- a/src/lmem.h
+++ b/src/lmem.h
@@ -38,9 +38,9 @@
((v)=cast(t *, luaM_reallocv(L, v, oldn, n, sizeof(t))))
@ -63,10 +55,8 @@ Index: lua-5.1.4/src/lmem.h
LUAI_FUNC void *luaM_growaux_ (lua_State *L, void *block, int *size,
size_t size_elem, int limit,
const char *errormsg);
Index: lua-5.1.4/src/lstring.h
===================================================================
--- lua-5.1.4.orig/src/lstring.h 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/src/lstring.h 2008-08-24 16:48:42.000000000 +0200
--- a/src/lstring.h
+++ b/src/lstring.h
@@ -25,7 +25,7 @@
LUAI_FUNC void luaS_resize (lua_State *L, int newsize);
@ -76,11 +66,9 @@ Index: lua-5.1.4/src/lstring.h
#endif
Index: lua-5.1.4/src/lundump.h
===================================================================
--- lua-5.1.4.orig/src/lundump.h 2008-08-24 16:46:37.000000000 +0200
+++ lua-5.1.4/src/lundump.h 2008-08-24 16:48:42.000000000 +0200
@@ -17,7 +17,7 @@
--- a/src/lundump.h
+++ b/src/lundump.h
@@ -17,7 +17,7 @@ LUAI_FUNC Proto* luaU_undump (lua_State*
LUAI_FUNC void luaU_header (char* h);
/* dump one chunk; from ldump.c */
@ -89,11 +77,9 @@ Index: lua-5.1.4/src/lundump.h
#ifdef luac_c
/* print one chunk; from print.c */
Index: lua-5.1.4/src/Makefile
===================================================================
--- lua-5.1.4.orig/src/Makefile 2008-08-24 16:48:20.000000000 +0200
+++ lua-5.1.4/src/Makefile 2008-08-24 16:48:42.000000000 +0200
@@ -23,6 +23,7 @@
--- a/src/Makefile
+++ b/src/Makefile
@@ -23,6 +23,7 @@ MYLIBS=
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
LUA_A= liblua.a
@ -101,7 +87,7 @@ Index: lua-5.1.4/src/Makefile
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
lundump.o lvm.o lzio.o lnum.o
@@ -33,11 +34,12 @@
@@ -33,11 +34,12 @@ LUA_T= lua
LUA_O= lua.o
LUAC_T= luac
@ -116,7 +102,7 @@ Index: lua-5.1.4/src/Makefile
default: $(PLAT)
@@ -47,14 +49,23 @@
@@ -47,14 +49,23 @@ o: $(ALL_O)
a: $(ALL_A)
@ -143,7 +129,7 @@ Index: lua-5.1.4/src/Makefile
$(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
clean:
@@ -96,7 +107,7 @@
@@ -96,7 +107,7 @@ generic:
$(MAKE) all MYCFLAGS=
linux:

@ -1,8 +1,6 @@
Index: lua-5.1.4/src/ldump.c
===================================================================
--- lua-5.1.4.orig/src/ldump.c 2008-08-24 16:48:20.000000000 +0200
+++ lua-5.1.4/src/ldump.c 2008-08-24 16:48:52.000000000 +0200
@@ -67,12 +67,12 @@
--- a/src/ldump.c
+++ b/src/ldump.c
@@ -67,12 +67,12 @@ static void DumpString(const TString* s,
{
if (s==NULL || getstr(s)==NULL)
{
@ -17,11 +15,9 @@ Index: lua-5.1.4/src/ldump.c
DumpVar(size,D);
DumpBlock(getstr(s),size,D);
}
Index: lua-5.1.4/src/lundump.c
===================================================================
--- lua-5.1.4.orig/src/lundump.c 2008-08-24 16:48:20.000000000 +0200
+++ lua-5.1.4/src/lundump.c 2008-08-24 16:48:52.000000000 +0200
@@ -25,6 +25,7 @@
--- a/src/lundump.c
+++ b/src/lundump.c
@@ -25,6 +25,7 @@ typedef struct {
ZIO* Z;
Mbuffer* b;
const char* name;
@ -29,7 +25,7 @@ Index: lua-5.1.4/src/lundump.c
} LoadState;
#ifdef LUAC_TRUST_BINARIES
@@ -40,7 +41,6 @@
@@ -40,7 +41,6 @@ static void error(LoadState* S, const ch
}
#endif
@ -37,7 +33,7 @@ Index: lua-5.1.4/src/lundump.c
#define LoadByte(S) (lu_byte)LoadChar(S)
#define LoadVar(S,x) LoadMem(S,&x,1,sizeof(x))
#define LoadVector(S,b,n,size) LoadMem(S,b,n,size)
@@ -51,6 +51,49 @@
@@ -51,6 +51,49 @@ static void LoadBlock(LoadState* S, void
IF (r!=0, "unexpected end");
}
@ -87,7 +83,7 @@ Index: lua-5.1.4/src/lundump.c
static int LoadChar(LoadState* S)
{
char x;
@@ -82,7 +125,7 @@
@@ -82,7 +125,7 @@ static lua_Integer LoadInteger(LoadState
static TString* LoadString(LoadState* S)
{
@ -96,7 +92,7 @@ Index: lua-5.1.4/src/lundump.c
LoadVar(S,size);
if (size==0)
return NULL;
@@ -196,6 +239,7 @@
@@ -196,6 +239,7 @@ static void LoadHeader(LoadState* S)
char s[LUAC_HEADERSIZE];
luaU_header(h);
LoadBlock(S,s,LUAC_HEADERSIZE);
@ -104,7 +100,7 @@ Index: lua-5.1.4/src/lundump.c
IF (memcmp(h,s,LUAC_HEADERSIZE)!=0, "bad header");
}
@@ -230,7 +274,7 @@
@@ -230,7 +274,7 @@ void luaU_header (char* h)
*h++=(char)LUAC_FORMAT;
*h++=(char)*(char*)&x; /* endianness */
*h++=(char)sizeof(int);

@ -1,6 +1,5 @@
diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
--- lua-luci-5.1.3/src/luaconf.h 2008-04-14 13:19:54.000000000 +0200
+++ lua-luci-5.1.3-new/src/luaconf.h 2008-04-14 13:19:17.000000000 +0200
--- a/src/luaconf.h
+++ b/src/luaconf.h
@@ -38,7 +38,6 @@
#if defined(LUA_USE_LINUX)
#define LUA_USE_POSIX
@ -9,11 +8,9 @@ diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
#endif
#if defined(LUA_USE_MACOSX)
Nur in lua-luci-5.1.3-new/src: luaconf.h.orig.
diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
--- lua-luci-5.1.3/src/Makefile 2008-04-14 13:19:57.000000000 +0200
+++ lua-luci-5.1.3-new/src/Makefile 2008-04-14 13:19:17.000000000 +0200
@@ -17,6 +17,7 @@
--- a/src/Makefile
+++ b/src/Makefile
@@ -17,6 +17,7 @@ LIBS= -lm $(MYLIBS)
MYCFLAGS=
MYLDFLAGS=
MYLIBS=
@ -21,7 +18,7 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
# == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
@@ -86,7 +87,7 @@
@@ -86,7 +87,7 @@ echo:
@echo "MYLIBS = $(MYLIBS)"
# convenience targets for popular platforms
@ -30,7 +27,7 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
none:
@echo "Please choose a platform:"
@echo " $(PLATS)"
@@ -101,16 +102,16 @@
@@ -101,16 +102,16 @@ bsd:
$(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
freebsd:
@ -50,4 +47,3 @@ diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
# use this on Mac OS X 10.3-
# $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
Nur in lua-luci-5.1.3-new/src: Makefile.orig.

@ -1,5 +1,5 @@
--- b/src/luaconf.h 2008-05-06 20:10:46.000000000 +0200
+++ a/src/luaconf.h 2008-05-06 20:10:27.000000000 +0200
--- a/src/luaconf.h
+++ b/src/luaconf.h
@@ -95,9 +95,9 @@
".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"

@ -10,7 +10,7 @@
/*
* If 'obj' is a string, it is tried to be interpreted as a number.
@@ -562,12 +565,63 @@
@@ -562,12 +565,63 @@ static inline int arith_mode( const TVal
ARITH_OP1_END
#endif
@ -74,7 +74,7 @@
reentry: /* entry point */
lua_assert(isLua(L->ci));
pc = L->savedpc;
@@ -592,33 +646,33 @@
@@ -592,33 +646,33 @@ void luaV_execute (lua_State *L, int nex
lua_assert(base == L->base && L->base == L->ci->base);
lua_assert(base <= L->top && L->top <= L->stack + L->stacksize);
lua_assert(L->top == L->ci->top || luaG_checkopenop(i));
@ -115,7 +115,7 @@
TValue g;
TValue *rb = KBx(i);
sethvalue(L, &g, cl->env);
@@ -626,88 +680,88 @@
@@ -626,88 +680,88 @@ void luaV_execute (lua_State *L, int nex
Protect(luaV_gettable(L, &g, rb, ra));
continue;
}
@ -219,7 +219,7 @@
const TValue *rb = RB(i);
switch (ttype(rb)) {
case LUA_TTABLE: {
@@ -727,18 +781,18 @@
@@ -727,18 +781,18 @@ void luaV_execute (lua_State *L, int nex
}
continue;
}
@ -241,7 +241,7 @@
TValue *rb = RKB(i);
TValue *rc = RKC(i);
Protect(
@@ -748,7 +802,7 @@
@@ -748,7 +802,7 @@ void luaV_execute (lua_State *L, int nex
pc++;
continue;
}
@ -250,7 +250,7 @@
Protect(
if (luaV_lessthan(L, RKB(i), RKC(i)) == GETARG_A(i))
dojump(L, pc, GETARG_sBx(*pc));
@@ -756,7 +810,7 @@
@@ -756,7 +810,7 @@ void luaV_execute (lua_State *L, int nex
pc++;
continue;
}
@ -259,7 +259,7 @@
Protect(
if (lessequal(L, RKB(i), RKC(i)) == GETARG_A(i))
dojump(L, pc, GETARG_sBx(*pc));
@@ -764,13 +818,13 @@
@@ -764,13 +818,13 @@ void luaV_execute (lua_State *L, int nex
pc++;
continue;
}
@ -275,7 +275,7 @@
TValue *rb = RB(i);
if (l_isfalse(rb) != GETARG_C(i)) {
setobjs2s(L, ra, rb);
@@ -779,7 +833,7 @@
@@ -779,7 +833,7 @@ void luaV_execute (lua_State *L, int nex
pc++;
continue;
}
@ -284,7 +284,7 @@
int b = GETARG_B(i);
int nresults = GETARG_C(i) - 1;
if (b != 0) L->top = ra+b; /* else previous instruction set top */
@@ -800,7 +854,7 @@
@@ -800,7 +854,7 @@ void luaV_execute (lua_State *L, int nex
}
}
}
@ -293,7 +293,7 @@
int b = GETARG_B(i);
if (b != 0) L->top = ra+b; /* else previous instruction set top */
L->savedpc = pc;
@@ -832,7 +886,7 @@
@@ -832,7 +886,7 @@ void luaV_execute (lua_State *L, int nex
}
}
}
@ -302,7 +302,7 @@
int b = GETARG_B(i);
if (b != 0) L->top = ra+b-1;
if (L->openupval) luaF_close(L, base);
@@ -847,7 +901,7 @@
@@ -847,7 +901,7 @@ void luaV_execute (lua_State *L, int nex
goto reentry;
}
}
@ -311,7 +311,7 @@
/* If start,step and limit are all integers, we don't need to check
* against overflow in the looping.
*/
@@ -875,7 +929,7 @@
@@ -875,7 +929,7 @@ void luaV_execute (lua_State *L, int nex
}
continue;
}
@ -320,7 +320,7 @@
const TValue *init = ra;
const TValue *plimit = ra+1;
const TValue *pstep = ra+2;
@@ -898,7 +952,7 @@
@@ -898,7 +952,7 @@ void luaV_execute (lua_State *L, int nex
dojump(L, pc, GETARG_sBx(i));
continue;
}
@ -329,7 +329,7 @@
StkId cb = ra + 3; /* call base */
setobjs2s(L, cb+2, ra+2);
setobjs2s(L, cb+1, ra+1);
@@ -914,7 +968,7 @@
@@ -914,7 +968,7 @@ void luaV_execute (lua_State *L, int nex
pc++;
continue;
}
@ -338,7 +338,7 @@
int n = GETARG_B(i);
int c = GETARG_C(i);
int last;
@@ -936,11 +990,11 @@
@@ -936,11 +990,11 @@ void luaV_execute (lua_State *L, int nex
}
continue;
}
@ -352,7 +352,7 @@
Proto *p;
Closure *ncl;
int nup, j;
@@ -960,7 +1014,7 @@
@@ -960,7 +1014,7 @@ void luaV_execute (lua_State *L, int nex
Protect(luaC_checkGC(L));
continue;
}

@ -1,7 +1,6 @@
diff -Nur lzma/C/7zip/Compress/LZMA/LZMADecoder.cpp lzma.patched/C/7zip/Compress/LZMA/LZMADecoder.cpp
--- lzma/C/7zip/Compress/LZMA/LZMADecoder.cpp 2005-09-22 10:55:34.000000000 +0200
+++ lzma.patched/C/7zip/Compress/LZMA/LZMADecoder.cpp 2006-03-25 11:04:53.000000000 +0100
@@ -274,12 +274,17 @@
--- a/C/7zip/Compress/LZMA/LZMADecoder.cpp
+++ b/C/7zip/Compress/LZMA/LZMADecoder.cpp
@@ -274,12 +274,17 @@ STDMETHODIMP CDecoder::SetDecoderPropert
Byte remainder = (Byte)(properties[0] / 9);
int lp = remainder % 5;
int pb = remainder / 5;
@ -22,10 +21,9 @@ diff -Nur lzma/C/7zip/Compress/LZMA/LZMADecoder.cpp lzma.patched/C/7zip/Compress
if (!_outWindowStream.Create(dictionarySize))
return E_OUTOFMEMORY;
if (!_literalDecoder.Create(lp, lc))
diff -Nur lzma/C/7zip/Compress/LZMA/LZMADecoder.h lzma.patched/C/7zip/Compress/LZMA/LZMADecoder.h
--- lzma/C/7zip/Compress/LZMA/LZMADecoder.h 2005-09-19 08:10:06.000000000 +0200
+++ lzma.patched/C/7zip/Compress/LZMA/LZMADecoder.h 2006-03-25 11:04:53.000000000 +0100
@@ -228,6 +228,7 @@
--- a/C/7zip/Compress/LZMA/LZMADecoder.h
+++ b/C/7zip/Compress/LZMA/LZMADecoder.h
@@ -228,6 +228,7 @@ public:
ICompressProgressInfo *progress);
STDMETHOD(SetDecoderProperties2)(const Byte *data, UInt32 size);
@ -33,9 +31,8 @@ diff -Nur lzma/C/7zip/Compress/LZMA/LZMADecoder.h lzma.patched/C/7zip/Compress/L
STDMETHOD(GetInStreamProcessedSize)(UInt64 *value);
diff -Nur lzma/C/7zip/Compress/LZMA_Lib/makefile lzma.patched/C/7zip/Compress/LZMA_Lib/makefile
--- lzma/C/7zip/Compress/LZMA_Lib/makefile 1970-01-01 01:00:00.000000000 +0100
+++ lzma.patched/C/7zip/Compress/LZMA_Lib/makefile 2006-03-25 11:29:46.000000000 +0100
--- /dev/null
+++ b/C/7zip/Compress/LZMA_Lib/makefile
@@ -0,0 +1,92 @@
+PROG = liblzma.a
+CXX = g++ -O3 -Wall
@ -129,9 +126,8 @@ diff -Nur lzma/C/7zip/Compress/LZMA_Lib/makefile lzma.patched/C/7zip/Compress/LZ
+clean:
+ -$(RM) $(PROG) $(OBJS)
+
diff -Nur lzma/C/7zip/Compress/LZMA_Lib/ZLib.cpp lzma.patched/C/7zip/Compress/LZMA_Lib/ZLib.cpp
--- lzma/C/7zip/Compress/LZMA_Lib/ZLib.cpp 1970-01-01 01:00:00.000000000 +0100
+++ lzma.patched/C/7zip/Compress/LZMA_Lib/ZLib.cpp 2006-03-25 11:04:53.000000000 +0100
--- /dev/null
+++ b/C/7zip/Compress/LZMA_Lib/ZLib.cpp
@@ -0,0 +1,273 @@
+/*
+ * lzma zlib simplified wrapper

@ -1,8 +1,6 @@
Index: lzma/C/7zip/Compress/LZMA_Lib/makefile
===================================================================
--- lzma.orig/C/7zip/Compress/LZMA_Lib/makefile 2007-12-02 23:37:08.000000000 +0100
+++ lzma/C/7zip/Compress/LZMA_Lib/makefile 2007-12-02 23:38:40.000000000 +0100
@@ -29,6 +29,7 @@
--- a/C/7zip/Compress/LZMA_Lib/makefile
+++ b/C/7zip/Compress/LZMA_Lib/makefile
@@ -29,6 +29,7 @@ all: $(PROG)
$(PROG): $(OBJS)
$(AR) r $(PROG) $(OBJS)

@ -1,6 +1,5 @@
diff -urN mtd-20050122.orig.old/include/mtd/jffs2-user.h mtd-20050122.orig.dev/include/mtd/jffs2-user.h
--- mtd-20050122.orig.old/include/mtd/jffs2-user.h 2004-05-05 13:57:54.000000000 +0200
+++ mtd-20050122.orig.dev/include/mtd/jffs2-user.h 2005-07-02 10:03:09.000000000 +0200
--- a/include/mtd/jffs2-user.h
+++ b/include/mtd/jffs2-user.h
@@ -19,8 +19,6 @@
#undef je32_to_cpu
#undef jemode_to_cpu
@ -10,10 +9,9 @@ diff -urN mtd-20050122.orig.old/include/mtd/jffs2-user.h mtd-20050122.orig.dev/i
#define t16(x) ({ uint16_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_16(__b); })
#define t32(x) ({ uint32_t __b = (x); (target_endian==__BYTE_ORDER)?__b:bswap_32(__b); })
diff -urN mtd.old/util/jffs3.h mtd.dev/util/jffs3.h
--- mtd.old/util/jffs3.h 2005-01-22 00:00:13.000000000 +0100
+++ mtd.dev/util/jffs3.h 2005-07-17 17:48:24.000000000 +0200
@@ -177,8 +177,6 @@
--- a/util/jffs3.h
+++ b/util/jffs3.h
@@ -177,8 +177,6 @@ union jffs3_node_union {
#undef je32_to_cpu
#undef jemode_to_cpu

@ -1,13 +1,11 @@
diff -urN mtd.old/include/asm/types.h mtd.dev/include/asm/types.h
--- mtd.old/include/asm/types.h 1970-01-01 01:00:00.000000000 +0100
+++ mtd.dev/include/asm/types.h 2006-09-27 16:50:03.000000000 +0200
--- /dev/null
+++ b/include/asm/types.h
@@ -0,0 +1,3 @@
+#ifdef linux
+#include_next <asm/types.h>
+#endif
diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
--- mtd.old/util/mkfs.jffs2.c 2004-11-27 00:00:13.000000000 +0100
+++ mtd.dev/util/mkfs.jffs2.c 2006-09-27 16:51:56.000000000 +0200
--- a/util/mkfs.jffs2.c
+++ b/util/mkfs.jffs2.c
@@ -68,6 +68,7 @@
#include <zlib.h>
#undef crc32
@ -16,7 +14,7 @@ diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
/* Do not use the wierd XPG version of basename */
#undef basename
@@ -1032,7 +1033,7 @@
@@ -1032,7 +1033,7 @@ static void recursive_populate_directory
case S_IFDIR:
if (verbose) {
printf("\td %04o %9lu %5d:%-3d %s\n",
@ -25,7 +23,7 @@ diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
(int) (e->sb.st_uid), (int) (e->sb.st_gid),
e->name);
}
@@ -1041,7 +1042,7 @@
@@ -1041,7 +1042,7 @@ static void recursive_populate_directory
case S_IFSOCK:
if (verbose) {
printf("\ts %04o %9lu %5d:%-3d %s\n",
@ -34,7 +32,7 @@ diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
(int) e->sb.st_uid, (int) e->sb.st_gid, e->name);
}
write_pipe(e);
@@ -1049,7 +1050,7 @@
@@ -1049,7 +1050,7 @@ static void recursive_populate_directory
case S_IFIFO:
if (verbose) {
printf("\tp %04o %9lu %5d:%-3d %s\n",
@ -43,7 +41,7 @@ diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
(int) e->sb.st_uid, (int) e->sb.st_gid, e->name);
}
write_pipe(e);
@@ -1075,7 +1076,7 @@
@@ -1075,7 +1076,7 @@ static void recursive_populate_directory
case S_IFLNK:
if (verbose) {
printf("\tl %04o %9lu %5d:%-3d %s -> %s\n",
@ -52,7 +50,7 @@ diff -urN mtd.old/util/mkfs.jffs2.c mtd.dev/util/mkfs.jffs2.c
(int) e->sb.st_uid, (int) e->sb.st_gid, e->name,
e->link);
}
@@ -1084,7 +1085,7 @@
@@ -1084,7 +1085,7 @@ static void recursive_populate_directory
case S_IFREG:
if (verbose) {
printf("\tf %04o %9lu %5d:%-3d %s\n",

@ -6,7 +6,7 @@
CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
@@ -7,6 +8,9 @@
@@ -7,6 +8,9 @@ all: mksquashfs unsquashfs
mksquashfs: mksquashfs.o read_fs.o sort.o
$(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
@ -16,7 +16,7 @@
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
@@ -16,4 +20,9 @@
@@ -16,4 +20,9 @@ sort.o: sort.c squashfs_fs.h global.h so
unsquashfs: unsquashfs.o
$(CC) unsquashfs.o -lz -o $@

Loading…
Cancel
Save