kernel: update 3.14 to 3.14.10

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 41533
v19.07.3_mercusys_ac12_duma
Luka Perkov 10 years ago
parent ce0f954947
commit 354a1042cc

@ -23,8 +23,8 @@ endif
ifeq ($(LINUX_VERSION),3.13.7)
LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
endif
ifeq ($(LINUX_VERSION),3.14.9)
LINUX_KERNEL_MD5SUM:=62b80f9ab490db3bfe0b308a0d3f6f1f
ifeq ($(LINUX_VERSION),3.14.10)
LINUX_KERNEL_MD5SUM:=3ca34a93c59a788d7f573b2660eb5342
endif
# disable the md5sum check for unknown kernel versions

@ -197,7 +197,7 @@
}
#endif
@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@ -205,7 +205,7 @@
struct sk_buff *skb2 = skb;
const struct iphdr *iph;
struct igmphdr *ih;
@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
case IGMP_HOST_MEMBERSHIP_REPORT:
case IGMPV2_HOST_MEMBERSHIP_REPORT:
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@ -214,7 +214,7 @@
break;
case IGMPV3_HOST_MEMBERSHIP_REPORT:
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
err = br_ip4_multicast_query(br, port, skb2, vid);
break;
case IGMP_HOST_LEAVE_MESSAGE:
@ -223,7 +223,7 @@
break;
}
@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@ -231,7 +231,7 @@
struct sk_buff *skb2;
const struct ipv6hdr *ip6h;
u8 icmp6_type;
@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
}
mld = (struct mld_msg *)skb_transport_header(skb2);
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@ -241,7 +241,7 @@
break;
}
case ICMPV6_MLD2_REPORT:
@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
goto out;
}
mld = (struct mld_msg *)skb_transport_header(skb2);

@ -39,7 +39,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
@@ -1070,3 +1085,4 @@ static void quirk_usb_early_handoff(stru
@@ -1083,3 +1098,4 @@ static void quirk_usb_early_handoff(stru
}
DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);

@ -1,6 +1,6 @@
--- a/mm/Kconfig
+++ b/mm/Kconfig
@@ -554,7 +554,7 @@ config MEM_SOFT_DIRTY
@@ -557,7 +557,7 @@ config MEM_SOFT_DIRTY
See Documentation/vm/soft-dirty.txt for more details.
config ZSMALLOC

@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
LINUX_VERSION:=3.14.9
LINUX_VERSION:=3.14.10
include $(INCLUDE_DIR)/target.mk

@ -12,7 +12,7 @@ BOARDNAME:=x86_64
FEATURES:=ext4 vdi vmdk targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=3.14.9
LINUX_VERSION:=3.14.10
KERNELNAME:=bzImage

Loading…
Cancel
Save