kernel: remove already upstream applied patch

Remove 131-MIPS-export-get_c0_perfcount_int.patch which was already applied
in 4.1.6. This fixes the following build error:

arch/mips/ath79/setup.c:217:77: error: redefinition of '__kstrtab_get_c0_perfcount_int'
arch/mips/ath79/setup.c:211:77: note: previous definition of '__kstrtab_get_c0_perfcount_int' was here
arch/mips/ath79/setup.c:217:350: error: redefinition of '__ksymtab_get_c0_perfcount_int'
arch/mips/ath79/setup.c:211:350: note: previous definition of '__ksymtab_get_c0_perfcount_int' was here
scripts/Makefile.build:258: recipe for target 'arch/mips/ath79/setup.o' failed

Reported-by: swalker
Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 46715
v19.07.3_mercusys_ac12_duma
Jonas Gorski 9 years ago
parent 548630d74e
commit 2d53e22357

@ -1,73 +0,0 @@
From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 23 Jul 2015 18:54:49 +0200
Subject: [PATCH] MIPS: export get_c0_perfcount_int()
get_c0_perfcount_int is tested from oprofile code. If oprofile is
compiled as module, get_c0_perfcount_int needs to be exported, otherwise
it cannot be resolved.
Fixes: a669efc4a3b4 ("MIPS: Add hook to get C0 performance counter interrupt")
Cc: stable@vger.kernel.org # v3.19+
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
---
--- a/arch/mips/ath79/setup.c
+++ b/arch/mips/ath79/setup.c
@@ -181,6 +181,7 @@ const char *get_system_type(void)
{
return ath79_sys_type;
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
int get_c0_perfcount_int(void)
{
--- a/arch/mips/lantiq/irq.c
+++ b/arch/mips/lantiq/irq.c
@@ -461,6 +461,7 @@ int __init icu_of_init(struct device_nod
return 0;
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
int get_c0_perfcount_int(void)
{
--- a/arch/mips/mti-malta/malta-time.c
+++ b/arch/mips/mti-malta/malta-time.c
@@ -163,6 +163,7 @@ unsigned int get_c0_compare_int(void)
return mips_cpu_timer_irq;
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
static void __init init_rtc(void)
{
--- a/arch/mips/mti-sead3/sead3-time.c
+++ b/arch/mips/mti-sead3/sead3-time.c
@@ -85,6 +85,7 @@ unsigned int get_c0_compare_int(void)
return gic_get_c0_compare_int();
return MIPS_CPU_IRQ_BASE + cp0_compare_irq;
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
void __init plat_time_init(void)
{
--- a/arch/mips/pistachio/time.c
+++ b/arch/mips/pistachio/time.c
@@ -21,6 +21,7 @@ unsigned int get_c0_compare_int(void)
{
return gic_get_c0_compare_int();
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
int get_c0_perfcount_int(void)
{
--- a/arch/mips/ralink/irq.c
+++ b/arch/mips/ralink/irq.c
@@ -95,6 +95,7 @@ unsigned int get_c0_compare_int(void)
{
return CP0_LEGACY_COMPARE_IRQ;
}
+EXPORT_SYMBOL_GPL(get_c0_perfcount_int);
static void ralink_intc_irq_handler(unsigned int irq, struct irq_desc *desc)
{
Loading…
Cancel
Save