ar71xx: refresh 4.1 patches

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 46427
v19.07.3_mercusys_ac12_duma
Felix Fietkau 9 years ago
parent 78b1a6b773
commit 2a74944f07

@ -1,6 +1,6 @@
--- a/lib/Kconfig
+++ b/lib/Kconfig
@@ -233,6 +233,9 @@ config LZMA_COMPRESS
@@ -241,6 +241,9 @@ config LZMA_COMPRESS
config LZMA_DECOMPRESS
tristate
@ -12,7 +12,7 @@
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -97,6 +97,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
@@ -101,6 +101,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
obj-$(CONFIG_RAID6_PQ) += raid6/
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -246,7 +246,9 @@ static int m25p_probe(struct spi_device
@@ -234,7 +234,9 @@ static int m25p_probe(struct spi_device
ppdata.of_node = spi->dev.of_node;

@ -1,8 +1,8 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -516,4 +516,8 @@ config MTD_NAND_XWAY
Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
to the External Bus Unit (EBU).
@@ -530,4 +530,8 @@ config MTD_NAND_HISI504
help
Enables support for NAND controller on Hisilicon SoC Hip04.
+config MTD_NAND_RB4XX
+ tristate "NAND flash driver for RouterBoard 4xx series"

@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -520,4 +520,8 @@ config MTD_NAND_RB4XX
@@ -534,4 +534,8 @@ config MTD_NAND_RB4XX
tristate "NAND flash driver for RouterBoard 4xx series"
depends on MTD_NAND && ATH79_MACH_RB4XX

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -244,6 +244,7 @@ static int m25p_probe(struct spi_device
@@ -232,6 +232,7 @@ static int m25p_probe(struct spi_device
if (ret)
return ret;

@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -524,4 +524,12 @@ config MTD_NAND_RB750
@@ -538,4 +538,12 @@ config MTD_NAND_RB750
tristate "NAND flash driver for the RouterBoard 750"
depends on MTD_NAND && ATH79_MACH_RB750

@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -524,6 +524,10 @@ config MTD_NAND_RB750
@@ -538,6 +538,10 @@ config MTD_NAND_RB750
tristate "NAND flash driver for the RouterBoard 750"
depends on MTD_NAND && ATH79_MACH_RB750

@ -1,6 +1,6 @@
--- a/net/dsa/tag_trailer.c
+++ b/net/dsa/tag_trailer.c
@@ -86,7 +86,7 @@ static int trailer_rcv(struct sk_buff *s
@@ -84,7 +84,7 @@ static int trailer_rcv(struct sk_buff *s
trailer = skb_tail_pointer(skb) - 4;
if (trailer[0] != 0x80 || (trailer[1] & 0xf8) != 0x00 ||

@ -84,7 +84,7 @@
/* save relevant PHY registers to private copy */
static void at803x_context_save(struct phy_device *phydev,
struct at803x_context *context)
@@ -208,8 +256,16 @@ static int at803x_probe(struct phy_devic
@@ -209,8 +257,16 @@ static int at803x_probe(struct phy_devic
return 0;
}
@ -101,7 +101,7 @@
int ret;
ret = genphy_config_init(phydev);
@@ -227,6 +283,26 @@ static int at803x_config_init(struct phy
@@ -228,6 +284,26 @@ static int at803x_config_init(struct phy
return ret;
}
@ -128,7 +128,7 @@
return 0;
}
@@ -258,6 +334,8 @@ static int at803x_config_intr(struct phy
@@ -259,6 +335,8 @@ static int at803x_config_intr(struct phy
static void at803x_link_change_notify(struct phy_device *phydev)
{
struct at803x_priv *priv = phydev->priv;
@ -137,7 +137,7 @@
/*
* Conduct a hardware reset for AT8030 every time a link loss is
@@ -288,6 +366,26 @@ static void at803x_link_change_notify(st
@@ -289,6 +367,26 @@ static void at803x_link_change_notify(st
priv->phy_reset = false;
}
}

@ -1,6 +1,6 @@
--- a/drivers/Makefile
+++ b/drivers/Makefile
@@ -68,8 +68,8 @@ obj-$(CONFIG_IDE) += ide/
@@ -71,8 +71,8 @@ obj-$(CONFIG_IDE) += ide/
obj-$(CONFIG_SCSI) += scsi/
obj-$(CONFIG_ATA) += ata/
obj-$(CONFIG_TARGET_CORE) += target/

@ -1,6 +1,6 @@
--- a/include/linux/spi/spi.h
+++ b/include/linux/spi/spi.h
@@ -620,6 +620,8 @@ struct spi_transfer {
@@ -618,6 +618,8 @@ struct spi_transfer {
unsigned cs_change:1;
unsigned tx_nbits:3;
unsigned rx_nbits:3;
@ -9,7 +9,7 @@
#define SPI_NBITS_SINGLE 0x01 /* 1bit transfer */
#define SPI_NBITS_DUAL 0x02 /* 2bits transfer */
#define SPI_NBITS_QUAD 0x04 /* 4bits transfer */
@@ -665,6 +667,7 @@ struct spi_message {
@@ -663,6 +665,7 @@ struct spi_message {
struct spi_device *spi;
unsigned is_dma_mapped:1;

@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -433,6 +433,12 @@ config SPI_QUP
@@ -457,6 +457,12 @@ config SPI_QUP
This driver can also be built as a module. If so, the module
will be called spi_qup.
@ -15,7 +15,7 @@
depends on ARCH_S3C24XX
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -62,6 +62,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
@@ -65,6 +65,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_DMA) += spi-pxa2xx-dma.o
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o

@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -647,6 +647,13 @@ config SPI_TLE62X0
@@ -676,6 +676,13 @@ config SPI_TLE62X0
sysfs interface, with each line presented as a kind of GPIO
exposing both switch control and diagnostic feedback.
@ -16,7 +16,7 @@
#
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -63,6 +63,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
@@ -66,6 +66,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx-platform.o
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o

@ -1,6 +1,6 @@
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -662,6 +662,11 @@ config SPI_RB4XX_CPLD
@@ -691,6 +691,11 @@ config SPI_RB4XX_CPLD
SPI driver for the Xilinx CPLD chip present on the
MikroTik RB4xx boards.
@ -14,7 +14,7 @@
#
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -86,6 +86,7 @@ obj-$(CONFIG_SPI_TEGRA20_SLINK) += spi-
@@ -90,6 +90,7 @@ obj-$(CONFIG_SPI_TEGRA20_SLINK) += spi-
obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o

@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -505,6 +505,13 @@ config LEDS_VERSATILE
This option enabled support for the LEDs on the ARM Versatile
and RealView boards. Say Y to enabled these.
@@ -534,6 +534,13 @@ config LEDS_PM8941_WLED
This option enables support for the 'White' LED block
on Qualcomm PM8941 PMICs.
+config LEDS_WNDR3700_USB
+ tristate "NETGEAR WNDR3700 USB LED driver"
@ -16,7 +16,7 @@
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -41,6 +41,7 @@ obj-$(CONFIG_LEDS_DA9052) += leds-da905
@@ -43,6 +43,7 @@ obj-$(CONFIG_LEDS_DA9052) += leds-da905
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o

@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -512,6 +512,10 @@ config LEDS_WNDR3700_USB
@@ -541,6 +541,10 @@ config LEDS_WNDR3700_USB
This option enables support for the USB LED found on the
NETGEAR WNDR3700 board.
@ -13,7 +13,7 @@
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -48,6 +48,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
@@ -50,6 +50,7 @@ obj-$(CONFIG_LEDS_LT3593) += leds-lt359
obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o

@ -1,8 +1,8 @@
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -905,4 +905,12 @@ config GPIO_VIPERBOARD
River Tech's viperboard.h for detailed meaning
of the module parameters.
@@ -988,4 +988,12 @@ config GPIO_VIPERBOARD
endmenu
+comment "Other GPIO expanders"
+
@ -15,7 +15,7 @@
endif
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -60,6 +60,7 @@ obj-$(CONFIG_GPIO_MSM_V2) += gpio-msm-v2
@@ -64,6 +64,7 @@ obj-$(CONFIG_GPIO_MSM_V2) += gpio-msm-v2
obj-$(CONFIG_GPIO_MVEBU) += gpio-mvebu.o
obj-$(CONFIG_GPIO_MXC) += gpio-mxc.o
obj-$(CONFIG_GPIO_MXS) += gpio-mxs.o

@ -100,7 +100,7 @@
+#endif
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -821,7 +821,7 @@ config GPIO_MC33880
@@ -941,7 +941,7 @@ menu "SPI GPIO expanders"
config GPIO_74X164
tristate "74x164 serial-in/parallel-out 8-bits shift register"

@ -1,6 +1,6 @@
--- a/drivers/spi/spi-bitbang.c
+++ b/drivers/spi/spi-bitbang.c
@@ -234,13 +234,14 @@ void spi_bitbang_cleanup(struct spi_devi
@@ -230,13 +230,14 @@ void spi_bitbang_cleanup(struct spi_devi
}
EXPORT_SYMBOL_GPL(spi_bitbang_cleanup);

@ -1,6 +1,6 @@
--- a/include/linux/spi/spi.h
+++ b/include/linux/spi/spi.h
@@ -508,6 +508,12 @@ extern struct spi_master *spi_busnum_to_
@@ -506,6 +506,12 @@ extern struct spi_master *spi_busnum_to_
/*---------------------------------------------------------------------------*/
@ -13,7 +13,7 @@
/*
* I/O INTERFACE between SPI controller and protocol drivers
*
@@ -628,6 +634,7 @@ struct spi_transfer {
@@ -626,6 +632,7 @@ struct spi_transfer {
u8 bits_per_word;
u16 delay_usecs;
u32 speed_hz;

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -142,10 +142,12 @@ static int m25p80_read(struct spi_nor *n
@@ -139,10 +139,12 @@ static int m25p80_read(struct spi_nor *n
flash->command[0] = nor->read_opcode;
m25p_addr2cmd(nor, from, flash->command);

@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -142,6 +142,9 @@ static int m25p80_read(struct spi_nor *n
@@ -139,6 +139,9 @@ static int m25p80_read(struct spi_nor *n
flash->command[0] = nor->read_opcode;
m25p_addr2cmd(nor, from, flash->command);
@ -25,7 +25,7 @@
while (len--) {
--- a/include/linux/spi/spi.h
+++ b/include/linux/spi/spi.h
@@ -635,6 +635,7 @@ struct spi_transfer {
@@ -633,6 +633,7 @@ struct spi_transfer {
u16 delay_usecs;
u32 speed_hz;
enum spi_transfer_type type;

@ -53,16 +53,16 @@
#define OHCI_CTRL_HCFS (3 << 6)
--- a/include/linux/usb/ehci_pdriver.h
+++ b/include/linux/usb/ehci_pdriver.h
@@ -46,6 +46,8 @@ struct usb_ehci_pdata {
unsigned big_endian_mmio:1;
unsigned no_io_watchdog:1;
@@ -50,6 +50,8 @@ struct usb_ehci_pdata {
unsigned reset_on_resume:1;
unsigned dma_mask_64:1;
unsigned ignore_oc:1;
+ unsigned qca_force_host_mode:1;
+ unsigned qca_force_16bit_ptw:1;
/* Turn on all power and clocks */
int (*power_on)(struct platform_device *pdev);
@@ -55,6 +57,7 @@ struct usb_ehci_pdata {
@@ -59,6 +61,7 @@ struct usb_ehci_pdata {
* turn off everything else */
void (*power_suspend)(struct platform_device *pdev);
int (*pre_setup)(struct usb_hcd *hcd);
@ -72,7 +72,7 @@
#endif /* __USB_CORE_EHCI_PDRIVER_H */
--- a/drivers/usb/host/ehci-platform.c
+++ b/drivers/usb/host/ehci-platform.c
@@ -48,6 +48,14 @@ struct ehci_platform_priv {
@@ -49,6 +49,14 @@ struct ehci_platform_priv {
static const char hcd_name[] = "ehci-platform";
@ -87,7 +87,7 @@
static int ehci_platform_reset(struct usb_hcd *hcd)
{
struct platform_device *pdev = to_platform_device(hcd->self.controller);
@@ -228,6 +236,13 @@ static int ehci_platform_probe(struct pl
@@ -266,6 +274,13 @@ static int ehci_platform_probe(struct pl
ehci->big_endian_mmio = 1;
if (pdata->ignore_oc)
ehci->ignore_oc = 1;

@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -208,6 +208,7 @@ endif
@@ -225,6 +225,7 @@ endif
#
libs-$(CONFIG_FW_ARC) += arch/mips/fw/arc/
libs-$(CONFIG_FW_CFE) += arch/mips/fw/cfe/
@ -10,7 +10,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -982,6 +982,9 @@ config MIPS_MSC
@@ -1067,6 +1067,9 @@ config MIPS_MSC
config MIPS_NILE4
bool

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -21,10 +21,39 @@
@@ -22,10 +22,39 @@
#include "common.h"

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -18,6 +18,7 @@
@@ -19,6 +19,7 @@
#include <asm/bootinfo.h>
#include <asm/addrspace.h>
#include <asm/fw/fw.h>
@ -8,7 +8,7 @@
#include "common.h"
@@ -31,10 +32,44 @@ static void __init ath79_prom_append_cmd
@@ -32,10 +33,44 @@ static void __init ath79_prom_append_cmd
strlcat(arcs_cmdline, ath79_cmdline_buf, sizeof(arcs_cmdline));
}

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -32,6 +32,35 @@ static void __init ath79_prom_append_cmd
@@ -33,6 +33,35 @@ static void __init ath79_prom_append_cmd
strlcat(arcs_cmdline, ath79_cmdline_buf, sizeof(arcs_cmdline));
}
@ -36,7 +36,7 @@
static int __init ath79_prom_init_myloader(void)
{
struct myloader_info *mylo;
@@ -60,6 +89,8 @@ static int __init ath79_prom_init_myload
@@ -61,6 +90,8 @@ static int __init ath79_prom_init_myload
ath79_prom_append_cmdline("ethaddr", mac_buf);
@ -45,7 +45,7 @@
return 1;
}
@@ -70,7 +101,8 @@ void __init prom_init(void)
@@ -71,7 +102,8 @@ void __init prom_init(void)
if (ath79_prom_init_myloader())
return;

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/setup.c
+++ b/arch/mips/ath79/setup.c
@@ -229,6 +229,8 @@ void __init plat_time_init(void)
@@ -234,6 +234,8 @@ void __init plat_time_init(void)
mips_hpt_frequency = cpu_clk_rate / 2;
}

@ -1580,7 +1580,7 @@
+obj-$(CONFIG_ATH79_MACH_NBG6716) += mach-nbg6716.o
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -127,6 +127,12 @@ void __init prom_init(void)
@@ -130,6 +130,12 @@ void __init prom_init(void)
initrd_end = initrd_start + fw_getenvl("initrd_size");
}
#endif

@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -1205,6 +1205,10 @@ config SOC_AR934X
@@ -1229,6 +1229,10 @@ config SOC_AR934X
select PCI_AR724X if PCI
def_bool n
@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
config SOC_QCA955X
select HW_HAS_PCI
select PCI_AR724X if PCI
@@ -1247,7 +1251,7 @@ config ATH79_DEV_USB
@@ -1271,7 +1275,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC
@ -394,7 +394,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
} else if (soc_is_qca955x()) {
ath79_ip2_handler = ath79_default_ip2_handler;
ath79_ip3_handler = ath79_default_ip3_handler;
@@ -365,6 +407,8 @@ void __init arch_init_irq(void)
@@ -364,6 +406,8 @@ void __init arch_init_irq(void)
if (soc_is_ar934x())
ar934x_ip2_irq_init();

@ -20,7 +20,7 @@
select SOC_QCA955X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -70,6 +70,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2) += mac
@@ -72,6 +72,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2) += mac
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
@ -30,7 +30,7 @@
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -60,6 +60,7 @@ enum ath79_mach_type {
@@ -62,6 +62,7 @@ enum ath79_mach_type {
ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
ATH79_MACH_ESR1750, /* EnGenius ESR1750 */

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -1225,6 +1225,12 @@ config SOC_QCA955X
@@ -1249,6 +1249,12 @@ config SOC_QCA955X
select PCI_AR724X if PCI
def_bool n
@ -13,7 +13,7 @@
config ATH79_DEV_M25P80
select ATH79_DEV_SPI
def_bool n
@@ -1262,7 +1268,7 @@ config ATH79_DEV_USB
@@ -1286,7 +1292,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC
@ -393,7 +393,7 @@
} else {
BUG();
}
@@ -411,4 +506,6 @@ void __init arch_init_irq(void)
@@ -410,4 +505,6 @@ void __init arch_init_irq(void)
qca953x_irq_init();
else if (soc_is_qca955x())
qca955x_irq_init();

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -566,6 +566,16 @@ config ATH79_MACH_R6100
@@ -590,6 +590,16 @@ config ATH79_MACH_R6100
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@ -19,7 +19,7 @@
select SOC_AR71XX
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -79,6 +79,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) +
@@ -81,6 +81,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) +
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
@ -29,7 +29,7 @@
obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -118,6 +118,7 @@ enum ath79_mach_type {
@@ -120,6 +120,7 @@ enum ath79_mach_type {
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
ATH79_MACH_TEW_712BR, /* TRENDnet TEW-712BR */
ATH79_MACH_TEW_732BR, /* TRENDnet TEW-732BR */

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -85,6 +85,7 @@ enum ath79_mach_type {
@@ -87,6 +87,7 @@ enum ath79_mach_type {
ATH79_MACH_OM2P_LC, /* OpenMesh OM2P-LC */
ATH79_MACH_OM2Pv2, /* OpenMesh OM2Pv2 */
ATH79_MACH_OM2P, /* OpenMesh OM2P */
@ -10,7 +10,7 @@
ATH79_MACH_PB92, /* Atheros PB92 */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -719,6 +719,7 @@ config ATH79_MACH_OM2P
@@ -743,6 +743,7 @@ config ATH79_MACH_OM2P
config ATH79_MACH_OM5P
bool "OpenMesh OM5P board support"
select SOC_AR934X

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -726,6 +726,26 @@ config ATH79_MACH_OM5P
@@ -750,6 +750,26 @@ config ATH79_MACH_OM5P
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
@ -29,7 +29,7 @@
select SOC_AR934X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -80,6 +80,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach
@@ -82,6 +82,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
obj-$(CONFIG_ATH79_MACH_MC_MAC1200R) += mach-mc-mac1200r.o
@ -40,7 +40,7 @@
obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -69,6 +69,8 @@ enum ath79_mach_type {
@@ -71,6 +71,8 @@ enum ath79_mach_type {
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
ATH79_MACH_JWAP003, /* jjPlus JWAP003 */
ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -601,6 +601,16 @@ config ATH79_MACH_RB91X
@@ -625,6 +625,16 @@ config ATH79_MACH_RB91X
select ATH79_DEV_USB
select ATH79_ROUTERBOOT
@ -19,7 +19,7 @@
select SOC_AR934X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_R6100) += mach-
@@ -102,6 +102,7 @@ obj-$(CONFIG_ATH79_MACH_R6100) += mach-
obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
@ -29,7 +29,7 @@
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -107,6 +107,7 @@ enum ath79_mach_type {
@@ -109,6 +109,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_750G_R3, /* MikroTik RouterBOARD 750GL */
ATH79_MACH_RB_751, /* MikroTik RouterBOARD 751 */
ATH79_MACH_RB_751G, /* Mikrotik RouterBOARD 751G */
@ -39,7 +39,7 @@
ATH79_MACH_RB_2011G, /* Mikrotik RouterBOARD 2011UAS-2HnD */
--- a/arch/mips/ath79/prom.c
+++ b/arch/mips/ath79/prom.c
@@ -184,7 +184,8 @@ void __init prom_init(void)
@@ -134,7 +134,8 @@ void __init prom_init(void)
if (strstr(arcs_cmdline, "board=750Gr3") ||
strstr(arcs_cmdline, "board=951G") ||
strstr(arcs_cmdline, "board=2011L") ||

@ -10,7 +10,7 @@
#endif /* __ATH79_COMMON_H */
--- a/arch/mips/ath79/gpio.c
+++ b/arch/mips/ath79/gpio.c
@@ -130,6 +130,30 @@ static int ar934x_gpio_direction_output(
@@ -142,6 +142,30 @@ static int ar934x_gpio_direction_output(
return 0;
}

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -174,6 +174,7 @@ enum ath79_mach_type {
@@ -176,6 +176,7 @@ enum ath79_mach_type {
ATH79_MACH_UBNT_NANO_M, /* Ubiquiti NanoStation M */
ATH79_MACH_UBNT_NANO_M_XW, /* Ubiquiti NanoStation M XW */
ATH79_MACH_UBNT_ROCKET_M, /* Ubiquiti Rocket M */

@ -125,7 +125,7 @@
.name = "ubnt:blue:wlan",
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -176,6 +176,7 @@ enum ath79_mach_type {
@@ -178,6 +178,7 @@ enum ath79_mach_type {
ATH79_MACH_UBNT_NANO_M_XW, /* Ubiquiti NanoStation M XW */
ATH79_MACH_UBNT_ROCKET_M, /* Ubiquiti Rocket M */
ATH79_MACH_UBNT_ROCKET_M_XW, /* Ubiquiti Rocket M XW*/

Loading…
Cancel
Save