strace: update to version 4.11

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 48784
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 8 years ago
parent cb04b8d582
commit 29a36d1fd6

@ -10,9 +10,9 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=strace
PKG_VERSION:=4.10
PKG_VERSION:=4.11
PKG_RELEASE:=1
PKG_MD5SUM:=107a5be455493861189e9b57a3a51912
PKG_MD5SUM:=a15d2555a7febb56d00c6e1a51c655dc
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)

@ -1,53 +0,0 @@
--- a/evdev.c
+++ b/evdev.c
@@ -28,6 +28,8 @@
#include "defs.h"
+#include <linux/ioctl.h>
+
#ifdef HAVE_LINUX_INPUT_H
#include <linux/input.h>
#include "xlat/evdev_abs.h"
--- a/ioctl.c
+++ b/ioctl.c
@@ -29,7 +29,7 @@
*/
#include "defs.h"
-#include <asm/ioctl.h>
+#include <linux/ioctl.h>
#include "xlat/ioctl_dirs.h"
#ifdef HAVE_LINUX_INPUT_H
--- a/ioctlsort.c
+++ b/ioctlsort.c
@@ -33,7 +33,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <asm/ioctl.h>
+#include <linux/ioctl.h>
struct ioctlent {
const char *info;
--- a/mknod.c
+++ b/mknod.c
@@ -1,6 +1,7 @@
#include "defs.h"
#include <fcntl.h>
+#include <sys/stat.h>
#ifdef MAJOR_IN_SYSMACROS
# include <sys/sysmacros.h>
--- a/printmode.c
+++ b/printmode.c
@@ -1,6 +1,7 @@
#include "defs.h"
#include <fcntl.h>
+#include <sys/stat.h>
#include "xlat/modetypes.h"
Loading…
Cancel
Save