curl: 7.36.0 -> 7.38.0

Main changes:
- URL parser: IPv6 zone identifiers are now supported
- cyassl: Use error-ssl.h when available (drop local patch)
- polarssl: support CURLOPT_CAPATH / --capath
- mkhelp: generate code for --disable-manual as well (drop local patch)

Full release notes: http://curl.haxx.se/changes.html

MIPS 34kc binary size:
- 7.36.0 before: 82,539 bytes
- 7.38.0 after: 83,321 bytes

Signed-off-by: Catalin Patulea <cat@vv.carleton.ca>

SVN-Revision: 42517
v19.07.3_mercusys_ac12_duma
Hauke Mehrtens 10 years ago
parent 0a5caa47e5
commit 275ba42c52

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.36.0
PKG_VERSION:=7.38.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
ftp://ftp.planetmirror.com/pub/curl/ \
http://www.mirrormonster.com/curl/download/ \
http://curl.mirrors.cyberservers.net/download/
PKG_MD5SUM:=e6d1f9d1b59da5062109ffe14e0569a4
PKG_MD5SUM:=af6b3c299bd891f43cb5f76c4091b7b4
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING

@ -1,45 +0,0 @@
From 0204e17bc656e6c59b4010283e67f9251eb12c41 Mon Sep 17 00:00:00 2001
From: Dan Fandrich <dan@coneharvesters.com>
Date: Wed, 23 Apr 2014 11:01:30 +0200
Subject: [PATCH] cyassl: Use error-ssl.h when available
Versions since at least 2.9.4 renamed error.h to error-ssl.h, so use
whichever one is available.
---
configure.ac | 3 +++
lib/vtls/cyassl.c | 9 +++++++--
2 files changed, 10 insertions(+), 2 deletions(-)
--- a/configure.ac
+++ b/configure.ac
@@ -2003,6 +2003,9 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
dnl cyassl/ctaocrypt/types.h needs SIZEOF_LONG_LONG defined!
AC_CHECK_SIZEOF(long long)
+ dnl Versions since at least 2.9.4 renamed error.h to error-ssl.h
+ AC_CHECK_HEADERS(cyassl/error-ssl.h)
+
LIBS="-lcyassl -lm $LIBS"
if test -n "$cyassllib"; then
--- a/lib/vtls/cyassl.c
+++ b/lib/vtls/cyassl.c
@@ -47,11 +47,16 @@
#define _MPRINTF_REPLACE /* use our functions only */
#include <curl/mprintf.h>
#include "curl_memory.h"
-/* The last #include file should be: */
-#include "memdebug.h"
+
#include <cyassl/ssl.h>
+#ifdef HAVE_CYASSL_ERROR_SSL_H
+#include <cyassl/error-ssl.h>
+#else
#include <cyassl/error.h>
+#endif
+/* The last #include file should be: */
+#include "memdebug.h"
static Curl_recv cyassl_recv;
static Curl_send cyassl_send;

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -2904,6 +2904,7 @@ CURL_VERIFY_RUNTIMELIBS
@@ -2877,6 +2877,7 @@ CURL_VERIFY_RUNTIMELIBS
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(long)

@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,7 @@ CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
@@ -128,7 +128,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include
@ -11,12 +11,12 @@
pkgconfig_DATA = libcurl.pc
--- a/Makefile.in
+++ b/Makefile.in
@@ -506,7 +506,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
@@ -574,7 +574,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
SUBDIRS = lib src include
-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
+DIST_SUBDIRS = $(SUBDIRS) packages
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcurl.pc
VSOURCES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c vtls/qssl.c \
LIB_VTLS_CFILES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c \

@ -1,13 +0,0 @@
--- a/src/tool_hugehelp.h
+++ b/src/tool_hugehelp.h
@@ -23,6 +23,10 @@
***************************************************************************/
#include "tool_setup.h"
+#ifdef USE_MANUAL
void hugehelp(void);
+#else
+#define hugehelp() Curl_nop_stmt
+#endif
#endif /* HEADER_CURL_TOOL_HUGEHELP_H */
Loading…
Cancel
Save