mkimage: update to 2014.10

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 43428
v19.07.3_mercusys_ac12_duma
Luka Perkov 9 years ago
parent 070d3b27c2
commit 25d8cb275e

@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
PKG_VERSION:=2014.07
PKG_VERSION:=2014.10
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
PKG_SOURCE_URL:=\
http://mirror2.openwrt.org/sources \
ftp://ftp.denx.de/pub/u-boot
PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@ -29,6 +31,7 @@ define Host/Prepare
endef
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) defconfig
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTLDFLAGS="$(HOST_STATIC_LINKING)" \
tools-only

@ -0,0 +1,10 @@
--- a/include/u-boot/rsa-checksum.h
+++ b/include/u-boot/rsa-checksum.h
@@ -7,7 +7,6 @@
#ifndef _RSA_CHECKSUM_H
#define _RSA_CHECKSUM_H
-#include <errno.h>
#include <image.h>
#include <u-boot/sha1.h>
#include <u-boot/sha256.h>

@ -1,18 +0,0 @@
--- a/tools/mkimage.c
+++ b/tools/mkimage.c
@@ -458,6 +458,7 @@
#if defined(_POSIX_SYNCHRONIZED_IO) && \
!defined(__sun__) && \
!defined(__FreeBSD__) && \
+ !defined(__OpenBSD__) && \
!defined(__APPLE__)
(void) fdatasync (ifd);
#else
@@ -501,6 +502,7 @@
#if defined(_POSIX_SYNCHRONIZED_IO) && \
!defined(__sun__) && \
!defined(__FreeBSD__) && \
+ !defined(__OpenBSD__) && \
!defined(__APPLE__)
(void) fdatasync (ifd);
#else

@ -1,10 +1,10 @@
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -193,7 +193,7 @@
@@ -194,7 +194,7 @@ endif # !LOGO_BMP
# Define _GNU_SOURCE to obtain the getline prototype from stdio.h
#
HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
- $(patsubst -I%,-idirafter%, $(UBOOTINCLUDE)) \
- $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
+ -I$(srctree)/include \
-I$(srctree)/lib/libfdt \
-I$(srctree)/tools \

@ -8,7 +8,7 @@
/* Define this to avoid #ifdefs later on */
struct lmb;
@@ -257,13 +256,13 @@
@@ -258,13 +257,13 @@ struct lmb;
* all data in network byte order (aka natural aka bigendian).
*/
typedef struct image_header {

@ -1,6 +1,6 @@
--- a/include/compiler.h
+++ b/include/compiler.h
@@ -53,6 +53,11 @@
@@ -58,6 +58,11 @@ typedef uint8_t __u8;
typedef uint16_t __u16;
typedef uint32_t __u32;
typedef unsigned int uint;
@ -14,7 +14,7 @@
((((x) & 0xff00) >> 8) | \
--- a/include/linux/posix_types.h
+++ b/include/linux/posix_types.h
@@ -43,6 +43,8 @@
@@ -43,6 +43,8 @@ typedef void (*__kernel_sighandler_t)(in
/* Type of a SYSV IPC key. */
typedef int __kernel_key_t;

Loading…
Cancel
Save