update to 2.6.31.5

SVN-Revision: 18127
v19.07.3_mercusys_ac12_duma
Florian Fainelli 15 years ago
parent d4b251bdb8
commit 21367682e8

@ -25,8 +25,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.30.9)
LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
endif
ifeq ($(LINUX_VERSION),2.6.31.1)
LINUX_KERNEL_MD5SUM:=8077cd7f7c1cdeb6aef3872441ae5294
ifeq ($(LINUX_VERSION),2.6.31.5)
LINUX_KERNEL_MD5SUM:=926bff46d24e2f303e4ee92234e394d8
endif
# disable the md5sum check for unknown kernel versions

@ -1,5 +1,7 @@
--- a/include/asm-generic/vmlinux.lds.h
+++ b/include/asm-generic/vmlinux.lds.h
Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
===================================================================
--- linux-2.6.31.5.orig/include/asm-generic/vmlinux.lds.h 2009-10-23 00:57:56.000000000 +0200
+++ linux-2.6.31.5/include/asm-generic/vmlinux.lds.h 2009-10-23 12:43:50.000000000 +0200
@@ -55,6 +55,27 @@
#define LOAD_OFFSET 0
#endif
@ -84,9 +86,11 @@
} \
\
/* __*init sections */ \
--- a/include/linux/module.h
+++ b/include/linux/module.h
@@ -188,16 +188,24 @@ void *__symbol_get_gpl(const char *symbo
Index: linux-2.6.31.5/include/linux/module.h
===================================================================
--- linux-2.6.31.5.orig/include/linux/module.h 2009-10-23 00:57:56.000000000 +0200
+++ linux-2.6.31.5/include/linux/module.h 2009-10-23 12:43:50.000000000 +0200
@@ -188,16 +188,24 @@
#define __CRC_SYMBOL(sym, sec)
#endif
@ -113,20 +117,11 @@
= { (unsigned long)&sym, __kstrtab_##sym }
#define EXPORT_SYMBOL(sym) \
--- a/Makefile
+++ b/Makefile
@@ -986,7 +986,7 @@ prepare: prepare0
# Leave this as default for preprocessing vmlinux.lds.S, which is now
# done in arch/$(ARCH)/kernel/Makefile
-export CPPFLAGS_vmlinux.lds += -P -C -U$(ARCH)
+export CPPFLAGS_vmlinux.lds += -P -C -U$(ARCH) $(EXTRA_LDSFLAGS)
# The asm symlink changes when $(ARCH) changes.
# Detect this and ask user to run make mrproper
--- a/arch/arm/kernel/vmlinux.lds.S
+++ b/arch/arm/kernel/vmlinux.lds.S
@@ -79,26 +79,6 @@ SECTIONS
Index: linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S
===================================================================
--- linux-2.6.31.5.orig/arch/arm/kernel/vmlinux.lds.S 2009-10-23 00:57:56.000000000 +0200
+++ linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S 2009-10-23 12:43:50.000000000 +0200
@@ -79,26 +79,6 @@
#endif
}
@ -153,7 +148,7 @@
.text : { /* Real text segment */
_text = .; /* Text and read-only data */
__exception_text_start = .;
@@ -205,6 +185,28 @@ SECTIONS
@@ -205,6 +185,28 @@
__bss_stop = .;
_end = .;
}
@ -182,9 +177,11 @@
/* Stabs debugging sections. */
.stab 0 : { *(.stab) }
.stabstr 0 : { *(.stabstr) }
--- a/arch/powerpc/kernel/vmlinux.lds.S
+++ b/arch/powerpc/kernel/vmlinux.lds.S
@@ -37,12 +37,6 @@ jiffies = jiffies_64 + 4;
Index: linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S
===================================================================
--- linux-2.6.31.5.orig/arch/powerpc/kernel/vmlinux.lds.S 2009-10-23 00:57:56.000000000 +0200
+++ linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S 2009-10-23 12:43:50.000000000 +0200
@@ -37,12 +37,6 @@
#endif
SECTIONS
{
@ -197,7 +194,7 @@
. = KERNELBASE;
/*
@@ -295,6 +289,12 @@ SECTIONS
@@ -295,6 +289,12 @@
__bss_stop = .;
}

@ -12,7 +12,7 @@ BOARDNAME:=x86
FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
SUBTARGETS=generic
LINUX_VERSION:=2.6.31.1
LINUX_VERSION:=2.6.31.5
include $(INCLUDE_DIR)/target.mk

@ -1,5 +1,7 @@
--- a/drivers/ata/pata_sc1200.c
+++ b/drivers/ata/pata_sc1200.c
Index: linux-2.6.31.5/drivers/ata/pata_sc1200.c
===================================================================
--- linux-2.6.31.5.orig/drivers/ata/pata_sc1200.c 2009-10-23 00:57:56.000000000 +0200
+++ linux-2.6.31.5/drivers/ata/pata_sc1200.c 2009-10-23 12:45:54.000000000 +0200
@@ -236,7 +236,7 @@
.port_ops = &sc1200_port_ops
};

Loading…
Cancel
Save