ar71xx: ar934x_nfc: experimental NAND Flash Controller driver for AR934x

SVN-Revision: 33385
v19.07.3_mercusys_ac12_duma
Gabor Juhos 12 years ago
parent acaf597f4a
commit 1e5fdbeae5

File diff suppressed because it is too large Load Diff

@ -0,0 +1,30 @@
/*
* Platform data definition for the built-in NAND controller of the
* Atheros AR934x SoCs
*
* Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
#ifndef _AR934X_NFC_PLATFORM_H
#define _AR934X_NFC_PLATFORM_H
#define AR934X_NFC_DRIVER_NAME "ar934x-nfc"
struct mtd_info;
struct mtd_partition;
struct ar934x_nfc_platform_data {
const char *name;
struct mtd_partition *parts;
int nr_parts;
void (*hw_reset)(bool active);
void (*select_chip)(int chip_no);
int (*scan_fixup)(struct mtd_info *mtd);
};
#endif /* _AR934X_NFC_PLATFORM_H */

@ -0,0 +1,21 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -544,4 +544,8 @@ config MTD_NAND_RB750
tristate "NAND flash driver for the RouterBoard 750"
depends on MTD_NAND && ATH79_MACH_RB750
+config MTD_NAND_AR934X
+ tristate "NAND flash driver for the Atheros AR934x SoCs"
+ depends on SOC_AR934X
+
endif # MTD_NAND
--- a/drivers/mtd/nand/Makefile
+++ b/drivers/mtd/nand/Makefile
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_SM_COMMON) += sm_comm
obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nand.o
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
+obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nfc.o
obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
obj-$(CONFIG_MTD_NAND_DENALI) += denali.o
obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o
Loading…
Cancel
Save