hostapd: update to 20110527, includes a client mode wpa auth fix

SVN-Revision: 27021
v19.07.3_mercusys_ac12_duma
Felix Fietkau 13 years ago
parent 016e8dee34
commit 1b2b3be64d

@ -8,16 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20110421
PKG_VERSION:=20110527
PKG_RELEASE:=1
PKG_REV:=0725cc7b7efc434910e89865c42eda7ce61bbf08
PKG_REV:=ceb34f250af7a7082f18c1e0451dc7fbc0f000f3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=git
PKG_MIRROR_MD5SUM:=fa3f3182dc82f40c88398822ebfe693e
PKG_MIRROR_MD5SUM:=4b98902d782813b41aca1faff613f677
PKG_BUILD_DEPENDS:= \
PACKAGE_kmod-madwifi:madwifi \

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -1847,6 +1847,7 @@ static void * wpa_driver_nl80211_init(vo
@@ -1890,6 +1890,7 @@ static void * wpa_driver_nl80211_init(vo
drv->monitor_ifidx = -1;
drv->monitor_sock = -1;
drv->ioctl_sock = -1;
@ -8,7 +8,7 @@
if (wpa_driver_nl80211_init_nl(drv)) {
os_free(drv);
@@ -2013,29 +2014,29 @@ wpa_driver_nl80211_finish_drv_init(struc
@@ -2056,29 +2057,29 @@ wpa_driver_nl80211_finish_drv_init(struc
drv->ifindex = if_nametoindex(bss->ifname);
drv->first_bss.ifindex = drv->ifindex;
@ -58,7 +58,7 @@
if (wpa_driver_nl80211_capa(drv))
return -1;
@@ -3765,7 +3766,8 @@ static void nl80211_remove_iface(struct
@@ -3849,7 +3850,8 @@ static void nl80211_remove_iface(struct
#ifdef HOSTAPD
/* stop listening for EAPOL on this interface */
@ -68,7 +68,7 @@
#endif /* HOSTAPD */
msg = nlmsg_alloc();
@@ -3838,7 +3840,8 @@ static int nl80211_create_iface_once(str
@@ -3922,7 +3924,8 @@ static int nl80211_create_iface_once(str
#ifdef HOSTAPD
/* start listening for EAPOL on this interface */

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -466,6 +466,10 @@ static void wpa_driver_nl80211_event_rtm
@@ -475,6 +475,10 @@ static void wpa_driver_nl80211_event_rtm
return;
}
@ -11,7 +11,7 @@
wpa_printf(MSG_DEBUG, "RTM_NEWLINK: operstate=%d ifi_flags=0x%x "
"(%s%s%s%s)",
drv->operstate, ifi->ifi_flags,
@@ -537,6 +541,10 @@ static void wpa_driver_nl80211_event_rtm
@@ -546,6 +550,10 @@ static void wpa_driver_nl80211_event_rtm
attrlen = len;
attr = (struct rtattr *) buf;
@ -22,7 +22,7 @@
rta_len = RTA_ALIGN(sizeof(struct rtattr));
while (RTA_OK(attr, attrlen)) {
if (attr->rta_type == IFLA_IFNAME) {
@@ -1636,6 +1644,11 @@ static int wpa_driver_nl80211_capa(struc
@@ -1679,6 +1687,11 @@ static int wpa_driver_nl80211_capa(struc
drv->capa.flags |= WPA_DRIVER_FLAGS_EAPOL_TX_STATUS;
drv->capa.max_remain_on_chan = info.max_remain_on_chan;
@ -34,7 +34,7 @@
return 0;
}
@@ -5638,8 +5651,6 @@ static void *i802_init(struct hostapd_da
@@ -5715,8 +5728,6 @@ static void *i802_init(struct hostapd_da
br_ifindex = 0;
}

@ -10,7 +10,7 @@
/* hostapd.c */
--- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c
@@ -790,6 +790,9 @@ int hostapd_setup_interface_complete(str
@@ -807,6 +807,9 @@ int hostapd_setup_interface_complete(str
wpa_printf(MSG_DEBUG, "%s: Setup of interface done.",
iface->bss[0]->conf->iface);
@ -128,7 +128,7 @@
} else if (os_strcmp(buf, "ht_capab") == 0) {
--- a/src/ap/ap_config.h
+++ b/src/ap/ap_config.h
@@ -389,6 +389,7 @@ struct hostapd_config {
@@ -390,6 +390,7 @@ struct hostapd_config {
int ht_op_mode_fixed;
u16 ht_capab;

@ -132,7 +132,7 @@
wpa_cli.exe: wpa_cli
--- a/src/drivers/driver.h
+++ b/src/drivers/driver.h
@@ -3187,8 +3187,8 @@ union wpa_event_data {
@@ -3199,8 +3199,8 @@ union wpa_event_data {
* Driver wrapper code should call this function whenever an event is received
* from the driver.
*/
@ -179,7 +179,7 @@
for (;;) {
--- a/wpa_supplicant/events.c
+++ b/wpa_supplicant/events.c
@@ -1741,8 +1741,8 @@ static void wpa_supplicant_event_unprot_
@@ -1746,8 +1746,8 @@ static void wpa_supplicant_event_unprot_
}

@ -10,7 +10,7 @@
struct wpa_driver_capa capa;
int has_capability;
@@ -1776,7 +1778,7 @@ err1:
@@ -1819,7 +1821,7 @@ err1:
return -1;
}
@ -19,7 +19,7 @@
static void wpa_driver_nl80211_rfkill_blocked(void *ctx)
{
wpa_printf(MSG_DEBUG, "nl80211: RFKILL blocked");
@@ -1798,6 +1800,7 @@ static void wpa_driver_nl80211_rfkill_un
@@ -1841,6 +1843,7 @@ static void wpa_driver_nl80211_rfkill_un
}
/* rtnetlink ifup handler will report interface as enabled */
}
@ -27,7 +27,7 @@
static void nl80211_get_phy_name(struct wpa_driver_nl80211_data *drv)
@@ -1846,7 +1849,9 @@ static void * wpa_driver_nl80211_init(vo
@@ -1889,7 +1892,9 @@ static void * wpa_driver_nl80211_init(vo
{
struct wpa_driver_nl80211_data *drv;
struct netlink_config *cfg;
@ -37,7 +37,7 @@
struct i802_bss *bss;
drv = os_zalloc(sizeof(*drv));
@@ -1887,6 +1892,7 @@ static void * wpa_driver_nl80211_init(vo
@@ -1930,6 +1935,7 @@ static void * wpa_driver_nl80211_init(vo
goto failed;
}
@ -45,7 +45,7 @@
rcfg = os_zalloc(sizeof(*rcfg));
if (rcfg == NULL)
goto failed;
@@ -1899,6 +1905,7 @@ static void * wpa_driver_nl80211_init(vo
@@ -1942,6 +1948,7 @@ static void * wpa_driver_nl80211_init(vo
wpa_printf(MSG_DEBUG, "nl80211: RFKILL status not available");
os_free(rcfg);
}
@ -53,7 +53,7 @@
if (wpa_driver_nl80211_finish_drv_init(drv))
goto failed;
@@ -1909,7 +1916,9 @@ static void * wpa_driver_nl80211_init(vo
@@ -1952,7 +1959,9 @@ static void * wpa_driver_nl80211_init(vo
return bss;
failed:
@ -63,7 +63,7 @@
netlink_deinit(drv->netlink);
if (drv->ioctl_sock >= 0)
close(drv->ioctl_sock);
@@ -2012,10 +2021,12 @@ static int nl80211_register_action_frame
@@ -2055,10 +2064,12 @@ static int nl80211_register_action_frame
}
@ -76,7 +76,7 @@
static int
@@ -2034,13 +2045,16 @@ wpa_driver_nl80211_finish_drv_init(struc
@@ -2077,13 +2088,16 @@ wpa_driver_nl80211_finish_drv_init(struc
}
if (linux_set_iface_flags(drv->ioctl_sock, bss->ifname, 1)) {
@ -94,7 +94,7 @@
wpa_printf(MSG_ERROR, "nl80211: Could not set "
"interface '%s' UP", bss->ifname);
return -1;
@@ -2068,8 +2082,10 @@ wpa_driver_nl80211_finish_drv_init(struc
@@ -2111,8 +2125,10 @@ wpa_driver_nl80211_finish_drv_init(struc
}
if (send_rfkill_event) {
@ -105,7 +105,7 @@
}
return 0;
@@ -2150,7 +2166,9 @@ static void wpa_driver_nl80211_deinit(vo
@@ -2193,7 +2209,9 @@ static void wpa_driver_nl80211_deinit(vo
netlink_send_oper_ifla(drv->netlink, drv->ifindex, 0, IF_OPER_UP);
netlink_deinit(drv->netlink);
@ -115,7 +115,7 @@
eloop_cancel_timeout(wpa_driver_nl80211_scan_timeout, drv, drv->ctx);
@@ -5708,7 +5726,9 @@ static void *i802_init(struct hostapd_da
@@ -5785,7 +5803,9 @@ static void *i802_init(struct hostapd_da
failed:
nl80211_remove_monitor_interface(drv);

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -2092,23 +2092,43 @@ wpa_driver_nl80211_finish_drv_init(struc
@@ -2135,23 +2135,43 @@ wpa_driver_nl80211_finish_drv_init(struc
}
@ -46,7 +46,7 @@
/**
* wpa_driver_nl80211_deinit - Deinitialize nl80211 driver interface
@@ -6581,4 +6601,5 @@ const struct wpa_driver_ops wpa_driver_n
@@ -6658,4 +6678,5 @@ const struct wpa_driver_ops wpa_driver_n
.set_intra_bss = nl80211_set_intra_bss,
.set_param = nl80211_set_param,
.get_radio_name = nl80211_get_radio_name,
@ -54,10 +54,10 @@
};
--- a/src/drivers/driver.h
+++ b/src/drivers/driver.h
@@ -2241,6 +2241,8 @@ struct wpa_driver_ops {
* @signal_info: Connection info structure
*/
int (*signal_poll)(void *priv, struct wpa_signal_info *signal_info);
@@ -2253,6 +2253,8 @@ struct wpa_driver_ops {
* implementation, there is no need to implement this function.
*/
int (*set_authmode)(void *priv, int authmode);
+
+ int (*stop_ap)(void *priv);
};

@ -55,7 +55,7 @@
--- a/wpa_supplicant/ctrl_iface.c
+++ b/wpa_supplicant/ctrl_iface.c
@@ -2927,6 +2927,7 @@ char * wpa_supplicant_ctrl_iface_process
@@ -2929,6 +2929,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = -1;
} else if (os_strncmp(buf, "NOTE ", 5) == 0) {
wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@ -63,7 +63,7 @@
} else if (os_strcmp(buf, "MIB") == 0) {
reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
if (reply_len >= 0) {
@@ -2938,6 +2939,7 @@ char * wpa_supplicant_ctrl_iface_process
@@ -2940,6 +2941,7 @@ char * wpa_supplicant_ctrl_iface_process
else
reply_len += res;
}
@ -71,7 +71,7 @@
} else if (os_strncmp(buf, "STATUS", 6) == 0) {
reply_len = wpa_supplicant_ctrl_iface_status(
wpa_s, buf + 6, reply, reply_size);
@@ -3243,6 +3245,7 @@ char * wpa_supplicant_ctrl_iface_process
@@ -3245,6 +3247,7 @@ char * wpa_supplicant_ctrl_iface_process
reply_len = wpa_supplicant_ctrl_iface_bss(
wpa_s, buf + 4, reply, reply_size);
#ifdef CONFIG_AP
@ -79,7 +79,7 @@
} else if (os_strcmp(buf, "STA-FIRST") == 0) {
reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
} else if (os_strncmp(buf, "STA ", 4) == 0) {
@@ -3251,6 +3254,7 @@ char * wpa_supplicant_ctrl_iface_process
@@ -3253,6 +3256,7 @@ char * wpa_supplicant_ctrl_iface_process
} else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
reply_size);
@ -105,7 +105,7 @@
+#endif
--- a/src/ap/ieee802_1x.c
+++ b/src/ap/ieee802_1x.c
@@ -1895,6 +1895,7 @@ static const char * bool_txt(Boolean boo
@@ -1896,6 +1896,7 @@ static const char * bool_txt(Boolean boo
return bool ? "TRUE" : "FALSE";
}
@ -113,7 +113,7 @@
int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
{
@@ -2046,6 +2047,7 @@ int ieee802_1x_get_mib_sta(struct hostap
@@ -2047,6 +2048,7 @@ int ieee802_1x_get_mib_sta(struct hostap
return len;
}

@ -1,6 +1,6 @@
--- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c
@@ -717,11 +717,8 @@ int hostapd_setup_interface_complete(str
@@ -723,11 +723,8 @@ int hostapd_setup_interface_complete(str
size_t j;
u8 *prev_addr;
@ -14,7 +14,7 @@
wpa_printf(MSG_DEBUG, "Completing interface initialization");
if (hapd->iconf->channel) {
@@ -737,7 +734,7 @@ int hostapd_setup_interface_complete(str
@@ -743,7 +740,7 @@ int hostapd_setup_interface_complete(str
hapd->iconf->secondary_channel)) {
wpa_printf(MSG_ERROR, "Could not set channel for "
"kernel driver");
@ -23,7 +23,7 @@
}
}
@@ -748,7 +745,7 @@ int hostapd_setup_interface_complete(str
@@ -754,7 +751,7 @@ int hostapd_setup_interface_complete(str
hostapd_logger(hapd, NULL, HOSTAPD_MODULE_IEEE80211,
HOSTAPD_LEVEL_WARNING,
"Failed to prepare rates table.");
@ -32,7 +32,7 @@
}
}
@@ -756,14 +753,14 @@ int hostapd_setup_interface_complete(str
@@ -762,14 +759,14 @@ int hostapd_setup_interface_complete(str
hostapd_set_rts(hapd, hapd->iconf->rts_threshold)) {
wpa_printf(MSG_ERROR, "Could not set RTS threshold for "
"kernel driver");
@ -49,7 +49,7 @@
}
prev_addr = hapd->own_addr;
@@ -773,7 +770,7 @@ int hostapd_setup_interface_complete(str
@@ -779,7 +776,7 @@ int hostapd_setup_interface_complete(str
if (j)
os_memcpy(hapd->own_addr, prev_addr, ETH_ALEN);
if (hostapd_setup_bss(hapd, j == 0))
@ -58,7 +58,7 @@
if (hostapd_mac_comp_empty(hapd->conf->bssid) == 0)
prev_addr = hapd->own_addr;
}
@@ -785,7 +782,7 @@ int hostapd_setup_interface_complete(str
@@ -791,7 +788,7 @@ int hostapd_setup_interface_complete(str
if (hostapd_driver_commit(hapd) < 0) {
wpa_printf(MSG_ERROR, "%s: Failed to commit driver "
"configuration", __func__);
@ -66,8 +66,8 @@
+ goto error;
}
if (hapd->setup_complete_cb)
@@ -798,6 +795,11 @@ int hostapd_setup_interface_complete(str
/*
@@ -815,6 +812,11 @@ int hostapd_setup_interface_complete(str
iface->init_complete(iface);
return 0;

@ -141,7 +141,7 @@
ifeq ($(CONFIG_CTRL_IFACE), y)
--- a/wpa_supplicant/Android.mk
+++ b/wpa_supplicant/Android.mk
@@ -1102,9 +1102,8 @@ endif
@@ -1109,9 +1109,8 @@ endif
ifdef CONFIG_NO_RANDOM_POOL
L_CFLAGS += -DCONFIG_NO_RANDOM_POOL

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -4921,9 +4921,6 @@ static int wpa_driver_nl80211_set_mode(v
@@ -5005,9 +5005,6 @@ static int wpa_driver_nl80211_set_mode(v
/* Try to set the mode again while the interface is
* down */
ret = nl80211_set_mode(drv, drv->ifindex, nlmode);
@ -10,7 +10,7 @@
if (!ret)
break;
} else
@@ -4936,6 +4933,8 @@ static int wpa_driver_nl80211_set_mode(v
@@ -5020,6 +5017,8 @@ static int wpa_driver_nl80211_set_mode(v
wpa_printf(MSG_DEBUG, "nl80211: Mode change succeeded while "
"interface is down");
drv->nlmode = nlmode;

@ -1,6 +1,6 @@
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -5504,6 +5504,9 @@ static int i802_set_wds_sta(void *priv,
@@ -5660,6 +5660,9 @@ static int i802_set_wds_sta(void *priv,
linux_set_iface_flags(drv->ioctl_sock, name, 1);
return i802_set_sta_vlan(priv, addr, name, 0);
} else {
@ -10,7 +10,7 @@
i802_set_sta_vlan(priv, addr, bss->ifname, 0);
return wpa_driver_nl80211_if_remove(priv, WPA_IF_AP_VLAN,
name);
@@ -5944,14 +5947,14 @@ static int wpa_driver_nl80211_if_remove(
@@ -6021,14 +6024,14 @@ static int wpa_driver_nl80211_if_remove(
return -1;
#ifdef HOSTAPD

@ -1,6 +1,6 @@
--- a/hostapd/config_file.c
+++ b/hostapd/config_file.c
@@ -1901,6 +1901,10 @@ struct hostapd_config * hostapd_config_r
@@ -1920,6 +1920,10 @@ struct hostapd_config * hostapd_config_r
"ht_capab", line);
errors++;
}
@ -13,7 +13,7 @@
#endif /* CONFIG_IEEE80211N */
--- a/src/ap/ap_config.h
+++ b/src/ap/ap_config.h
@@ -393,6 +393,7 @@ struct hostapd_config {
@@ -395,6 +395,7 @@ struct hostapd_config {
int ieee80211n;
int secondary_channel;
int require_ht;

Loading…
Cancel
Save