ar71xx: add GL-Domino Pi support V3

This is the patch for GL-Domino Pi V3. Updated against the latest trunk.

Signed-off-by: alzhao<alzhao@gmail.com>

SVN-Revision: 47622
v19.07.3_mercusys_ac12_duma
John Crispin 9 years ago
parent a04c3e73a3
commit 1a092ce0e0

@ -225,6 +225,10 @@ gl-ar300)
ucidef_set_led_wlan "wlan" "WLAN" "gl_ar300:wlan" "phy0tpt"
;;
gl-domino)
ucidef_set_led_wlan "wlan" "WLAN" "domino:blue:wlan" "phy0tpt"
;;
gl-inet)
ucidef_set_led_netdev "lan" "LAN" "gl-connect:green:lan" "eth1"
ucidef_set_led_wlan "wlan" "WLAN" "gl-connect:red:wlan" "phy0tpt"

@ -397,6 +397,7 @@ alfa-ap96 |\
alfa-nx |\
ap83 |\
gl-ar150 |\
gl-domino |\
gl-inet |\
jwap003 |\
pb42 |\

@ -466,6 +466,9 @@ ar71xx_board_detect() {
*"Dragino v2")
name="dragino2"
;;
*"Domino Pi")
name="gl-domino"
;;
*"EAP300 v2")
name="eap300v2"
;;

@ -222,6 +222,7 @@ platform_check_image() {
ew-dorin-router | \
gl-ar150 | \
gl-ar300 | \
gl-domino | \
hiwifi-hc6361 | \
hornet-ub-x2 | \
mzk-w04nu | \

@ -66,6 +66,7 @@ CONFIG_ATH79_MACH_DIR_825_C1=y
CONFIG_ATH79_MACH_DLAN_HOTSPOT=y
CONFIG_ATH79_MACH_DLAN_PRO_1200_AC=y
CONFIG_ATH79_MACH_DLAN_PRO_500_WP=y
CONFIG_ATH79_MACH_GL_DOMINO=y
CONFIG_ATH79_MACH_DRAGINO2=y
CONFIG_ATH79_MACH_EAP300V2=y
CONFIG_ATH79_MACH_EAP7660D=y

@ -0,0 +1,136 @@
/*
* Domino board support
*
* Copyright (C) 2011 dongyuqi <729650915@qq.com>
* Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
* Copyright (C) 2013 alzhao <alzhao@gmail.com>
* Copyright (C) 2014 Michel Stempin <michel.stempin@wanadoo.fr>
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/
#include <linux/gpio.h>
#include <asm/mach-ath79/ath79.h>
#include "dev-eth.h"
#include "dev-gpio-buttons.h"
#include "dev-leds-gpio.h"
#include "dev-m25p80.h"
#include "dev-usb.h"
#include "dev-wmac.h"
#include "machtypes.h"
#define DOMINO_GPIO_LED_WLAN 0
#define DOMINO_GPIO_LED_WAN 17
#define DOMINO_GPIO_LED_USB 1
#define DOMINO_GPIO_LED_LAN1 13
#define DOMINO_GPIO_LED_LAN2 14
#define DOMINO_GPIO_LED_LAN3 15
#define DOMINO_GPIO_LED_LAN4 16
#define DOMINO_GPIO_LED_SYS 27
#define DOMINO_GPIO_LED_WPS 26
#define DOMINO_GPIO_USB_POWER 6
#define DOMINO_GPIO_BTN_RESET 11
#define DOMINO_GPIO_BTN_WPS 20
#define DOMINO_KEYS_POLL_INTERVAL 20 /* msecs */
#define DOMINO_KEYS_DEBOUNCE_INTERVAL (3 * DOMINO_KEYS_POLL_INTERVAL)
#define DOMINO_MAC0_OFFSET 0x0000
#define DOMINO_MAC1_OFFSET 0x0000
#define DOMINO_CALDATA_OFFSET 0x1000
#define DOMINO_WMAC_MAC_OFFSET 0x0000
static struct gpio_led domino_leds_gpio[] __initdata = {
{
.name = "domino:blue:wlan",
.gpio = DOMINO_GPIO_LED_WLAN,
.active_low = 0,
},
{
.name = "domino:red:wan",
.gpio = DOMINO_GPIO_LED_WAN,
.active_low = 1,
},
{
.name = "domino:white:usb",
.gpio = DOMINO_GPIO_LED_USB,
.active_low = 0,
},
{
.name = "domino:green:lan1",
.gpio = DOMINO_GPIO_LED_LAN1,
.active_low = 0,
},
{
.name = "domino:yellow:wps",
.gpio = DOMINO_GPIO_LED_WPS,
.active_low = 1,
},
{
.name = "domino:orange:sys",
.gpio = DOMINO_GPIO_LED_SYS,
.active_low = 1,
},
};
static struct gpio_keys_button domino_gpio_keys[] __initdata = {
{
.desc = "reset",
.type = EV_KEY,
.code = KEY_RESTART,
.debounce_interval = DOMINO_KEYS_DEBOUNCE_INTERVAL,
.gpio = DOMINO_GPIO_BTN_RESET,
.active_low = 0,
},
{
.desc = "wps",
.type = EV_KEY,
.code = KEY_WPS_BUTTON,
.debounce_interval = DOMINO_KEYS_DEBOUNCE_INTERVAL,
.gpio = DOMINO_GPIO_BTN_WPS,
.active_low = 0,
}
};
static void __init domino_setup(void)
{
/* ART base address */
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
/* disable PHY_SWAP and PHY_ADDR_SWAP bits */
ath79_setup_ar933x_phy4_switch(false, false);
/* register flash. */
ath79_register_m25p80(NULL);
/* register gpio LEDs and keys */
ath79_register_leds_gpio(-1, ARRAY_SIZE(domino_leds_gpio),
domino_leds_gpio);
ath79_register_gpio_keys_polled(-1, DOMINO_KEYS_POLL_INTERVAL,
ARRAY_SIZE(domino_gpio_keys),
domino_gpio_keys);
gpio_request_one(DOMINO_GPIO_USB_POWER,
GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
"USB power");
/* enable usb */
ath79_register_usb();
/* register eth0 as WAN, eth1 as LAN */
ath79_init_mac(ath79_eth0_data.mac_addr, art+DOMINO_MAC0_OFFSET, 0);
ath79_init_mac(ath79_eth1_data.mac_addr, art+DOMINO_MAC1_OFFSET, 0);
ath79_register_mdio(0, 0x0);
ath79_register_eth(0);
ath79_register_eth(1);
/* register wireless mac with cal data */
ath79_register_wmac(art + DOMINO_CALDATA_OFFSET, art + DOMINO_WMAC_MAC_OFFSET);
}
MIPS_MACHINE(ATH79_MACH_GL_DOMINO, "DOMINO", "Domino Pi", domino_setup);

@ -36,3 +36,14 @@ define Profile/GL-AR300/Description
endef
$(eval $(call Profile,GL-AR300))
define Profile/DOMINO
NAME:=GL Domino Pi
PACKAGES:=kmod-usb-core kmod-usb2
endef
define Profile/DOMINO/Description
Configuration of Domino, Wifi for everything.
endef
$(eval $(call Profile,DOMINO))

@ -204,6 +204,14 @@ define Device/gl-ar300
endef
TARGET_DEVICES += gl-ar300
define Device/gl-domino
BOARDNAME = DOMINO
IMAGE_SIZE = 16000k
CONSOLE = ttyATH0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-domino
define Device/wndr3700
BOARDNAME = WNDR3700

@ -0,0 +1,39 @@
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -597,6 +597,16 @@ config ATH79_MACH_GL_AR300
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_GL_DOMINO
+ bool "DOMINO support"
+ select SOC_AR933X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_GL_INET
bool "GL-INET support"
select SOC_AR933X
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -85,6 +85,7 @@ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach
obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
+obj-$(CONFIG_ATH79_MACH_GL_DOMINO) += mach-gl-domino.o
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -74,6 +74,7 @@ enum ath79_mach_type {
ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
ATH79_MACH_GL_AR150, /* GL-AR150 support */
ATH79_MACH_GL_AR300, /* GL-AR300 */
+ ATH79_MACH_GL_DOMINO, /* Domino */
ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
Loading…
Cancel
Save