Add support for LED drivers (clock tick and CPU activity) Removed partition support (done on command line now)

SVN-Revision: 6531
v19.07.3_mercusys_ac12_duma
Hamish Guthrie 18 years ago
parent 4af390ee76
commit 18b744818a

@ -73,7 +73,6 @@ CONFIG_CPU_CP15_MMU=y
# CONFIG_CPU_DCACHE_WRITETHROUGH is not set
# CONFIG_CPU_ICACHE_DISABLE is not set
CONFIG_CPU_TLB_V4WBI=y
CONFIG_CRC32=m
# CONFIG_CRYPTO_AES is not set
CONFIG_CRYPTO_ALGAPI=m
# CONFIG_CRYPTO_ANUBIS is not set
@ -102,6 +101,7 @@ CONFIG_DAVICOM_PHY=y
# CONFIG_DEBUG_BUGVERBOSE is not set
CONFIG_DEBUG_DRIVER=y
# CONFIG_DEBUG_ERRORS is not set
CONFIG_DEBUG_FS=y
# CONFIG_DEBUG_INFO is not set
CONFIG_DEBUG_KERNEL=y
# CONFIG_DEBUG_KOBJECT is not set
@ -169,12 +169,13 @@ CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
# CONFIG_IP_ROUTE_MULTIPATH_CACHED is not set
# CONFIG_IP_ROUTE_VERBOSE is not set
# CONFIG_ISO9660_FS is not set
# CONFIG_JFFS2_FS is not set
CONFIG_JFFS2_FS_DEBUG=0
# CONFIG_JFS_FS is not set
# CONFIG_LEDS is not set
CONFIG_LEDS=y
CONFIG_LEDS_CPU=y
CONFIG_LEDS_TIMER=y
# CONFIG_LIBCRC32C is not set
# CONFIG_LLC2 is not set
# CONFIG_LOCALVERSION_AUTO is not set
# CONFIG_MACH_AT91RM9200EK is not set
# CONFIG_MACH_ATEB9200 is not set
# CONFIG_MACH_CARMEVA is not set
@ -186,7 +187,6 @@ CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_MACH_VLINK=y
# CONFIG_MINIX_FS is not set
CONFIG_MINI_FO=y
# CONFIG_MODULE_UNLOAD is not set
# CONFIG_MSDOS_FS is not set
CONFIG_MTD=y
# CONFIG_MTD_ABSENT is not set
@ -200,16 +200,14 @@ CONFIG_MTD_CFI_I2=y
# CONFIG_MTD_CFI_I4 is not set
# CONFIG_MTD_CFI_I8 is not set
CONFIG_MTD_CHAR=y
# CONFIG_MTD_CMDLINE_PARTS is not set
CONFIG_MTD_CMDLINE_PARTS=y
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
# CONFIG_MTD_CONCAT is not set
CONFIG_MTD_DATAFLASH=y
# CONFIG_MTD_DEBUG is not set
# CONFIG_MTD_DOC2000 is not set
# CONFIG_MTD_DOC2001 is not set
# CONFIG_MTD_DOC2001PLUS is not set
# CONFIG_MTD_JEDECPROBE is not set
# CONFIG_MTD_M25P80 is not set
CONFIG_MTD_MAP_BANK_WIDTH_1=y
# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
CONFIG_MTD_MAP_BANK_WIDTH_2=y
@ -227,6 +225,7 @@ CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_ROM is not set
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_SPLIT_ROOTFS is not set
# CONFIG_NETFILTER_XT_MATCH_COMMENT is not set
# CONFIG_NETFILTER_XT_MATCH_CONNBYTES is not set
# CONFIG_NETFILTER_XT_MATCH_DCCP is not set
@ -278,11 +277,6 @@ CONFIG_SERIO_SERPORT=y
# CONFIG_SMSC_PHY is not set
# CONFIG_SOUND is not set
# CONFIG_SPARSEMEM_STATIC is not set
CONFIG_SPI=y
CONFIG_SPI_ATMEL=y
CONFIG_SPI_BITBANG=y
CONFIG_SPI_DEBUG=y
CONFIG_SPI_MASTER=y
CONFIG_SPLIT_PTLOCK_CPUS=4096
# CONFIG_UDF_FS is not set
CONFIG_UID16=y
@ -300,4 +294,3 @@ CONFIG_VT_CONSOLE=y
# CONFIG_XIP_KERNEL is not set
CONFIG_ZBOOT_ROM_BSS=0x0
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZLIB_DEFLATE=m

@ -0,0 +1,166 @@
diff -urN linux-2.6.19.2.old/arch/arm/mach-at91rm9200/Makefile linux-2.6.19.2/arch/arm/mach-at91rm9200/Makefile
--- linux-2.6.19.2.old/arch/arm/mach-at91rm9200/Makefile 2007-03-06 11:29:37.000000000 +0100
+++ linux-2.6.19.2/arch/arm/mach-at91rm9200/Makefile 2007-03-06 20:52:28.000000000 +0100
@@ -40,6 +40,7 @@
led-$(CONFIG_MACH_CSB637) += leds.o
led-$(CONFIG_MACH_KB9200) += leds.o
led-$(CONFIG_MACH_KAFA) += leds.o
+led-$(CONFIG_MACH_VLINK) += vlink_leds.o
obj-$(CONFIG_LEDS) += $(led-y)
# VGA support
diff -urN linux-2.6.19.2.old/arch/arm/mach-at91rm9200/vlink_leds.c linux-2.6.19.2/arch/arm/mach-at91rm9200/vlink_leds.c
--- linux-2.6.19.2.old/arch/arm/mach-at91rm9200/vlink_leds.c 1970-01-01 01:00:00.000000000 +0100
+++ linux-2.6.19.2/arch/arm/mach-at91rm9200/vlink_leds.c 2007-03-06 21:11:16.000000000 +0100
@@ -0,0 +1,151 @@
+/*
+ * LED driver for Atmel AT91-based boards.
+ *
+ * Copyright (C) SAN People (Pty) Ltd
+ *
+ * Modified for FDL Versalink board (c) Guthrie Consulting
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+*/
+
+#include <linux/kernel.h>
+#include <linux/module.h>
+#include <linux/init.h>
+
+#include <asm/mach-types.h>
+#include <asm/leds.h>
+#include <asm/arch/board.h>
+#include <asm/arch/gpio.h>
+
+#define LED_CPU 0
+#define LED_TIMER 1
+#define LED_COM1 2
+#define LED_COM2 3
+
+static inline void at91_led_on(unsigned int led)
+{
+ at91_set_gpio_value(led, 0);
+}
+
+static inline void at91_led_off(unsigned int led)
+{
+ at91_set_gpio_value(led, 1);
+}
+
+static inline void at91_led_toggle(unsigned int led)
+{
+ unsigned long is_off = at91_get_gpio_value(AT91_PIN_PC7);
+ if (is_off) {
+ at91_set_gpio_value(AT91_PIN_PC7, 0);
+ at91_set_gpio_value(AT91_PIN_PC8, 1);
+ } else {
+ at91_set_gpio_value(AT91_PIN_PC7, 1);
+ at91_set_gpio_value(AT91_PIN_PC8, 0);
+ }
+}
+
+
+/*
+ * Handle LED events.
+ */
+static void at91_leds_event(led_event_t evt)
+{
+ unsigned long flags;
+
+ local_irq_save(flags);
+
+ switch(evt) {
+ case led_start: /* System startup */
+// at91_led_on(at91_leds_cpu);
+ at91_led_toggle(at91_leds_timer);
+/*
+ at91_set_gpio_value(AT91_PIN_PC7, 0);
+ at91_set_gpio_value(AT91_PIN_PC8, 1);
+*/
+ break;
+
+ case led_stop: /* System stop / suspend */
+ at91_led_toggle(at91_leds_timer);
+/*
+ at91_set_gpio_value(AT91_PIN_PC7, 1);
+ at91_set_gpio_value(AT91_PIN_PC8, 0);
+*/
+ break;
+
+#ifdef CONFIG_LEDS_TIMER
+ case led_timer: /* Every 50 timer ticks */
+ at91_led_toggle(at91_leds_timer);
+ break;
+#endif
+
+#ifdef CONFIG_LEDS_CPU
+ case led_idle_start: /* Entering idle state */
+ at91_led_toggle(at91_leds_timer);
+/*
+ at91_set_gpio_value(AT91_PIN_PC7, 1);
+ at91_set_gpio_value(AT91_PIN_PC8, 0);
+*/
+ break;
+
+ case led_idle_end: /* Exit idle state */
+ at91_led_toggle(at91_leds_timer);
+/*
+ at91_set_gpio_value(AT91_PIN_PC7, 0);
+ at91_set_gpio_value(AT91_PIN_PC8, 1);
+*/
+ break;
+#endif
+
+ default:
+ break;
+ }
+
+ local_irq_restore(flags);
+}
+
+
+static int __init leds_init(void)
+{
+/* if (!at91_leds_timer || !at91_leds_cpu)
+ return -ENODEV;
+*/
+// printk("leds_init()\n");
+
+ /* Enable PIO to access the LEDs */
+ at91_set_gpio_output(AT91_PIN_PC7, 1);
+ at91_set_gpio_output(AT91_PIN_PC8, 1);
+ at91_set_gpio_output(AT91_PIN_PC14, 1);
+ at91_set_gpio_output(AT91_PIN_PC15, 1);
+ at91_set_gpio_output(AT91_PIN_PB14, 1);
+ at91_set_gpio_output(AT91_PIN_PB15, 1);
+ at91_set_gpio_output(AT91_PIN_PB16, 1);
+ at91_set_gpio_output(AT91_PIN_PB17, 1);
+
+ at91_set_gpio_output(AT91_PIN_PB9, 1);
+ at91_set_gpio_output(AT91_PIN_PB10, 1);
+ at91_set_gpio_output(AT91_PIN_PB11, 1);
+ at91_set_gpio_output(AT91_PIN_PB12, 1);
+
+ at91_set_gpio_input(AT91_PIN_PB8, 1);
+ at91_set_gpio_input(AT91_PIN_PB22, 1);
+ at91_set_gpio_input(AT91_PIN_PA19, 1);
+ at91_set_gpio_input(AT91_PIN_PA24, 1);
+ at91_set_gpio_output(AT91_PIN_PA29, 1);
+ at91_set_gpio_output(AT91_PIN_PB2, 1);
+ at91_set_gpio_output(AT91_PIN_PB3, 1);
+ at91_set_gpio_output(AT91_PIN_PB4, 1);
+
+ at91_set_gpio_input(AT91_PIN_PB27, 1);
+ at91_set_gpio_input(AT91_PIN_PB28, 1);
+ at91_set_gpio_input(AT91_PIN_PB29, 1);
+
+ leds_event = at91_leds_event;
+
+ leds_event(led_start);
+ return 0;
+}
+
+__initcall(leds_init);

@ -1,37 +0,0 @@
diff -urN linux-2.6.19.2/drivers/mtd/devices/at91_dataflash.c linux-2.6.19.2.old/drivers/mtd/devices/at91_dataflash.c
--- linux-2.6.19.2/drivers/mtd/devices/at91_dataflash.c 2007-03-05 11:21:48.000000000 +0100
+++ linux-2.6.19.2.old/drivers/mtd/devices/at91_dataflash.c 2007-03-05 09:23:03.000000000 +0100
@@ -130,28 +130,18 @@
{
.name = "bootloader",
.offset = 0,
- .size = 1 * 32 * 8 * 1056, /* 1st sector = 16 blocks * 8 pages * 1056 bytes */
+ .size = 1 * 32 * 8 * 1056, /* 1st sector = 32 blocks * 8 pages * 1056 bytes */
.mask_flags = MTD_WRITEABLE, /* read-only */
},
{
- .name = "linux",
+ .name = "kernel",
.offset = MTDPART_OFS_NXTBLK,
- .size = 4 * 32 * 8 * 1056, /* 4 sectors */
+ .size = 5 * 32 * 8 * 1056, /* 5 sectors */
},
{
- .name = "rootfs",
+ .name = "filesystem",
.offset = MTDPART_OFS_NXTBLK,
- .size = 4 * 32 * 8 * 1056, /* 4 sectors */
- },
- {
- .name = "nvram",
- .offset = MTDPART_OFS_NXTBLK,
- .size = 1 * 4 * 8 * 1056, /* 4 blocks of 8 pages = ~32k */
- },
- {
- .name = "OpenWrt",
- .offset = MTDPART_OFS_NXTBLK,
- .size = MTDPART_SIZ_FULL, /* rest of device */
+ .size = MTDPART_SIZ_FULL, /* rest = 26 sectors */
}
};
#endif
Loading…
Cancel
Save