iproute2: update to 3.10.0

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 37590
v19.07.3_mercusys_ac12_duma
Luka Perkov 11 years ago
parent f566115085
commit 1646bd096c

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=3.9.0
PKG_RELEASE:=3
PKG_VERSION:=3.10.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
PKG_MD5SUM:=b53376db94c8d66f9d540c69ed84f13b
PKG_MD5SUM:=45fb5427fc723a0001c72b92c931ba02
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)

@ -8,7 +8,7 @@
case IPPROTO_DCCP:
default: /* XXX */
if (sel->sport_mask)
@@ -1273,7 +1272,6 @@ static int xfrm_selector_upspec_parse(st
@@ -1283,7 +1282,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:

@ -9,8 +9,6 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
ip/rtm_map.c | 4 ++++
3 files changed, 9 insertions(+)
diff --git a/include/linux/fib_rules.h b/include/linux/fib_rules.h
index 51da65b..3420838 100644
--- a/include/linux/fib_rules.h
+++ b/include/linux/fib_rules.h
@@ -64,6 +64,10 @@ enum {
@ -24,8 +22,6 @@ index 51da65b..3420838 100644
__FR_ACT_MAX,
};
diff --git a/include/linux/rtnetlink.h b/include/linux/rtnetlink.h
index 93370bd..cfec9ff 100644
--- a/include/linux/rtnetlink.h
+++ b/include/linux/rtnetlink.h
@@ -203,6 +203,7 @@ enum {
@ -36,11 +32,9 @@ index 93370bd..cfec9ff 100644
__RTN_MAX
};
diff --git a/ip/rtm_map.c b/ip/rtm_map.c
index 21e818b..8ad2d07 100644
--- a/ip/rtm_map.c
+++ b/ip/rtm_map.c
@@ -49,6 +49,8 @@ char *rtnl_rtntype_n2a(int id, char *buf, int len)
@@ -49,6 +49,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
return "nat";
case RTN_XRESOLVE:
return "xresolve";
@ -58,6 +52,3 @@ index 21e818b..8ad2d07 100644
else {
res = strtoul(arg, &end, 0);
if (!end || end == arg || *end || res > 255)
--
1.7.10.4

Loading…
Cancel
Save