fuse: remove obsolete patches

SVN-Revision: 32393
v19.07.3_mercusys_ac12_duma
Felix Fietkau 12 years ago
parent b391548cf0
commit 0934a4035e

@ -1,45 +0,0 @@
--- a/kernel/Makefile.in
+++ b/kernel/Makefile.in
@@ -54,23 +54,8 @@ distdir: $(DISTFILES) $(COMPATDISTFILES)
ifeq ($(majver), 2.4)
-CC = gcc
-LD = ld
-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe @KERNELCFLAGS@
-CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
-
fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
-SUFFIXES = .c .o .s
-
-all-spec: fuse.o
-
-.c.o:
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
-fuse.o: $(fuse_objs)
- $(LD) -r -o fuse.o $(fuse_objs)
-
fuse_headers = fuse_i.h fuse_kernel.h
dev.o: $(fuse_headers)
@@ -78,6 +63,18 @@ dir.o: $(fuse_headers)
file.o: $(fuse_headers)
inode.o: $(fuse_headers)
+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
+
+O_TARGET := fuse.o
+
+obj-y := $(fuse_objs)
+obj-m := $(O_TARGET)
+
+-include $(TOPDIR)/Rules.make
+
+all-spec:
+ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
+
else
EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"

@ -1,14 +0,0 @@
--- a/kernel/Makefile.in
+++ b/kernel/Makefile.in
@@ -31,11 +31,9 @@ all-y: all-spec
install-y: all
$(mkdir_p) $(DESTDIR)$(fusemoduledir)
$(INSTALL) -m 644 $(fusemodule) $(DESTDIR)$(fusemoduledir)/$(fusemodule)
- -/sbin/depmod -a
uninstall-y:
rm -f $(DESTDIR)$(fusemoduledir)/$(fusemodule)
- -/sbin/depmod -a
clean:
-rm -f $(fusemodule) *.o .*.cmd *.mod.c *.ko *.s */*.o

@ -1,11 +0,0 @@
--- a/util/Makefile.in
+++ b/util/Makefile.in
@@ -453,7 +453,7 @@ uninstall-am: uninstall-binPROGRAMS unin
install-exec-hook:
-chown root $(DESTDIR)$(bindir)/fusermount
-chmod u+s $(DESTDIR)$(bindir)/fusermount
- @if test ! -e $(DESTDIR)/dev/fuse; then \
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
$(mkdir_p) $(DESTDIR)/dev; \
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \

@ -1,73 +0,0 @@
--- a/kernel/dev.c
+++ b/kernel/dev.c
@@ -512,6 +512,9 @@ static int fuse_copy_fill(struct fuse_co
{
unsigned long offset;
int err;
+#ifdef DCACHE_BUG
+ struct vm_area_struct *vma;
+#endif
unlock_request(cs->req);
fuse_copy_finish(cs);
@@ -523,14 +526,22 @@ static int fuse_copy_fill(struct fuse_co
cs->nr_segs --;
}
down_read(&current->mm->mmap_sem);
+#ifndef DCACHE_BUG
err = get_user_pages(current, current->mm, cs->addr, 1, cs->write, 0,
&cs->pg, NULL);
+#else
+ err = get_user_pages(current, current->mm, cs->addr, 1, cs->write, 0,
+ &cs->pg, &vma);
+#endif
up_read(&current->mm->mmap_sem);
if (err < 0)
return err;
BUG_ON(err != 1);
offset = cs->addr % PAGE_SIZE;
cs->mapaddr = kmap_atomic(cs->pg, KM_USER0);
+#ifdef DCACHE_BUG
+ r4k_flush_cache_page(vma, cs->addr);
+#endif
cs->buf = cs->mapaddr + offset;
cs->len = min(PAGE_SIZE - offset, cs->seglen);
cs->seglen -= cs->len;
@@ -545,6 +556,11 @@ static inline int fuse_copy_do(struct fu
{
unsigned ncpy = min(*size, cs->len);
if (val) {
+#ifdef DCACHE_BUG
+ // patch from mailing list, it is very important, otherwise,
+ // can't mount, or ls mount point will hang
+ flush_cache_all();
+#endif
if (cs->write)
memcpy(cs->buf, *val, ncpy);
else
--- a/kernel/fuse_i.h
+++ b/kernel/fuse_i.h
@@ -45,6 +45,10 @@
# endif
#endif
+//#if defined(__arm__) && LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20)
+#define DCACHE_BUG
+//#endif
+
#include "config.h"
#ifndef KERNEL_2_6
# include <linux/config.h>
--- a/kernel/inode.c
+++ b/kernel/inode.c
@@ -739,6 +739,10 @@ static int __init fuse_init(void)
printk("fuse distribution version: %s\n", FUSE_VERSION);
#endif
+#ifdef DCACHE_BUG
+printk("fuse init: DCACHE_BUG enabled\n");
+#endif
+
spin_lock_init(&fuse_lock);
res = fuse_fs_init();
if (res)
Loading…
Cancel
Save