uClibc: update 0.9.32 to latest git

SVN-Revision: 24073
v19.07.3_mercusys_ac12_duma
Felix Fietkau 14 years ago
parent 9bfd20a160
commit 05e837fb6d

@ -14,7 +14,7 @@ PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
ifeq ($(CONFIG_UCLIBC_VERSION_0_9_32),y)
PKG_SOURCE_URL:=git://git.busybox.net/uClibc
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=ef487a35f428da6240003dca23b9d29908e2285e
PKG_SOURCE_VERSION:=22bf234a7119559901adfedc9991876af01eb64c
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
LIBC_SO_VERSION:=$(PKG_VERSION)-git

@ -168,6 +168,7 @@ UCLIBC_HAS_TM_EXTENSIONS=y
UCLIBC_HAS_TZ_CACHING=y
UCLIBC_HAS_TZ_FILE=y
UCLIBC_HAS_TZ_FILE_READ_MANY=y
# UCLIBC_HAS_UTMPX is not set
UCLIBC_HAS_WCHAR=y
UCLIBC_HAS_WORDEXP=y
# UCLIBC_HAS_XATTR is not set

@ -1,7 +1,6 @@
diff -ruN uClibc-0.9.32.orig/extra/Configs/Config.in uClibc-0.9.32/extra/Configs/Config.in
--- uClibc-0.9.32.orig/extra/Configs/Config.in 2010-08-05 08:41:15.880201300 +0000
+++ uClibc-0.9.32/extra/Configs/Config.in 2010-08-05 09:03:50.517199984 +0000
@@ -460,7 +460,6 @@
--- a/extra/Configs/Config.in
+++ b/extra/Configs/Config.in
@@ -453,7 +453,6 @@
select UCLIBC_HAS_TLS
select UCLIBC_HAS_STDIO_FUTEXES
# NPTL local:

@ -1,6 +1,6 @@
--- a/include/string.h
+++ b/include/string.h
@@ -357,18 +357,40 @@ extern char *index (__const char *__s, i
@@ -357,18 +357,40 @@
/* Find the last occurrence of C in S (same as strrchr). */
extern char *rindex (__const char *__s, int __c)
__THROW __attribute_pure__ __nonnull ((1));

@ -1,6 +1,6 @@
--- a/include/sys/timex.h
+++ b/include/sys/timex.h
@@ -116,9 +116,8 @@ struct timex
@@ -116,9 +116,8 @@
__BEGIN_DECLS

@ -1,12 +0,0 @@
--- a/libc/sysdeps/linux/common/bits/mathcalls.h
+++ b/libc/sysdeps/linux/common/bits/mathcalls.h
@@ -237,8 +237,7 @@ __END_NAMESPACE_C99
/* Return nonzero if VALUE is not a number. */
-/* DELETE? __MATHDECL_PRIV adds another "__": so this is "____isnan"???! */
-/*__MATHDECL_PRIV (int,__isnan,, (_Mdouble_ __value), (__const__))*/
+__MATHDECL_PRIV (int,isnan,, (_Mdouble_ __value), (__const__));
#if defined __USE_MISC || defined __USE_XOPEN
/* Return nonzero if VALUE is not a number. */

@ -1,6 +1,6 @@
--- a/include/math.h
+++ b/include/math.h
@@ -198,7 +198,7 @@ libm_hidden_proto(signgam)
@@ -195,7 +195,7 @@
/* ISO C99 defines some generic macros which work on any data type. */
@ -9,7 +9,7 @@
/* Get the architecture specific values describing the floating-point
evaluation. The following symbols will get defined:
@@ -318,6 +318,11 @@ enum
@@ -315,6 +315,11 @@
#endif /* Use ISO C99. */

@ -1,6 +1,6 @@
--- a/libc/stdio/_stdio.c
+++ b/libc/stdio/_stdio.c
@@ -119,7 +119,7 @@ static FILE _stdio_streams[] = {
@@ -124,7 +124,7 @@
__FLAG_NBF|__FLAG_WRITEONLY, \
2, \
NULL, \

@ -1,6 +1,6 @@
--- a/Rules.mak
+++ b/Rules.mak
@@ -477,6 +477,17 @@ ifeq ($(TARGET_ARCH),microblaze)
@@ -481,6 +481,17 @@
SYMBOL_PREFIX=_
endif
@ -20,7 +20,7 @@
endif
--- a/extra/Configs/Config.in
+++ b/extra/Configs/Config.in
@@ -102,6 +102,9 @@ config TARGET_sh64
@@ -102,6 +102,9 @@
config TARGET_sparc
bool "sparc"
@ -30,7 +30,7 @@
config TARGET_v850
bool "v850 (BROKEN)"
@@ -203,6 +206,10 @@ if TARGET_sparc
@@ -203,6 +206,10 @@
source "extra/Configs/Config.sparc"
endif
@ -43,7 +43,7 @@
endif
--- a/extra/Configs/Config.in.arch
+++ b/extra/Configs/Config.in.arch
@@ -149,7 +149,7 @@ config UCLIBC_HAS_SOFT_FLOAT
@@ -149,7 +149,7 @@
config DO_C99_MATH
bool "Enable full C99 math library support"
depends on UCLIBC_HAS_FLOATS
@ -101,7 +101,7 @@
+ string
--- a/include/elf.h
+++ b/include/elf.h
@@ -337,6 +337,8 @@ typedef struct
@@ -337,6 +337,8 @@
#define EM_XSTORMY16 0xad45
@ -110,7 +110,7 @@
/* FRV magic number - no EABI available??. */
#define EM_CYGNUS_FRV 0x5441
@@ -3063,6 +3065,55 @@ typedef Elf32_Addr Elf32_Conflict;
@@ -3063,6 +3065,55 @@
/* Keep this the last entry. */
#define R_XTENSA_NUM 50
@ -168,7 +168,7 @@
#endif
--- a/include/features.h
+++ b/include/features.h
@@ -445,4 +445,10 @@ uClibc was built without large file supp
@@ -445,4 +445,10 @@
# include <libc-internal.h>
#endif
@ -181,7 +181,7 @@
#endif /* features.h */
--- a/ldso/ldso/dl-startup.c
+++ b/ldso/ldso/dl-startup.c
@@ -164,10 +164,13 @@ DL_START(unsigned long args)
@@ -164,10 +164,13 @@
aux_dat += 2;
}
@ -197,7 +197,7 @@
--- a/ldso/ldso/ldso.c
+++ b/ldso/ldso/ldso.c
@@ -325,10 +325,12 @@ void _dl_get_ready_to_run(struct elf_res
@@ -327,10 +327,12 @@
_dl_progname = argv[0];
}
@ -2095,7 +2095,7 @@
+ .size _dl_ubicom32_resolve_pending, . - _dl_ubicom32_resolve_pending
--- a/libc/misc/Makefile.in
+++ b/libc/misc/Makefile.in
@@ -12,7 +12,9 @@ include $(top_srcdir)libc/misc/assert/Ma
@@ -12,7 +12,9 @@
include $(top_srcdir)libc/misc/ctype/Makefile.in
include $(top_srcdir)libc/misc/dirent/Makefile.in
include $(top_srcdir)libc/misc/error/Makefile.in
@ -4170,7 +4170,7 @@
+ .set __GI_vfork,vfork
--- a/libpthread/linuxthreads.old/pthread.c
+++ b/libpthread/linuxthreads.old/pthread.c
@@ -393,6 +393,10 @@ void __pthread_initialize_minimal(void)
@@ -393,6 +393,10 @@
#endif
__libc_multiple_threads_ptr = __libc_pthread_init (ptr_pthread_functions);
@ -4181,7 +4181,7 @@
}
@@ -461,8 +465,11 @@ static void pthread_initialize(void)
@@ -461,8 +465,11 @@
* __pthread_initial_thread_bos at address 0. These bounds are refined as we
* malloc other stack frames such that they don't overlap. -StS
*/

Loading…
Cancel
Save