update to 2.6.22-rc6

SVN-Revision: 7758
v19.07.3_mercusys_ac12_duma
Gabor Juhos 17 years ago
parent 01b4fd853a
commit 031f500ae4

@ -1,4 +1,4 @@
#
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@ -11,7 +11,7 @@ BOARD:=adm5120
BOARDNAME:=ADM5120 (Little Endian)
FEATURES:=squashfs jffs2 pci usb
LINUX_VERSION:=2.6.21.5
LINUX_VERSION:=2.6.22-rc6
define Target/Description
Build firmware images for Infineon/ADMtek ADM5120 based boards

@ -5,6 +5,8 @@ CONFIG_ADM5120_HARDWARE_SWAB=y
CONFIG_ADM5120_NR_UARTS=2
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
# CONFIG_ARCH_SUPPORTS_MSI is not set
# CONFIG_ATM_DRIVERS is not set
CONFIG_BASE_SMALL=0
CONFIG_BAYCOM_SER_FDX=m
CONFIG_BAYCOM_SER_HDX=m
@ -46,6 +48,7 @@ CONFIG_CPU_SUPPORTS_HIGHMEM=y
# CONFIG_CPU_VR41XX is not set
CONFIG_CRYPTO_SHA1=y
# CONFIG_DDB5477 is not set
CONFIG_DEVPORT=y
# CONFIG_DM9000 is not set
CONFIG_DMA_NEED_PCI_MAP_STATE=y
CONFIG_DMA_NONCOHERENT=y
@ -60,6 +63,7 @@ CONFIG_GENERIC_FIND_NEXT_BIT=y
CONFIG_GENERIC_GPIO=y
# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
# CONFIG_GEN_RTC is not set
CONFIG_HAS_DMA=y
CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT=y
CONFIG_HID=m
@ -100,6 +104,7 @@ CONFIG_LEDS_ADM5120_DIAG=y
CONFIG_LEDS_GPIO=y
CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256
# CONFIG_MACH_ALCHEMY is not set
# CONFIG_MACH_DECSTATION is not set
# CONFIG_MACH_JAZZ is not set
# CONFIG_MACH_VR41XX is not set
@ -109,36 +114,20 @@ CONFIG_MIPS=y
CONFIG_MIPS_ADM5120=y
CONFIG_MIPS_ADM5120_ENET=y
# CONFIG_MIPS_ATLAS is not set
# CONFIG_MIPS_BOSPORUS is not set
# CONFIG_MIPS_COBALT is not set
# CONFIG_MIPS_DB1000 is not set
# CONFIG_MIPS_DB1100 is not set
# CONFIG_MIPS_DB1200 is not set
# CONFIG_MIPS_DB1500 is not set
# CONFIG_MIPS_DB1550 is not set
# CONFIG_MIPS_EV64120 is not set
CONFIG_MIPS_L1_CACHE_SHIFT=5
# CONFIG_MIPS_MALTA is not set
# CONFIG_MIPS_MIRAGE is not set
# CONFIG_MIPS_MTX1 is not set
CONFIG_MIPS_MT_DISABLED=y
# CONFIG_MIPS_MT_SMP is not set
# CONFIG_MIPS_MT_SMTC is not set
# CONFIG_MIPS_PB1000 is not set
# CONFIG_MIPS_PB1100 is not set
# CONFIG_MIPS_PB1200 is not set
# CONFIG_MIPS_PB1500 is not set
# CONFIG_MIPS_PB1550 is not set
# CONFIG_MIPS_SEAD is not set
# CONFIG_MIPS_SIM is not set
# CONFIG_MIPS_VPE_LOADER is not set
# CONFIG_MIPS_XXS1500 is not set
CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_MOMENCO_JAGUAR_ATX is not set
# CONFIG_MOMENCO_OCELOT is not set
# CONFIG_MOMENCO_OCELOT_3 is not set
# CONFIG_MOMENCO_OCELOT_C is not set
# CONFIG_MOMENCO_OCELOT_G is not set
CONFIG_MTD=y
# CONFIG_MTD_ABSENT is not set
CONFIG_MTD_ADM5120=y
@ -179,10 +168,11 @@ CONFIG_MTD_NAND=y
# CONFIG_MTD_NAND_DISKONCHIP is not set
# CONFIG_MTD_NAND_ECC_SMC is not set
CONFIG_MTD_NAND_IDS=y
# CONFIG_MTD_NAND_MUSEUM_IDS is not set
# CONFIG_MTD_NAND_NANDSIM is not set
# CONFIG_MTD_NAND_PLATFORM is not set
CONFIG_MTD_NAND_RB100=y
# CONFIG_MTD_NAND_VERIFY_WRITE is not set
# CONFIG_MTD_OBSOLETE_CHIPS is not set
# CONFIG_MTD_ONENAND is not set
CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_PCI is not set
@ -194,6 +184,7 @@ CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_ROM is not set
# CONFIG_MTD_SLRAM is not set
# CONFIG_NETDEV_1000 is not set
CONFIG_NET_KEY=y
# CONFIG_NET_PCI is not set
# CONFIG_NET_PKTGEN is not set
@ -214,6 +205,7 @@ CONFIG_PCI_ADM5120=y
# CONFIG_RTC is not set
CONFIG_RWSEM_GENERIC_SPINLOCK=y
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
CONFIG_SCSI_WAIT_SCAN=m
# CONFIG_SERIAL_8250 is not set
CONFIG_SERIAL_ADM5120=y
CONFIG_SERIO=y
@ -260,11 +252,7 @@ CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
# CONFIG_USB_EHCI_SPLIT_ISO is not set
# CONFIG_USB_EHCI_TT_NEWSCHED is not set
# CONFIG_USB_ET61X251 is not set
# CONFIG_USB_GTCO is not set
# CONFIG_USB_IBMCAM is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_KONICAWC is not set
# CONFIG_USB_NET_DM9601 is not set
# CONFIG_USB_NET_GL620A is not set
# CONFIG_USB_NET_MCS7830 is not set
@ -273,22 +261,12 @@ CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_HCD=m
# CONFIG_USB_OV511 is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_PWC is not set
# CONFIG_USB_QUICKCAM_MESSENGER is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_SE401 is not set
# CONFIG_USB_SERIAL is not set
# CONFIG_USB_SN9C102 is not set
# CONFIG_USB_STV680 is not set
# CONFIG_USB_UHCI_HCD is not set
# CONFIG_USB_VICAM is not set
# CONFIG_USB_ZC0301 is not set
# CONFIG_USB_ZD1201 is not set
# CONFIG_VIDEO_CPIA is not set
CONFIG_VIDEO_CPIA2=m
# CONFIG_VIDEO_STRADIS is not set
# CONFIG_VGASTATE is not set
CONFIG_VIDEO_V4L1=y
CONFIG_VM_EVENT_COUNTERS=y
CONFIG_YAFFS_9BYTE_TAGS=y
@ -302,3 +280,4 @@ CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
CONFIG_YAFFS_YAFFS1=y
CONFIG_YAFFS_YAFFS2=y
# CONFIG_ZD1211RW is not set
CONFIG_ZONE_DMA_FLAG=0

@ -91,7 +91,8 @@ int __init pcibios_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
irq = -1;
if (slot < 1 || slot > 3) {
printk("PCI: slot number %u is not supported\n", slot);
printk(KERN_ALERT "PCI: slot number %u is not supported\n",
slot);
goto out;
}
@ -124,8 +125,8 @@ int __init pcibios_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
case MACH_ADM5120_WPP54AG:
case MACH_ADM5120_WPP54G:
default:
printk("PCI: irq map is unknown for %s, using defaults.\n",
adm5120_board_name());
printk(KERN_ALERT "PCI: irq map is unknown for %s, using "
"defaults.\n", adm5120_board_name());
break;
}
@ -138,7 +139,7 @@ int __init pcibios_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
}
if (irq < 0) {
printk(KERN_INFO "PCI: no irq found for %s pin:%u\n",
printk(KERN_ALERT "PCI: no irq found for %s pin:%u\n",
pci_name(dev), pin);
} else {
printk(KERN_INFO "PCI: mapping irq for %s pin:%u, irq:%d\n",

@ -1,11 +1,11 @@
Index: linux-2.6.21.1/arch/mips/Kconfig
Index: linux-2.6.22-rc6/arch/mips/Kconfig
===================================================================
--- linux-2.6.21.1.orig/arch/mips/Kconfig
+++ linux-2.6.21.1/arch/mips/Kconfig
@@ -16,6 +16,17 @@ choice
--- linux-2.6.22-rc6.orig/arch/mips/Kconfig
+++ linux-2.6.22-rc6/arch/mips/Kconfig
@@ -15,6 +15,17 @@ choice
prompt "System type"
default SGI_IP22
+config MIPS_ADM5120
+ bool "Support for ADM5120 SoC"
+ select SYS_HAS_CPU_MIPS32_R1
@ -17,24 +17,24 @@ Index: linux-2.6.21.1/arch/mips/Kconfig
+ select SYS_SUPPORTS_32BIT_KERNEL
+ select GENERIC_GPIO
+
config MIPS_MTX1
bool "4G Systems MTX-1 board"
select DMA_NONCOHERENT
@@ -766,6 +775,7 @@
config MACH_ALCHEMY
bool "Alchemy processor based machines"
@@ -658,6 +669,7 @@ config TOSHIBA_RBTX4938
endchoice
+source "arch/mips/adm5120/Kconfig"
source "arch/mips/au1000/Kconfig"
source "arch/mips/ddb5xxx/Kconfig"
source "arch/mips/gt64120/ev64120/Kconfig"
source "arch/mips/jazz/Kconfig"
Index: linux-2.6.21.1/arch/mips/Makefile
Index: linux-2.6.22-rc6/arch/mips/Makefile
===================================================================
--- linux-2.6.21.1.orig/arch/mips/Makefile
+++ linux-2.6.21.1/arch/mips/Makefile
--- linux-2.6.22-rc6.orig/arch/mips/Makefile
+++ linux-2.6.22-rc6/arch/mips/Makefile
@@ -165,6 +165,14 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#
+# ADMtek 5120
+#
@ -47,18 +47,18 @@ Index: linux-2.6.21.1/arch/mips/Makefile
# Common Alchemy Au1x00 stuff
#
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
Index: linux-2.6.21.1/include/asm-mips/bootinfo.h
Index: linux-2.6.22-rc6/include/asm-mips/bootinfo.h
===================================================================
--- linux-2.6.21.1.orig/include/asm-mips/bootinfo.h
+++ linux-2.6.21.1/include/asm-mips/bootinfo.h
--- linux-2.6.22-rc6.orig/include/asm-mips/bootinfo.h
+++ linux-2.6.22-rc6/include/asm-mips/bootinfo.h
@@ -213,6 +213,57 @@
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
+/*
+ * Valid machtype for group ADMtek ADM5120
+ */
+#define MACH_GROUP_ADM5120 23
+#define MACH_GROUP_ADM5120 26
+#define MACH_ADM5120_UNKNOWN 0 /* Unknown board */
+#define MACH_ADM5120_WP54G_WRT 1 /* Compex WP54G-WRT */
+#define MACH_ADM5120_WP54G 2 /* Compex WP54G */
@ -107,5 +107,5 @@ Index: linux-2.6.21.1/include/asm-mips/bootinfo.h
+#define MACH_ADM5120_BR6104K 47 /* Edimax BR-6104K */
+
#define CL_SIZE COMMAND_LINE_SIZE
const char *get_system_type(void);

@ -1,8 +1,8 @@
Index: linux-2.6.21.1/drivers/mtd/maps/Kconfig
Index: linux-2.6.22-rc6/drivers/mtd/maps/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.21.1/drivers/mtd/maps/Kconfig
@@ -605,5 +605,10 @@ config MTD_PLATRAM
--- linux-2.6.22-rc6.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.22-rc6/drivers/mtd/maps/Kconfig
@@ -620,5 +620,10 @@ config MTD_PLATRAM
This selection automatically selects the map_ram driver.
@ -13,11 +13,11 @@ Index: linux-2.6.21.1/drivers/mtd/maps/Kconfig
+
endmenu
Index: linux-2.6.21.1/drivers/mtd/maps/Makefile
Index: linux-2.6.22-rc6/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.21.1/drivers/mtd/maps/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_OCELOT) += ocelot.o
--- linux-2.6.22-rc6.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.22-rc6/drivers/mtd/maps/Makefile
@@ -47,6 +47,7 @@ obj-$(CONFIG_MTD_OCELOT) += ocelot.o
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o

@ -1,7 +1,7 @@
Index: linux-2.6.21.1/drivers/net/Kconfig
Index: linux-2.6.22-rc6/drivers/net/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/net/Kconfig
+++ linux-2.6.21.1/drivers/net/Kconfig
--- linux-2.6.22-rc6.orig/drivers/net/Kconfig
+++ linux-2.6.22-rc6/drivers/net/Kconfig
@@ -574,6 +574,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@ -13,10 +13,10 @@ Index: linux-2.6.21.1/drivers/net/Kconfig
config NET_SB1250_MAC
tristate "SB1250 Ethernet support"
depends on NET_ETHERNET && SIBYTE_SB1xxx_SOC
Index: linux-2.6.21.1/drivers/net/Makefile
Index: linux-2.6.22-rc6/drivers/net/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/net/Makefile
+++ linux-2.6.21.1/drivers/net/Makefile
--- linux-2.6.22-rc6.orig/drivers/net/Makefile
+++ linux-2.6.22-rc6/drivers/net/Makefile
@@ -165,6 +165,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o

@ -1,7 +1,7 @@
Index: linux-2.6.21.1/drivers/serial/Makefile
Index: linux-2.6.22-rc6/drivers/serial/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/serial/Makefile
+++ linux-2.6.21.1/drivers/serial/Makefile
--- linux-2.6.22-rc6.orig/drivers/serial/Makefile
+++ linux-2.6.22-rc6/drivers/serial/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
@ -10,25 +10,25 @@ Index: linux-2.6.21.1/drivers/serial/Makefile
obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
Index: linux-2.6.21.1/include/linux/serial_core.h
Index: linux-2.6.22-rc6/include/linux/serial_core.h
===================================================================
--- linux-2.6.21.1.orig/include/linux/serial_core.h
+++ linux-2.6.21.1/include/linux/serial_core.h
@@ -135,6 +135,9 @@
/* Xilinx uartlite */
#define PORT_UARTLITE 74
--- linux-2.6.22-rc6.orig/include/linux/serial_core.h
+++ linux-2.6.22-rc6/include/linux/serial_core.h
@@ -143,6 +143,9 @@
#define PORT_KS8695 76
+/* ADMtek ADM5120 SoC */
+#define PORT_ADM5120 68
+#define PORT_ADM5120 77
+
#ifdef __KERNEL__
#include <linux/compiler.h>
Index: linux-2.6.21.1/drivers/serial/Kconfig
Index: linux-2.6.22-rc6/drivers/serial/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/serial/Kconfig
+++ linux-2.6.21.1/drivers/serial/Kconfig
@@ -256,6 +256,22 @@ config SERIAL_8250_AU1X00
--- linux-2.6.22-rc6.orig/drivers/serial/Kconfig
+++ linux-2.6.22-rc6/drivers/serial/Kconfig
@@ -270,6 +270,22 @@ config SERIAL_8250_RM9K
comment "Non-8250 serial port support"

@ -1,20 +1,191 @@
Index: linux-2.6.21.1/drivers/usb/core/hub.c
Index: linux-2.6.22-rc6/drivers/usb/core/hub.c
===================================================================
--- linux-2.6.21.1.orig/drivers/usb/core/hub.c
+++ linux-2.6.21.1/drivers/usb/core/hub.c
@@ -2227,6 +2227,8 @@ hub_port_init (struct usb_hub *hub, stru
--- linux-2.6.22-rc6.orig/drivers/usb/core/hub.c
+++ linux-2.6.22-rc6/drivers/usb/core/hub.c
@@ -464,7 +464,7 @@ void usb_hub_tt_clear_buffer (struct usb
: (USB_ENDPOINT_XFER_BULK << 11);
if (usb_pipein (pipe))
clear->devinfo |= 1 << 15;
-
+
/* tell keventd to clear state for this TT */
spin_lock_irqsave (&tt->lock, flags);
list_add_tail (&clear->clear_list, &tt->clear_list);
@@ -540,7 +540,7 @@ static int hub_hub_status(struct usb_hub
"%s failed (err = %d)\n", __FUNCTION__, ret);
else {
*status = le16_to_cpu(hub->status->hub.wHubStatus);
- *change = le16_to_cpu(hub->status->hub.wHubChange);
+ *change = le16_to_cpu(hub->status->hub.wHubChange);
ret = 0;
}
mutex_unlock(&hub->status_mutex);
@@ -1424,7 +1424,7 @@ static int hub_port_status(struct usb_hu
ret = -EIO;
} else {
*status = le16_to_cpu(hub->status->port.wPortStatus);
- *change = le16_to_cpu(hub->status->port.wPortChange);
+ *change = le16_to_cpu(hub->status->port.wPortChange);
ret = 0;
}
mutex_unlock(&hub->status_mutex);
@@ -2007,7 +2007,7 @@ static inline int remote_wakeup(struct u
* Between connect detection and reset signaling there must be a delay
* of 100ms at least for debounce and power-settling. The corresponding
* timer shall restart whenever the downstream port detects a disconnect.
- *
+ *
* Apparently there are some bluetooth and irda-dongles and a number of
* low-speed devices for which this debounce period may last over a second.
* Not covered by the spec - but easy to deal with.
@@ -2142,7 +2142,7 @@ hub_port_init (struct usb_hub *hub, stru
goto fail;
}
oldspeed = udev->speed;
-
+
/* USB 2.0 section 5.5.3 talks about ep0 maxpacket ...
* it's fixed size except for full speed devices.
* For Wireless USB devices, ep0 max packet is always 512 (tho
@@ -2168,7 +2168,7 @@ hub_port_init (struct usb_hub *hub, stru
default:
goto fail;
}
-
+
type = "";
switch (udev->speed) {
case USB_SPEED_LOW: speed = "low"; break;
@@ -2194,7 +2194,7 @@ hub_port_init (struct usb_hub *hub, stru
udev->tt = &hub->tt;
udev->ttport = port1;
}
-
+
/* Why interleave GET_DESCRIPTOR and SET_ADDRESS this way?
* Because device hardware and firmware is sometimes buggy in
* this area, and this is how Linux has done it for ages.
@@ -2230,6 +2230,8 @@ hub_port_init (struct usb_hub *hub, stru
USB_DT_DEVICE << 8, 0,
buf, GET_DESCRIPTOR_BUFSIZE,
(i ? USB_CTRL_GET_TIMEOUT : 1000));
USB_CTRL_GET_TIMEOUT);
+printk(KERN_CRIT "usb_control_msg: %d %d %d (%d)\n", r, buf->bMaxPacketSize0,
+buf->bDescriptorType, USB_DT_DEVICE);
switch (buf->bMaxPacketSize0) {
case 8: case 16: case 32: case 64: case 255:
if (buf->bDescriptorType ==
Index: linux-2.6.21.1/drivers/usb/host/Kconfig
@@ -2281,7 +2283,7 @@ hub_port_init (struct usb_hub *hub, stru
udev->devnum, retval);
goto fail;
}
-
+
/* cope with hardware quirkiness:
* - let SET_ADDRESS settle, some device hardware wants it
* - read ep0 maxpacket even for high and low speed,
@@ -2318,7 +2320,7 @@ hub_port_init (struct usb_hub *hub, stru
udev->ep0.desc.wMaxPacketSize = cpu_to_le16(i);
ep0_reinit(udev);
}
-
+
retval = usb_get_device_descriptor(udev, USB_DT_DEVICE_SIZE);
if (retval < (signed)sizeof(udev->descriptor)) {
dev_err(&udev->dev, "device descriptor read/%s, error %d\n",
@@ -2416,7 +2418,7 @@ static void hub_port_connect_change(stru
struct device *hub_dev = hub->intfdev;
u16 wHubCharacteristics = le16_to_cpu(hub->descriptor->wHubCharacteristics);
int status, i;
-
+
dev_dbg (hub_dev,
"port %d, status %04x, change %04x, %s\n",
port1, portstatus, portchange, portspeed (portstatus));
@@ -2425,7 +2427,7 @@ static void hub_port_connect_change(stru
set_port_led(hub, port1, HUB_LED_AUTO);
hub->indicator[port1-1] = INDICATOR_AUTO;
}
-
+
/* Disconnect any existing devices under this port */
if (hdev->children[port1-1])
usb_disconnect(&hdev->children[port1-1]);
@@ -2455,7 +2457,7 @@ static void hub_port_connect_change(stru
if ((wHubCharacteristics & HUB_CHAR_LPSM) < 2
&& !(portstatus & (1 << USB_PORT_FEAT_POWER)))
set_port_feature(hdev, port1, USB_PORT_FEAT_POWER);
-
+
if (portstatus & USB_PORT_STAT_ENABLE)
goto done;
return;
@@ -2535,7 +2537,7 @@ static void hub_port_connect_change(stru
goto loop_disable;
}
}
-
+
/* check for devices running slower than they could */
if (le16_to_cpu(udev->descriptor.bcdUSB) >= 0x0200
&& udev->speed == USB_SPEED_FULL
@@ -2587,7 +2589,7 @@ loop:
if (status == -ENOTCONN)
break;
}
-
+
done:
hub_port_disable(hub, port1, 1);
}
@@ -2720,7 +2722,7 @@ static void hub_events(void)
* EM interference sometimes causes badly
* shielded USB devices to be shutdown by
* the hub, this hack enables them again.
- * Works at least with mouse driver.
+ * Works at least with mouse driver.
*/
if (!(portstatus & USB_PORT_STAT_ENABLE)
&& !connect_change
@@ -2750,7 +2752,7 @@ static void hub_events(void)
"resume on port %d, status %d\n",
i, ret);
}
-
+
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
dev_err (hub_dev,
"over-current change on port %d\n",
@@ -2985,7 +2987,7 @@ int usb_reset_device(struct usb_device *
if (ret < 0)
goto re_enumerate;
-
+
/* Device might have changed firmware (DFU or similar) */
if (memcmp(&udev->descriptor, &descriptor, sizeof descriptor)
|| config_descriptors_changed (udev)) {
@@ -2993,7 +2995,7 @@ int usb_reset_device(struct usb_device *
udev->descriptor = descriptor; /* for disconnect() calls */
goto re_enumerate;
}
-
+
if (!udev->actconfig)
goto done;
@@ -3031,7 +3033,7 @@ int usb_reset_device(struct usb_device *
done:
return 0;
-
+
re_enumerate:
hub_port_logical_disconnect(parent_hub, port1);
return -ENODEV;
Index: linux-2.6.22-rc6/drivers/usb/host/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/usb/host/Kconfig
+++ linux-2.6.21.1/drivers/usb/host/Kconfig
--- linux-2.6.22-rc6.orig/drivers/usb/host/Kconfig
+++ linux-2.6.22-rc6/drivers/usb/host/Kconfig
@@ -224,3 +224,6 @@ config USB_SL811_CS
To compile this driver as a module, choose M here: the
module will be called "sl811_cs".
@ -22,35 +193,38 @@ Index: linux-2.6.21.1/drivers/usb/host/Kconfig
+config USB_ADM5120_HCD
+ tristate "ADM5120 HCD support"
+ depends on USB && MIPS_ADM5120
Index: linux-2.6.21.1/drivers/usb/host/Makefile
Index: linux-2.6.22-rc6/drivers/usb/host/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/usb/host/Makefile
+++ linux-2.6.21.1/drivers/usb/host/Makefile
@@ -16,3 +16,4 @@ obj-$(CONFIG_USB_SL811_HCD) += sl811-hcd
obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
obj-$(CONFIG_USB_U132_HCD) += u132-hcd.o
obj-$(CONFIG_ETRAX_ARCH_V10) += hc_crisv10.o
--- linux-2.6.22-rc6.orig/drivers/usb/host/Makefile
+++ linux-2.6.22-rc6/drivers/usb/host/Makefile
@@ -8,6 +8,7 @@ endif
obj-$(CONFIG_PCI) += pci-quirks.o
+obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
Index: linux-2.6.21.1/drivers/usb/Kconfig
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
Index: linux-2.6.22-rc6/drivers/usb/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/usb/Kconfig
+++ linux-2.6.21.1/drivers/usb/Kconfig
@@ -91,8 +91,6 @@ source "drivers/usb/image/Kconfig"
--- linux-2.6.22-rc6.orig/drivers/usb/Kconfig
+++ linux-2.6.22-rc6/drivers/usb/Kconfig
@@ -88,8 +88,6 @@ source "drivers/usb/storage/Kconfig"
source "drivers/usb/net/Kconfig"
source "drivers/usb/image/Kconfig"
-source "drivers/usb/mon/Kconfig"
-
comment "USB port drivers"
depends on USB
Index: linux-2.6.21.1/drivers/usb/Makefile
Index: linux-2.6.22-rc6/drivers/usb/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/usb/Makefile
+++ linux-2.6.21.1/drivers/usb/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_USB_SL811_HCD) += host/
--- linux-2.6.22-rc6.orig/drivers/usb/Makefile
+++ linux-2.6.22-rc6/drivers/usb/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_ETRAX_USB_HOST) += host/
obj-$(CONFIG_USB_OHCI_AT91) += host/
+obj-$(CONFIG_USB_ADM5120_HCD) += host/

@ -1,8 +1,8 @@
Index: linux-2.6.21.1/drivers/leds/Kconfig
Index: linux-2.6.22-rc6/drivers/leds/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/leds/Kconfig
+++ linux-2.6.21.1/drivers/leds/Kconfig
@@ -19,6 +19,27 @@ config LEDS_CLASS
--- linux-2.6.22-rc6.orig/drivers/leds/Kconfig
+++ linux-2.6.22-rc6/drivers/leds/Kconfig
@@ -20,6 +20,27 @@ config LEDS_CLASS
comment "LED drivers"
@ -30,10 +30,10 @@ Index: linux-2.6.21.1/drivers/leds/Kconfig
config LEDS_CORGI
tristate "LED Support for the Sharp SL-C7x0 series"
depends on LEDS_CLASS && PXA_SHARP_C7xx
Index: linux-2.6.21.1/drivers/leds/Makefile
Index: linux-2.6.22-rc6/drivers/leds/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/leds/Makefile
+++ linux-2.6.21.1/drivers/leds/Makefile
--- linux-2.6.22-rc6.orig/drivers/leds/Makefile
+++ linux-2.6.22-rc6/drivers/leds/Makefile
@@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o

@ -1,17 +1,17 @@
Index: linux-2.6.21.1/arch/mips/pci/Makefile
Index: linux-2.6.22-rc6/arch/mips/pci/Makefile
===================================================================
--- linux-2.6.21.1.orig/arch/mips/pci/Makefile
+++ linux-2.6.21.1/arch/mips/pci/Makefile
@@ -53,3 +53,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
--- linux-2.6.22-rc6.orig/arch/mips/pci/Makefile
+++ linux-2.6.22-rc6/arch/mips/pci/Makefile
@@ -50,3 +50,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += fixup-adm5120.o ops-adm5120.o pci-adm5120.o
Index: linux-2.6.21.1/include/linux/pci_ids.h
Index: linux-2.6.22-rc6/include/linux/pci_ids.h
===================================================================
--- linux-2.6.21.1.orig/include/linux/pci_ids.h
+++ linux-2.6.21.1/include/linux/pci_ids.h
@@ -1701,6 +1701,9 @@
--- linux-2.6.22-rc6.orig/include/linux/pci_ids.h
+++ linux-2.6.22-rc6/include/linux/pci_ids.h
@@ -1712,6 +1712,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111

@ -1,6 +1,8 @@
--- linux-2.6.19.2/include/asm-mips/byteorder.h 2007-01-10 20:10:37.000000000 +0100
+++ linux-2.6.19.2.new/include/asm-mips/byteorder.h 2007-05-16 21:14:47.000000000 +0200
@@ -58,6 +58,35 @@
Index: linux-2.6.22-rc6/include/asm-mips/byteorder.h
===================================================================
--- linux-2.6.22-rc6.orig/include/asm-mips/byteorder.h
+++ linux-2.6.22-rc6/include/asm-mips/byteorder.h
@@ -58,6 +58,35 @@ static __inline__ __attribute_const__ __
#endif /* CONFIG_CPU_MIPSR2 */

@ -1,8 +1,8 @@
Index: linux-2.6.21.1/drivers/mtd/Kconfig
Index: linux-2.6.22-rc6/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/Kconfig
+++ linux-2.6.21.1/drivers/mtd/Kconfig
@@ -157,6 +157,22 @@ config MTD_AFS_PARTS
--- linux-2.6.22-rc6.orig/drivers/mtd/Kconfig
+++ linux-2.6.22-rc6/drivers/mtd/Kconfig
@@ -155,6 +155,22 @@ config MTD_AFS_PARTS
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@ -23,13 +23,13 @@ Index: linux-2.6.21.1/drivers/mtd/Kconfig
+ for your particular device. It won't happen automatically.
+
comment "User Modules And Translation Layers"
depends on MTD
Index: linux-2.6.21.1/drivers/mtd/Makefile
config MTD_CHAR
Index: linux-2.6.22-rc6/drivers/mtd/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/Makefile
+++ linux-2.6.21.1/drivers/mtd/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
--- linux-2.6.22-rc6.orig/drivers/mtd/Makefile
+++ linux-2.6.22-rc6/drivers/mtd/Makefile
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o

@ -1,7 +1,7 @@
Index: linux-2.6.21.1/drivers/mtd/chips/cfi_cmdset_0002.c
Index: linux-2.6.22-rc6/drivers/mtd/chips/cfi_cmdset_0002.c
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/chips/cfi_cmdset_0002.c
+++ linux-2.6.21.1/drivers/mtd/chips/cfi_cmdset_0002.c
--- linux-2.6.22-rc6.orig/drivers/mtd/chips/cfi_cmdset_0002.c
+++ linux-2.6.22-rc6/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -47,12 +47,17 @@
#define MANUFACTURER_AMD 0x0001
#define MANUFACTURER_ATMEL 0x001F
@ -66,11 +66,11 @@ Index: linux-2.6.21.1/drivers/mtd/chips/cfi_cmdset_0002.c
{ 0, 0, NULL, NULL }
};
static struct cfi_fixup jedec_fixup_table[] = {
Index: linux-2.6.21.1/drivers/mtd/chips/Kconfig
Index: linux-2.6.22-rc6/drivers/mtd/chips/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/chips/Kconfig
+++ linux-2.6.21.1/drivers/mtd/chips/Kconfig
@@ -199,6 +199,14 @@ config MTD_CFI_AMDSTD
--- linux-2.6.22-rc6.orig/drivers/mtd/chips/Kconfig
+++ linux-2.6.22-rc6/drivers/mtd/chips/Kconfig
@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
provides support for one of those command sets, used on chips
including the AMD Am29LV320.

@ -1,7 +1,7 @@
Index: linux-2.6.21.1/arch/mips/kernel/head.S
Index: linux-2.6.22-rc6/arch/mips/kernel/head.S
===================================================================
--- linux-2.6.21.1.orig/arch/mips/kernel/head.S
+++ linux-2.6.21.1/arch/mips/kernel/head.S
--- linux-2.6.22-rc6.orig/arch/mips/kernel/head.S
+++ linux-2.6.22-rc6/arch/mips/kernel/head.S
@@ -129,14 +129,19 @@
#endif
.endm

@ -1,8 +1,8 @@
Index: linux-2.6.21.1/drivers/mtd/nand/Kconfig
Index: linux-2.6.22-rc6/drivers/mtd/nand/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/nand/Kconfig
+++ linux-2.6.21.1/drivers/mtd/nand/Kconfig
@@ -75,6 +75,12 @@ config MTD_NAND_TS7250
--- linux-2.6.22-rc6.orig/drivers/mtd/nand/Kconfig
+++ linux-2.6.22-rc6/drivers/mtd/nand/Kconfig
@@ -81,6 +81,12 @@ config MTD_NAND_TS7250
help
Support for NAND flash on Technologic Systems TS-7250 platform.
@ -15,10 +15,10 @@ Index: linux-2.6.21.1/drivers/mtd/nand/Kconfig
config MTD_NAND_IDS
tristate
Index: linux-2.6.21.1/drivers/mtd/nand/Makefile
Index: linux-2.6.22-rc6/drivers/mtd/nand/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/nand/Makefile
+++ linux-2.6.21.1/drivers/mtd/nand/Makefile
--- linux-2.6.22-rc6.orig/drivers/mtd/nand/Makefile
+++ linux-2.6.22-rc6/drivers/mtd/nand/Makefile
@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o

@ -11,7 +11,7 @@ BOARD:=adm5120eb
BOARDNAME:=ADM5120 (Big Endian)
FEATURES:=squashfs pci usb
LINUX_VERSION:=2.6.21.5
LINUX_VERSION:=2.6.22-rc6
define Target/Description
Build firmware images for Infineon/ADMTek ADM5120 based boards running in big-endian mode

@ -5,6 +5,8 @@ CONFIG_ADM5120_HARDWARE_SWAB=y
CONFIG_ADM5120_NR_UARTS=2
# CONFIG_ARCH_HAS_ILOG2_U32 is not set
# CONFIG_ARCH_HAS_ILOG2_U64 is not set
# CONFIG_ARCH_SUPPORTS_MSI is not set
# CONFIG_ATM_DRIVERS is not set
CONFIG_BASE_SMALL=0
CONFIG_BAYCOM_SER_FDX=m
CONFIG_BAYCOM_SER_HDX=m
@ -46,6 +48,7 @@ CONFIG_CPU_SUPPORTS_HIGHMEM=y
# CONFIG_CPU_VR41XX is not set
CONFIG_CRYPTO_SHA1=y
# CONFIG_DDB5477 is not set
CONFIG_DEVPORT=y
# CONFIG_DM9000 is not set
CONFIG_DMA_NEED_PCI_MAP_STATE=y
CONFIG_DMA_NONCOHERENT=y
@ -60,6 +63,7 @@ CONFIG_GENERIC_FIND_NEXT_BIT=y
CONFIG_GENERIC_GPIO=y
# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
# CONFIG_GEN_RTC is not set
CONFIG_HAS_DMA=y
CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT=y
CONFIG_HID=m
@ -100,6 +104,7 @@ CONFIG_LEDS_ADM5120_DIAG=y
CONFIG_LEDS_GPIO=y
CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=256
# CONFIG_MACH_ALCHEMY is not set
# CONFIG_MACH_DECSTATION is not set
# CONFIG_MACH_JAZZ is not set
# CONFIG_MACH_VR41XX is not set
@ -109,36 +114,20 @@ CONFIG_MIPS=y
CONFIG_MIPS_ADM5120=y
CONFIG_MIPS_ADM5120_ENET=y
# CONFIG_MIPS_ATLAS is not set
# CONFIG_MIPS_BOSPORUS is not set
# CONFIG_MIPS_COBALT is not set
# CONFIG_MIPS_DB1000 is not set
# CONFIG_MIPS_DB1100 is not set
# CONFIG_MIPS_DB1200 is not set
# CONFIG_MIPS_DB1500 is not set
# CONFIG_MIPS_DB1550 is not set
# CONFIG_MIPS_EV64120 is not set
CONFIG_MIPS_L1_CACHE_SHIFT=5
# CONFIG_MIPS_MALTA is not set
# CONFIG_MIPS_MIRAGE is not set
# CONFIG_MIPS_MTX1 is not set
CONFIG_MIPS_MT_DISABLED=y
# CONFIG_MIPS_MT_SMP is not set
# CONFIG_MIPS_MT_SMTC is not set
# CONFIG_MIPS_PB1000 is not set
# CONFIG_MIPS_PB1100 is not set
# CONFIG_MIPS_PB1200 is not set
# CONFIG_MIPS_PB1500 is not set
# CONFIG_MIPS_PB1550 is not set
# CONFIG_MIPS_SEAD is not set
# CONFIG_MIPS_SIM is not set
# CONFIG_MIPS_VPE_LOADER is not set
# CONFIG_MIPS_XXS1500 is not set
CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_MOMENCO_JAGUAR_ATX is not set
# CONFIG_MOMENCO_OCELOT is not set
# CONFIG_MOMENCO_OCELOT_3 is not set
# CONFIG_MOMENCO_OCELOT_C is not set
# CONFIG_MOMENCO_OCELOT_G is not set
CONFIG_MTD=y
# CONFIG_MTD_ABSENT is not set
# CONFIG_MTD_ADM5120 is not set
@ -174,7 +163,6 @@ CONFIG_MTD_MAP_BANK_WIDTH_4=y
# CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
# CONFIG_MTD_MTDRAM is not set
# CONFIG_MTD_MYLOADER_PARTS is not set
# CONFIG_MTD_OBSOLETE_CHIPS is not set
# CONFIG_MTD_ONENAND is not set
CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_PCI is not set
@ -189,6 +177,7 @@ CONFIG_MTD_PHYSMAP_START=0x1fc00000
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_ROM is not set
# CONFIG_MTD_SLRAM is not set
CONFIG_NETDEV_1000=y
CONFIG_NET_KEY=y
# CONFIG_NET_PCI is not set
# CONFIG_NET_PKTGEN is not set
@ -209,6 +198,7 @@ CONFIG_PCI_ADM5120=y
# CONFIG_RTC is not set
CONFIG_RWSEM_GENERIC_SPINLOCK=y
CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
CONFIG_SCSI_WAIT_SCAN=m
# CONFIG_SERIAL_8250 is not set
CONFIG_SERIAL_ADM5120=y
CONFIG_SERIO=y
@ -252,7 +242,6 @@ CONFIG_USB_ADM5120_HCD=y
# CONFIG_USB_CATC is not set
# CONFIG_USB_DEVICEFS is not set
# CONFIG_USB_EHCI_HCD is not set
# CONFIG_USB_GTCO is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_PRINTER is not set
@ -263,5 +252,7 @@ CONFIG_USB_ADM5120_HCD=y
# CONFIG_USB_USBNET is not set
# CONFIG_USB_USBNET_MII is not set
# CONFIG_USB_ZD1201 is not set
# CONFIG_VGASTATE is not set
CONFIG_VM_EVENT_COUNTERS=y
# CONFIG_ZD1211RW is not set
CONFIG_ZONE_DMA_FLAG=0

Loading…
Cancel
Save